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Introduction 

Welcome to 

Strata Live 3D 

 Introduction 

Strata Live 3D™ is a powerful real‐time 3D application for creating 
content for the web, Flash and PDF. Strata Live 3D creates high quality 
content perfect for marketing projects, online catalogs, training manuals, 
design presentations and more (collectively referred to as “Product 
Tours“). This User Guide is designed to help get you on your feet as 
quickly as possible. 

Strata Live 3D is designed to work with 3D content from a variety of 
sources such as CAD data and design files from other 3D applications. 
Strata Live 3D is not a modeling application so youʹll want to have access 
to model files from another source or (ideally) youʹll want to have a full 
modeling companion application such as Strata 3D CX™, 3D Studio 
Max™ or Maya™ – among others. 

Once the model data is imported into Strata Live 3D you can add 
animation, adjust surface materials, set compression levels, make 
decisions about the interactive interface and more. The projects created in 
Strata Live 3D are saved as Master Models™, in XMM format. This 
format is open and directly editable, which allows complex changes to be 
made to the model, giving you the power to go beyond the features 
directly editable in Strata Live 3D. 

Of course, the perfect companion products for Strata Live 3D are Strata 
3D CX and Strata Foto 3D™. Strata 3D CX is a powerful modeling, 
texturing and animation application. Strata Foto 3D provides the ability 
to create 3D models directly from photographs, which are ideal for 
creating interactive 3D online product catalogs – for example. Whatever 
your companion products of choice are, Strata Live 3D will add 
interactivity to your 3D world. 

1 
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Java™ Power 
Strata Live 3D is written in the Java programming language. In addition 
to the Live 3D authoring application, the players themselves are Java 
“applets” or JAR files (Java Archives). This commitment to Java provides 
a tremendous amount of power to the entire Strata Live 3D system. Both 
the application and player are platform independent. When people want 
to view the content youʹve created using Strata Live 3D there is no plug‐
in required. This means that web content, for example, can be opened by 
virtually any visitor using any browser. 

One of the side effects of this ubiquitous commitment to Java is that Strata 
Live 3D uses Java standards when it comes to application look and feel. 
You may notice differences in how windows and palettes are displayed 
and managed. Though this may be non‐standard for the operating system 
you use, it means that the content will be fully independent of current 
and future platform restrictions. 

More About the Master Model format and XML 
Product Tours are a collection of elements, but the heart of the project is 
the Master Model file format. This format includes a rich set of 
information about the 3D file. This file format can be edited in a text 
editor or directly from within the Strata Live 3D interface. The core of the 
Master Model is based on the XML format standard. This standard opens 
up many possibilities for power users to who want to create very complex 
projects. 

In this User Guide you’ll often see the term Master Model and the file 
extension “XMM” (which represents the combination of “Master Model” 
and “XML”). These references are meant to remind you of the 
opportunities you will have to further edit your Strata Live 3D models to 
tweak them into the perfect Product Tour presentation. 

The Meson™ Programming Language 
More advanced features, such as 3D hotspots with pop‐up text, or even 
changing the appearance of a Product Tour, can be added using the 
Meson programming language.  

“Meson” is the name of a suite of connected technologies which allow 
interactive applications with both 2D and 3D elements to be developed 
quickly, and with a very small execution footprint. Like “Java” the name 
denotes a language, an object model of predefined classes, and a runtime 
execution environment. 
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About this User Guide 
This User Guide is laid out to enhance your ability to learn the software 
quickly. It’s designed to allow you to read from front to back, or to pick 
and choose areas to cover, similar to a reference manual. Because of this 
design philosophy, you may notice some redundancies in explanations of 
terms, how to access a menu in order to locate a particular feature, etc. 
This design is meant to allow you to skip ahead if you like, without 
getting lost. 

This User Guide is organized into five chapters with each taking a slightly 
different approach to help you get familiar with the software. 

Chapter 1 – Welcome to Strata Live 3D 
This chapter (the one you’re reading now) provides an overview of Strata 
Live 3D and this User Guide. 

Chapter 2 – Getting Started 
This chapter covers installing and getting acquainted with the software, 
as well as a very simple tutorial to get you up on your feet and quickly 
creating content. By the end of this short chapter you’ll be looking at your 
first interactive 3D content in a web browser that you’ve created using 
Strata Live 3D. 

Chapter 3 – The Workspace 
This chapter takes you through the interface in a logical, step‐by‐step 
process. This approach is meant to get you familiar with all the functions 
available in Strata Live 3D. 

Chapter 4 – The Workflow 
This chapter takes the approach of walking you through the logic of how 
you might approach a project – starting with getting your model into the 
software and ending with export options. 

Chapter 5 – Live 3D Tutorials 
These tutorials go into much greater detail about the process of creating 
interactive content than the simple tutorial in Chapter 2. 

Appendix
The Appendix contains information about getting Strata support and 
some helpful information about how to solve problems you may 
encounter. Also included is a Glossary of terms and the Index.  
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Live 3D Feature Overview 
• Imports VRML, DWF, and WIRE formatted files 
• Automatically extracts geometry, appearance, and animation 
• Edit hierarchy and object names 
• Copy/Paste sections of the hierarchy 
• Copy/Paste parts between different models 
• Export meshes to VRML for editing in other tools 
• Scale, rotate, and move mesh data 
• Adjust positions, orientation, and pivot points of objects 
• Insert flexible wires, cables, straps and sheets, using dynamic 

Elliptical Hermite Lofts 
• Adjust scene lighting and orientation 
• Create new range‐of‐motion animations 
• Create material swaps (for texture or color changes) 
• Create color curve animations 
• Create object and material fade animations 
• Edit material properties: color, texture, lighting 
• Edit mesh smoothing groups 
• Set up initial object position, zoom and rotate limits, etc. 
• Graphically create animation scripts moving multiple parts, camera 

view, scene orientation, and lighting 
• Easily specify conditional relationships between scripts, to create 

robust simulations 
• Automatically select texture and geometry compression parameters 
• Preview web compression and streaming prior to export 
• Handles models with hundreds of megabytes of texture 
• Handles models with millions of polygons 
• Optimizer automatically reduces polygon count, under user control 
• Optimizer automatically eliminates unneeded hierarchy 
• Easily edit underlying XML representation of Master Model 
• Create and edit meta‐data associated with the model 
• Export animated models to plug‐in‐free Web 3D 
• Export animated models to plug‐in‐free PowerPoint 



STRATA LIVE 3D User Guide – Chapter 1 
Introduction 

5 

• Export animated models to plug‐in‐free Flash + 3D 
• Export animated models to plug‐in‐free 3D PDF 
• Available for both Windows & Mac 

3D PDF Capabilities 
• 3D PDF requires no special plug‐ins: works in Adobe® Reader 7 or 

later 
• Generate 3D PDF directly from Strata Live 3D, no Acrobat® required 
• Edit generated 3D PDFʹs using Illustrator® CS2 or Acrobat 
• Insert animated 3D models in any PDF using Acrobat Pro® 7 or 

Acrobat 3D® 
• Automatically includes all animation behavior: no Javascripting™ 

required 
• Automatically includes easy‐to‐use interactive Navigation Bar  
• Automatically includes unique “Measure” feature 
• Automatically compresses all texture to ensure best performance on 

all hardware 
• Uses proprietary optimization to produce far smaller PDF files 

(typically 50‐70% smaller than other tools) 
• Most robust U3D compressor in the industry – easily handles models 

that crash other tools 
• Only solution that supports enhanced, dynamic lighting models not 

found in U3D 
• Only solution that supports real‐time texture and color swaps 

Web 3D Capabilities 
• Strata Live 3D viewer requires no special plug‐ins: relies on Java 1.1 

(circa 1997) or later 
• Strata Live 3D “just works” on more than 90% of computers 

(Windows, Mac, Linux, Solaris, etc...) 
• Uses sophisticated Meson Platform for rich 2D interfaces and 

dynamic 3D scenes 
• Comprehensive optimization produces the smallest files in the 

industry 
• All HTML generated completely automatically 
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Web viewer 3D capabilities: 
• Dedkov compression produces the smallest 3D models across the 

largest range of model types (from photo‐real high‐texture models, to 
untextured scanned models) 

• JPEG, GIF, and Wavelet‐streaming textures 
• Dynamic textures can be generated by a Meson program: 

o To embed 3D scenes onto texture in 3D scenes (for 
example, to show a moving scene on a camcorder modelʹs 
view screen) 

o To use rendered text in the 3D scene (for example, to 
simulate the menu system of a mobile phone) 

• Real‐time, dynamically generated shadows 
• Perspective‐correct, bi‐linear filtered textures of unlimited 

dimensions 
• MIP‐map‐style continuous texture anti‐aliasing 
• 32‐bit ARGB, 16‐ and 12‐bit YCrCb, and 8‐bit Y (constant CrCb) 

texture pixel formats, with optional error‐diffusion dither 
• Photoshop‐compatible color curves applied to texture images in real 

time 
• Real‐time edge anti‐aliasing 
• Stable‐scene 256x over‐sample progressive anti‐aliasing 
• Perspective‐correct Phong shader with no performance penalty 
• Specular highlights and chrome shading model (to convey shininess 

without the need for cumbersome reflection maps) 
• Dynamically‐generated flexible objects (elliptical hermite lofts), for 

modeling wires, ribbon cables, straps, paper, etc. 
• Illustration rendering mode automatically turns 3D models into 

“sketches.” Support for both line drawing over realistic shading, and 
line drawing over flat color 

• Reuse the animated Master Model in 3D PDF, on the web, in 
PowerPoint and for Flash integration 

Web viewer 2D capabilities: 
• Alpha channel compositing of an arbitrary numbers of layers 
• Smooth animation of any attribute (such as alpha, or position) 
• Hot areas, including pickable pixels, and rectangular areas 
• Mouse cursor control 
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• Context (right click) menu 
• Unicode support for multi‐lingual applications 
• Anti‐aliasing text engine with CSS‐like font control, drop shadow 

generation, and internationalized word‐wrapping capability 
• Multi‐state images and text (for mouse‐over or push‐button effects, 

for example) 
• Separate images for color/alpha information (for example, to use a 

JPEG image for color, and a grayscale GIF for the alpha channel) 
• Image tiling (primarily for repeating backgrounds) 
• Rotation, scale, skew, bilinear‐filtering, and over‐sampling of any 2D 

element, including rendered text or even the rendered 3D scene 
• Wavelet‐streaming encoded images 
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Getting Started 

2.1 Installation and Setup 

Installing Strata Live 3D is very straight forward and similar to software 
installations you may have done in the past. 

System Requirements 
Strata Live 3D can be installed on Windows 2000, Windows XP or Mac 
OS X operating systems.  

Like any 3D program, this software is CPU, memory and graphics 
intensive. The following minimum configuration is provided; however 
complex models and textures may demand greater system capacity to run 
efficiently. If you experience sluggish response with larger models and 
textures, consider upgrading your system. 

Minimum system configuration: 

Windows 
• Processor: Intel Pentium or Celeron, AMD Athlon, and equivalents at 

1GHz of faster.  
• Memory: 512Mb, 1Gb highly recommended.  
• Video: 64Mb, DirectX9c compatible. 800 x 600 resolution or better. 
• Hard Drive: 45Mb free space for the program files. 

Mac OS X 
• Power Macintosh with Mac OS X 10.3 or higher 
• Memory: 256 MB RAM 
• Video: Support for resolutions above 800 x 600 

9 



STRATA LIVE 3D User Guide – Chapter 2 
Getting Started 

10 

• Hard drive: 45 mb of free space for installation 

Installation 
Installation should be run within an account that has Administrator or 
Power User privileges. 

Simply run the Installer program and follow the instructions. The first 
time you run Strata Live 3D you’ll be asked to enter the Serial Number 
you received with your purchase. 

2.2 A Tutorial for Creating Your First 3D Content 

This tutorial will guide you through creating your first 3D content and 
trying out the basic features of Live 3D. The tutorial utilizes a model 
that was created using Strata Foto 3D by taking digital photographs of a 
child’s toy dinosaur. 

Step 1: Launch the Application 
When you launch Live 3D, three of the available ten windows, or 
“palettes” as they’re called in Strata Live 3D, are opened. These palettes 
include the main palette displaying the Strata Live 3D name; the Info 
palette; and the 3D View palette. 

Step 2: Import the 3D Model 
This project will utilize a VRML file named “Saber Dino”. To bring a 
VRML file into Live 3D go to the File menu and select Import > VRML 2. 
You’ll note that the menu bar can be found at the top of the main Strata 
Live 3D palette. 

When you select the File > Import > VRML 2 command, the Open dialog 
appears. The dialog, like all interface elements in Strata Live 3D, is a Java 
standards based dialog, and may appear different than standard 
Windows or Mac dialogs.  

Navigate to the Tutorial Files folder which can be found in the Strata 
Live 3D application folder on your hard drive. On Windows this will be 
located on your main C drive, in the Programs folder, then the Strata 
folder, and then the Strata Live 3D folder (C:\Program 
Files\Strata\Strata Live 3D\Tutorial Files). For Mac users, look in the 
Applications folder on your main hard drive, then the Strata Live 3D 
folder (Hard Drive/Applications/Strata Live 3D/Tutorial Files). Select 
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the file Saber Dino.wrl (.wrl is the file identifier for VRML files). Now 
click on the “Open” button. 

Step 3: Explore the Navigation Bar Interface 
Let’s have a look at the model. Go to the 3D View palette. Click and 
drag the Saber Dino. You’ll see that as you drag the model rotates. Now 
click on the “Move” icon in the Navigation Bar at the bottom of the 3D 
View palette. You see the Move icon becomes the selected tool. Now 
when you click and drag the model moves in the view pane. Next, click 
on the Zoom icon. You’ll note that if you click on the right side of the 
Zoom icon (on the +) the view will get closer to the Dino. You can also 
drag the Zoom slider to zoom in and out. Now click on the Measure icon 
and use the Measure tool to see how long the Dino is by clicking on his 
nose and drag to his tail. He’s too big to mess with, that’s for sure. Now 
click on the Reset icon. Saber Dino is back where we started. 

Step 4: Enhance the 3D View 
Though the Saber Dino looked pretty good as you were rotating and 
moving him, we can do a couple of things to make him look more realistic 
while working inside Strata Live 3D. Go to the View menu and select 
Solid Background (View > Solid Background). Now you should have a 
white background behind the Saber Dino. The previous checkerboard 
background indicated transparency. 

11 
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Now try rotating the Dino around. We’re getting a better view of him, but 
there’s one more, easy to do step that will jump the realism up. Go back 
to the View menu and select Shadow (View > Shadow). Now when you 
rotate him around you’ll see that there’s a simple drop shadow under 
him. This helps to visually ground the model and gives a greater sense of 
dimensionality. 

Step 5: Output Your 3D Web Tour 
Now we’ll output a simple file for viewing in web browsers. This is as 
easy as selecting Export > Web Tour > Study Scene from Outside. 
This will create an object that you can rotate and move within your 
default web browser. 

When you select the above Export command, you will be presented with 
the “Save” dialog. You may want to save the model into its own folder 
because exported web tours contain several support files. Choose a name 
for this file (SaberDino would be fine) and click on the “Save” button. 
You’ll note that the name we’ve suggested (SaberDino) does not contain a 
space or any special characters. Strata Live 3D knows that web browsers 
don’t like files with names containing spaces and/or special characters – 
try it and Live 3D will bark at you! 

Step 6: Test Out the Model in Your Browser 
Your Saber Dino model will open in your default web browsing 
application. At the bottom will be the standard Navigation Bar supplied 

12 
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with Strata Live 3D. You’ll notice that this is a different Navigation Bar 
than the very straight forward – and somewhat plain – controller in the 
3D View palette. 

Test out rotating, moving, zooming and even measuring Saber Dino. Just 
as in the 3D View palette, you can test these different functions by just 
clicking on the corresponding button on the Navigation Bar. You can 
always click on the Reset button to put him back the way he was to begin 
with. 

Obviously there is much, much more you can do with Strata Live 3D. 
Additional tutorials are available in the chapter titled “Live 3D 
Tutorials”. There you’ll learn about creating Levels of Detail to reduce 
the overall polygon count of objects to make them more appropriate for 
real‐time graphics. You’ll learn about creating animated models, creating 
custom Navigation Bars, and even editing the Master Model XML code. 

13 
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The Workspace 

3.1 Palettes, Windows and Java 

When Strata Live 3D is launched, a number of program windows, called 
“palettes”, are created. Strata Live 3D is written in Java and, as a result, 
each of these palettes has its own tab on the taskbar when running on 
Microsoft Windows, even though on the Mac they are stacked within one 
document on the Application Dock. While this may be somewhat non‐
standard, we know youʹll appreciate the benefits of Java for both cross‐
platform consistency and plug‐in free viewing of the finished content. 

These palettes are used to provide clusters of functionality. You can move 
the palettes around to any configuration you like, and this placement will 
be saved automatically for future sessions. In particular, if you have 
multiple monitors, it is often convenient to put the 3D View palette on 
one monitor, and other palettes on the other monitor. If you do this, make 
sure that the 3D View palette is on the monitor using the best graphics 
card (most 2‐monitor configurations have one high‐performance graphics 
card, and one cheap one). While the 3D viewer does not use any native 
3D acceleration capabilities (another important part of platform 
independence), it does move a significant amount of data from memory 
to the screen, and a low‐performance graphics card can lower update rate 
and cursor responsiveness. 

3.2 The Toolbar 

The application Toolbar resides at the top of the main Strata Live 3D 
palette, just below the menu bar. The Toolbar can be used to perform 
many of the major functions of Live 3D or to gain quick access to 
additional palettes. The buttons on the Toolbar are shortcuts to certain 
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highly‐used menu items. These same functions can also be accessed via 
command keys. 

The Toolbar can be dragged off of the main palette to become its own, 
separate palette. To drag off the palette, click and drag on the left side of 
the Toolbar where the four dots representing the handle appear. 

 

Float the cursor over each button to see a pop‐up hint showing the button 
function. For detailed descriptions of the commands represented in the 
Toolbar, see the corresponding technical descriptions in the Main Menu 
section below. 

3.3 The Main Menu 

The main menu is located at the top of the main palette – the Strata Live 
3D palette. This menu gives access to most of the functions within Strata 
Live 3D. A few of these functions also have shortcut buttons in the 
Toolbar directly below the menu. This section of the User Guide gives an 
overview of each function available from the main menu. 

 
File Menu 

Use this menu to create a new a Master Model, open an existing one, 
import geometry and manage saving of your projects. 

16 
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New > 

Empty Master Model 
This command creates a new, empty model. You will be immediately 
prompted to give it a file name. 

Image Loop Master Model 
This is a special kind of Master Model for making cylindrical 3D slide 
shows. Upon selection, a dialog comes up asking you to select a series of 
images. You can use as many images as you like. Strata Live 3D will 
automatically construct a cylinder with the same number of sides as 
images you imported. 

NOTE:  If a model is open already, you will be prompted to save 
changes. In Strata Live 3D you only work with one model at a 
time, so open models must be closed before a new file can be 
created. 

Open… 
Opens an existing model file saved in either the XMM (Live 3D Master 
Model) format or the VRML (Virtual Reality Modeling Language) format. 

Hotkeys: 
Control (Ctrl) and “O” on Windows 
Command (Cmd) and “O” on Macintosh 

Ordinarily, the Master Model is stored in an .xmm file, which is a ZIP‐
style file archive but with a different extension (.xmm vs. .zip). 

Sometimes, such as when working on models with a lot of textures, it 
may be useful to work with the unzipped version of the XMM file. To 
unzip the .xmm file, just change the file extension from .xmm to .zip. You 
should now be able to unzip the file using a compression utility, such as 
WinZip or StuffIt Expander. Once the file is unzipped, you can navigate 
to the folder containing the unzipped data, and open the file named 
MASTER.XML that appears in that folder. You can also directly save an 
uncompressed model using the Save As command. 

Strata Live 3D will look in that directory for all ancillary files referenced 
in this Master Model file. When you are done editing the Master Model, 
you can use Save As to save the collection of files as an XMM archive 
once again.  

You can also open files by dragging and dropping onto the main Strata 
Live 3D palette. 
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Reload XML… 
This menu item is used when editing the XML of a Master Model outside 
Strata Live 3D, using a text editor. It is much faster to reload the XML 
than it would be to close and re‐open the entire XMM file, as it is not 
necessary to reload textures that have not been changed. 

Import > 
Use import to insert geometry into your model. Import supports VRML, 
Alias Studio (.WIRE) and K3D files. Note that Import either replaces the 
geometry you have in your current model or closes the existing XMM 
document and imports the model into a new document. Import is not for 
adding geometry to a model with existing geometry. To assemble 
multiple objects into a single model file use a full modeling application 
such as Strata 3D CX. For more information on importing, and ways to 
deal with some special situations, check the Troubleshooting section in 
the Appendix, near the end of this User Guide. 

VRML 2 (VRML 97)… 
Selecting the VRML command imports a 3D model in VRML (.wrl) 
format created by Strata 3D CX, Maya, Silo or similar 3D modeling 
programs (this format is also sometimes called X3D).  

NOTE:  VRML, though an industry standard format for objects 
and scenes, is an imperfect interchange format. There are an 
unlimited number of ways to describe the same objects and scene 
elements in VRML; thus, the Live 3D import feature was 
designed and optimized to read VRML files generated by the 
more popular 3D modeling programs, but it may not handle just 
any VRML file. 

Alias Studio… 
Strata Live 3D imports .WIRE files created with version 10 or later of 
Alias Studio. This process requires a running copy of Alias Studio on the 
machine that you use for Strata Live 3D. Details of the import process are 
sent to the Log palette. Alias Studio files tend to have extremely high 
polygon counts, so your next step should be to generate a lowered level 
of detail, or LOD. Details on generating LODs can be found in Palettes 
section of this User Guide. For details on this process see the 
Troubleshooting and Support section of this User Guide. 

K3D… 
Selecting K3D imports a 3D model in the K3D format, a legacy format 
from Kaon Interactive’s product Activate!3D Author. 
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Save 
This command saves the Strata Live 3D model in the Master Model XMM 
format with the modelʹs current name. The current name may be one you 
selected from a previous save or acquired from an imported model. 

Hotkeys: 
Control (Ctrl) and “S” on Windows 
Command (Cmd) and “S” on Macintosh 

Save As…  
Save As allows saving the Master Model with a new name and location. 

NOTE:  If you navigate into a folder and specifically type the 
name MASTER.XML, the XMM data will be saved and 
unpacked into that folder. This process is discussed in detail in 
Editing the XML File found in Chapter 4 of this User Guide. 
This technique should not be used on models with more than a 
few hundred objects, however, as Windows performance drops 
dramatically when folders have thousands of files in them. 

Close 
This command closes the current Master Model, allowing a new Master 
Model to be opened without restarting Strata Live 3D. 

Hotkeys: 
Control (Ctrl) and “W” on Windows 
Command (Cmd) and “W” on Macintosh 

Exit 
Selecting Exit closes all palettes and Exits the program. 

Edit Menu 
The Edit menu is used to assist you in editing important aspects of your 
Master Model project with the following commands: 

Undo 
A single level of Undo is available. Selecting Edit > Undo, clicking the 
Undo button in the Toolbar, or hitting control “Z” backs up to the 
previously checkpointed state of the 3D model. Checkpoints happen 
before any permanent operation. To see exactly what will be undone, 
float your cursor over the Undo Toolbar button, and wait for the tool tip. 
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Hotkeys: 
Control (Ctrl) and “Z” on Windows 
Command (Cmd) and “Z” on Macintosh 

Redo 
Selecting Edit > Redo, clicking the Redo button on the Toolbar, or hitting 
control “Y” reapplies the most recent Undo operation. To see exactly 
what will be redone, float your cursor over the Redo Toolbar button, and 
wait for the tool tip. 

Hotkeys: 
Control (Ctrl) and “Y” on Windows 
Command (Cmd) and “Y” on Macintosh 

Change All Materials > 
The Edit > Change All Materials > menu contains shortcuts to globally 
modify attributes of all materials at once. Individual materials can be 
changed using the Materials palette. For detailed information about the 
Materials palette see the Palettes section of this chapter.  

Materials are a collection of settings and an optional texture map. Settings 
such as Ambient Intensity and Glossiness can be individually managed 
within the Edit Material dialog.  

NOTE STRATA 3D USERS:  The term “Materials” in Strata 
Live 3D is basically equivalent to the term “Textures” in Strata 
3D CX. 

Backface All 
Sets all materials to show backfaces. In the Strata Live 3D renderer (as 
with virtually all polygon based renderers) each object has a front face 
and a back face. Using this information, the rendering can be made more 
efficient if only the front side is required to be displayed. In Strata Live 
3D this decision is controlled via the materials. This setting can be 
individually managed in the Edit Material dialog in addition to globally 
changing the setting with this menu command. 

Backface None 
Sets all material backfaces to not be displayed. See Backface All above for 
a more detailed discussion about materials and backfacing polygons. 

Light All Matte 
This command changes all materials to use a Phong shader, with no 
specular highlights. Note that you may need to insert lights using the 
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Insert > Light menu option in order for the Phong shader to illuminate the 
object properly. 

Light All Specular 
Changes all materials to use a Phong shader, with a specular intensity of 
1. Note that you may need to insert lights using the Insert > Light menu 
option in order to create specular highlights. 

Light None 
This command changes all materials to use no lighting model. This is 
useful for materials that contain texture maps that are “pre‐lit” 
(sometimes called a “baked‐in” or “self‐illuminated” texture). 

UV Wrap All 
Changes all materials to wrap textures that extend beyond the 0 to 1 
range. 

UV Wrap None 
Changes all materials to clamp textures that extend beyond the 0 to 1 
range. 

Change Aspect > 
All views in the Master Model are defined assuming a certain aspect 
ratio. This menu lets you change the aspect ratio to some standard values 
(Portrait 3:4, Square 1:1 and Landscape 4:3). The 3D View palette will 
show the aspect ratio defined here. To change the aspect ratio of the 
finished web tour, simply edit the width and height numbers in the 
HTML file. 

Dimensions 
The Master Model format contains a global scale factor, which converts 
from local coordinates to millimeters. This menu command brings up the 
Edit Scene Dimensions dialog which allows you to set this scale factor 
directly, or in terms of the width, height, or depth of visible scene. This 
process is useful, in particular, for adjusting the dimensions that will be 
displayed when a viewer checks the dimensions of your model using the 
Measure tool on the Navigation Bar. 

Compression Parameters 
This command brings up the Quality-driven Compression Parameters 
dialog. At the top of this dialog you’ll find the Common Settings pop‐
up menu. This menu provides the best approach for using some complex 
compression algorithms. 
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For a more detailed description of the individual settings of this dialog 
see the section on Making Efficient Models in Chapter 4 below. 

 

Default Background Color 
The Master Model contains a default background color, which some user 
interface templates will follow when displaying the 3D model. This menu 
item brings up a color picker that allows you to set this color. Note that to 
see the result on the screen, you will need to use the View > Solid 
Background menu item as well. 

Delete > 
Use this menu item to delete things from the Master Model. Note that 
deletions are deep – deleting a view deletes any script key frame that 
used that view, for example. 

XML 
This allows you to edit the XML of the Master Model directly using the 
Edit XML dialog. It can be used to make changes to things not exposed 
in the Strata Live 3D user interface.  

The Edit XML dialog is a very simple text editor and doesn’t supply any 
special features, such as Search and Replace, so you may find that using a 
third party text editor is easier. If you want to use a different editor, just 
select the portion of the XML code you want to edit (by clicking and 
dragging), and then copy using Ctrl - C (Cmd - C on Mac). Paste the 
copied code into the editor of your choice. When you’re done editing, just 
paste the text back into the Edit XML dialog using Ctrl - V (Cmd - V on 
Mac).  

22 
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NOTE: Simple text editors, such as WordPad on Windows, work 
best because they don’t add any hidden formatting characters to 
the text. 

View Menu 
The View menu contains commands that are used to manage the content 
of the 3D View palette and other aspects of the view which will help you 
determine what your final Product Tour will look like. 

Antialias 
By default, the 3D View palette has antialiasing (smoothing of the 
rendered image) disabled to avoid using too much CPU power during the 
editing process. To see the model the way it will look in a Product Tour 
turn this option on.  

There are two different approaches used for antialiasing: when the scene 
is changing, only edges are antialiased; when the scene stops changing, 
the entire scene is progressively redrawn with more antialiasing passes 
(up to a limit of 256 times oversampled). Note that in a Product Tour, 
MIPMaps are also used to avoid texture artifacts, but these are not shown 
in the 3D View palette. 

Wireframe > 
This option shows the triangle structure of the 3D model. You have the 
option of showing the wireframe overlaid on the 3D textured surface, or 
the wireframe alone on an un‐textured surface. This setting is useful for 
checking polygon level of detail (LOD) while in the 3D View palette. This 
setting is not used in the exported Product Tour.  

Shadow 
This option controls the display of the drop shadow in the 3D View 
palette. By default, regardless of how this menu command is set, Product 
Tours will be exported with a shadow. For web based product tours you 
can modify the shadow, and even turn it off altogether, by editing the 
HTML file that is saved out with your exported Product Tour. To remove 
the shadow in the Product Tour, just open the HTML file, search for 
“Shadow” and change the alpha setting down to 0.0. 

Solid Background 
This option shows the model against a solid background color in the 3D 
View palette. Use the Edit > Default Background Color menu item to 
change the solid color. 
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Frame Rate 
This option controls the display of the frame rate (frame updates per 
second, or FPS) in the 3D View palette. It appears in the upper right 
corner. It may be difficult to see, as it is in black text in a very small font – 
but look close and you will see the numbers. 

You can use this display as a rough guide of the performance users will 
see in web‐based Product Tours generated from this model. Note that 
window size, triangle count, CPU speed, and video card performance all 
significantly impact frame rate. 

Level of Detail > 
This gives you the ability to select which Level of Detail (LOD) to display 
in the 3D View palette. Three levels are supported: 

• Highest: Shows the highest defined level of detail (the most triangles 
and objects)  

• Lowest with All Objects: Shows the lowest level of detail, except 
where doing so would eliminate objects. The Master Model format 
allows a level of detail Mesh to replace an entire hierarchy of objects. 
While this mesh would be shown with the “Lowest” strategy, the 
object hierarchy will be shown using the “Lowest with All Objects” 
strategy.  

• Lowest: Shows the lowest defined level of detail (fewest objects and 
triangles) 

NOTE: Product Tours generated from the Master Model will 
choose a level of detail based upon the animation sequences used. 
In Strata Live 3D, a template can also supply a polygon budget 
to be achieved, which can lead to a mix of various levels of detail. 

To see level of detail meshes for individual objects, use the Isolate Object 
item from the right‐click menu on the object hierarchy tree. 

To generate levels of detail for a model from within Strata Live 3D, right‐
click on the Root object in the object hierarchy tree and select “Generate 
LOD”. 

Triangle Counts  
This option controls display of triangle counts in the object hierarchy tree. 
The polygon count of each mesh is displayed. If multiple levels of detail 
are defined, the triangle count of each is shown, separated by slashes. 
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Palettes Menu 
This menu is used to open the various palettes. If the palette is already 
open, the menu item will bring it to the front. To close a palette, use the 
close button on the paletteʹs title bar. 

Each palette function is summarized in this section. Each palette is more 
fully explained in the Palettes section, later in this chapter. 

3D View 
Opens the 3D View palette for the Master Model. 

Preview Scripts 
Opens the Preview Scripts palette. The Preview Scripts palette presents a 
set of buttons, one for each script. This is useful for testing the 
interactions of scripts, and making sure all preconditions and “before” 
scripts are properly set up. 

Hotkeys: 
Control (Ctrl) and “P” on Windows 
Command (Cmd) and “P” on Macintosh 

Preview Compression 
The Preview Compression palette is a second 3D window, slaved to the 
first, in which the full compressed web model is displayed. This can be 
used to do quality assurance (QA) of the compression settings 
(particularly texture compression), prior to generation of a Product Tour. 

Metadata 
The Metadata palette lets you edit data about the Master Model, such as 
its name and copyright holder. 

Hotkeys: 
Control (Ctrl) and “M” on Windows 
Command (Cmd) and “M” on Macintosh 

Sequences & Views 
The Sequences and Views palette allows you to edit named views and 
sequences. 
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Hotkeys: 
Control (Ctrl) and “E” on Windows 
Command (Cmd) and “E” on Macintosh 

Scripts 
The Scripts palette allows you to edit scripts – which are combinations of 
sequence actions and camera moves – over time. 

Hotkeys: 
Control (Ctrl) and “T” on Windows 
Command (Cmd) and “T” on Macintosh 

Materials 
The Materials palette presents a tree view of materials used in the Master 
Model, and allows editing of material properties. 

Info 
The Info palette shows overall information about the Master Model, such 
as filename and triangle count. 

Log 
The Log palette lists progress messages, warnings, and errors. 

QA Menu 
This menu is used for performing Quality Assurance on a 3D model. It 
configures the interface in a well‐defined way, to help ensure consistency. 

Off 
Turns off QA mode. 

Web 
Opens the Compression Preview palette with a fixed size, for QA of 
models destined for Web Product Tours. 

Print 
Configures the 3D View palette to aid QA of models destined for print 
applications. This includes adjusting the zoom limits and window size. 

Insert Menu 
Use this menu to add new elements to the Master Model. 
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Sequence 
Adds an animation sequence, and opens the Sequences and Views 
palette. You’ll be prompted to specify the type of sequence to add, and if 
“Object sequence” is chosen, you also need to select the object on which 
the sequence operates. 

Script 
Adds a script and opens the Scripts palette. You’ll be prompted to either 
begin the script by appending an existing script or to make a completely 
new one. If you decide to make a completely new script, you’ll need to 
select an existing sequence or view to base the script on. 

Bookmark 
Creates a bookmark from the current script editor settings (active script 
and time value). This bookmark can be used to quickly set the camera and 
sequences to a particular configuration. 

Light 
This command adds a directional light to the scene. The Sequences and 
Views palette and the Scene Lighting dialog will open, and the Scene 
Lighting editing overlay will be displayed on the 3D View palette to 
allow you to position the light and set its intensity. 

Material 
Adds a material to the scene and opens the Materials palette. 

Object > Null 
Adds a “Null” transform object to the hierarchy (useful for grouping 
other objects, or as an Elliptical Hermite Loft target). 

Object > Elliptical Hermite Loft 
Adds an Elliptical Hermite Loft object to the hierarchy. These objects can 
be used to model cables, straps, papers, and other flexible objects. 

Export Menu 
Use the Export menu to save out your finished Product Tour. 

Web Tour > 
Provides a series of options to create a compressed web model JAR, an 
HTML file with user interface controls, and all necessary extra files for the 
Product Tour (applet JARs, user interface JAR, etc.). Be sure to put this in 
an empty directory, to avoid accidentally overwriting files from other 
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Product Tours. From the sub‐menu you can choose the specific user 
interface template: 

Study Scene from Outside 
This option exports the scene with the default Navigation Bar for the 
Product Tour user interface. It has controls which allow you to rotate, 
pan, and zoom on the model. Any scripts in the Master Model will be 
assigned to buttons in this interface. 

Scene Walk-Through 
This is an alternate Navigation Bar user interface suitable for walk‐
through presentations for architecture, tradeshow, store interior, and 
similar applications. It has controls which allow you to move the camera 
location, and orientation, but not zoom or pan the camera. Any scripts in 
the Master Model will be assigned to buttons in this interface. For more 
information see section 4.8, Making Walkthrough Presentations. 

Minimal User Interface 
This export option includes no user interface at all. The only behavior 
available is orientation (rotation) control using the mouse. This is suitable 
for very simple web applications like animated logos, and is a clean 
starting point for writing a brand new user interface in the Meson 
language. All scripts defined in the model will be included in the model 
JAR file, but they will not be tied to any control buttons. 

Flash Embedding 
This export option creates an ActionScript macro program which causes 
the Flash authoring application to create a default user interface for the 
product tour. This default interface can then be customized using Flash. 
The 3D component of the tour is still produced using the Java applet, but 
this option embeds the 3D component in a Flash movie, for added 
flexibility in authoring. 

Other Web Template 
This export option allows you to select a Navigation Bar from the Web 
Templates folder, found in the Strata Live 3D application folder.  
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Strata Live 3D comes with four basic types of Navigation Bars. The 
standard bar is provided in six color combinations. You can find 
additional custom Navigation Bars at www.stratacafe.com. You can also 
make your own Navigation Bars. 

3D PDF 
This export option creates a PDF file with an embedded 3D model which 
Adobe Reader 7 can display. You are able to choose from a selection of 
PDF templates for your design. After you’ve exported your 3D PDF file, 
you can open the PDF in Adobe Illustrator to add design elements to the 
page (the 3D element won’t be visible in Illustrator). With Adobe Acrobat 
Pro and Acrobat 3D you can insert Live 3D content directly into any PDF 
document, such as product brochures, catalogs, technical manuals, etc. 
See the PDF section in Chapter 4. 

Compressed Web Model 
Creates a compressed web model JAR file containing all defined scripts. 
A JAR file (short for Java Archive) is a ZIP file used to distribute a set of 
Java classes. 

Non-Animated Web Model 
Creates a compressed web model JAR file with no scripts or animations, 
and uses the initial state of the model to control optimizations. This will 
typically be smaller than a full web model. Any objects that are not visible 
will be optimized away; all object hierarchy will be optimized away, etc. 

Non-Animated Low Resolution Web Model 
This is the same as a Non‐Animated web model except that only the first 
3 bands of wavelet texture data are included, resulting in a much smaller 
model.  

Special Menu 
This menu gives access to some special purpose functions, which are not 
likely to be needed by most typical Strata Live 3D users. 

Normalize IDs 
Re‐assigns IDs in the Master Model to more closely match the 
descriptions of objects. 

Unlimited Texture Memory 
Switches to a mode in which there are no limits on texture memory, 
because any texture that doesnʹt fit will cause an existing texture to be 
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dropped. This mode can make the 3D View palette unusable, because it 
can take minutes to render a single scene. 

Reverse Backfacing Triangles 
Analyzes the currently rendered scene in the 3D View palette and finds 
all meshes which are rendered in backface, and reverses the winding 
order of those meshes. While in principle this can be used to correct 
winding order of models, in practice most models have small cracks in 
them, which greatly limits the functionality of this command. 

Rescale Entire Model 
This command will rescale everything in the model by a constant factor. 
Use this when integrating models created with different units. To change 
the measurements displayed for the model, use the Edit > Dimensions 
command instead. 

Convert Object Fade to Material Fade 
Object fade sequences modify the “alpha” property of objects in the 
Master Model. Objects with transparency are treated very differently 
from materials with transparency. For example, a semi‐transparent object 
will completely obscure any object behind it which has material‐level 
transparency (either an alpha setting in the material, or per‐pixel alpha in 
the texture). Semi‐transparent objects also completely obscure other semi‐
transparent objects that are not more opaque than them. These rules 
allow you to fade an object without seeing a lot of artifacts caused by the 
presence or absence of backfacing triangles, and give object fade 
animations a much more natural appearance. Also, object fades propagate 
down the hierarchy to private children of the fading object. 

In some rare cases, you will find that these behaviors are undesirable. For 
example, if you are fading a solid object in front of another object which is 
fundamentally transparent throughout (such as a glass jar), the fact that 
the faded object completely obscures the object behind it will lead to 
strange bleed‐through of the background. In a case like this, it is instead 
desirable to hide the object by fading away its materials. This is what this 
menu item facilitates. It converts an existing object fade into a material 
fade that changes all the materials used by the object. Note that this can 
have surprising results if some of those materials are also used by other 
objects, or if the object being faded has private children in the hierarchy. 

Set Default VRML Import Units 
This command works in conjunction with the Rescale Entire Model 
command above. If you change your scale with the Rescale Entire Model 
command, the Set Default VRML Import Units command gives you the 
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opportunity to use this relative scale as the default for importing VRML 
files. 

Show Warnings as Alerts 
By default Warnings are shown in a dialog box. You can disable this 
dialog box, and then all warnings are sent only to the Log palette. This 
menu item switches back to the original behavior of showing dialogs for 
each warning. 

Help Menu 

Tutorials 
Links to additional tutorials on the Strata website. This section of the 
website will be added to on a regular basis. 

User Manual 
Opens the Strata Live 3D User Guide from the Strata website. The manual 
accessed via this command may be more up to date than a previously 
acquired version. 

Master Model Format 
Links to the Master Model format specification on Strataʹs web site. 

Meson Language Manual 
Links to the documentation of the Meson language, used in exported web 
tours. 

Extras 
Links to samples, scripts, templates, etc. This area of the Strata website 
will also be updated regularly. 

Check for Update 
Checks with the Strata server to see if there is a Strata Live 3D update 
available. 

3.4 The Palettes 

The windows in Strata Live 3D are referred to as “Palettes”. There are a 
variety of palettes for specific areas of functionality. 
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Strata Live 3D Main Palette 
The Strata Live 3D main palette is home to the main menu and Toolbar, 
which were discussed in the previous section. In addition to holding the 
menu and Toolbar, the main palette contains the object hierarchy. The 
object hierarchy contains the structured list of objects and assets 
contained in the model. The hierarchy is a “parent and child” 
relationship, providing an effective method of controlling the assets in 
your model. Model hierarchy is preserved from most imported models, 
including XMM and VRML models saved from Strata 3D CX. 

The features and commands available from the object hierarchy are 
described below: 

Public vs. Private 
 

Each object in the Master Model is either public or private. In the 
hierarchy view, public objects are shown in black, while private objects 
are gray. 

The biggest difference between public and private objects is the way they 
fade. Fading a public object (adjusting its alpha) fades its own mesh (if 
any), and the meshes of all private children. 

Clicking on an object in this view (or clicking in the 3D View palette with 
the Shift key down) selects an object. The selected object is shown in red 
(or tinted red). If the object has private children, they are shown in green 
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(or tinted green). If the object itself is private, other private objects, which 
are part of the same public object as the selected one, are shown in blue 
(or tinted blue). Both the 3D view and the labels in the hierarchy are 
colored in this way. 

To select no object, click on the root of the hierarchy tree, or type the Esc 
key. 

The description shown at the root of the tree is the Master Model title, 
which can be modified using the Metadata palette. 

Contextual Right-Click Menu 
Right‐clicking on an object in the hierarchy brings up a menu of available 
operations. If an object is already selected (such as with a Shift‐click in the 
3D View palette), a right click off of the hierarchy area will bring up a 
menu for the selected objects. These contextual menus for managing 
objects and their attributes include the following commands: 

Select Parent 
 

Selects the object above the currently selected one in the hierarchy. 
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Isolate in 3D View 
This menu command shows this object alone in the 3D View palette. The 
camera is automatically re‐centered on the object, and distance is set to fill 
the screen. Using the checkboxes, meshes below and above this object in 
the hierarchy can be displayed as well. 

Rename... 
The Rename command allows you to change the name of the selected 
object. Note that all objects have an ID and a description. The ID never 
changes, and never appears in the Strata Live 3D user interface. It is used 
to link objects with the animation sequences that control them, etc. This 
item edits the description, not the ID. The only way to change ID is using 
the Edit > XML menu command. 

When you change the name of an object, any sequence that operates on 
that object and uses the old name of the object, will be automatically 
updated to use the new name. 

To change the name of the Root you must use the Metadata palette. 

Change Parent 
This menu command starts a change parent operation. The next object 
you click on will become the new parent of this object. Note that Change 
Parent is not available on objects which have sequences associated with 
them, since the coordinate values in those sequences would become 
meaningless. 

Make Private 
Makes the selected object private. Any fade sequence that operates on this 
object is removed from the Master Model. 

Make Children Private 
This menu command takes all child objects of the selected object private. 
This is equivalent to using the Make Private menu item on each of those 
objects individually. 

Make Public 
This menu command makes a private object public. Since every object 
should have a fade sequence associated with it, you are given the choice 
of making a top‐level fade sequence, or making this object fade together 
with the object it was fading with when it was private. To make the object 
fade together with some other object, choose a top‐level fade, and then 
put that fade together with the other one using the Sequences and 
Views palette. 
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Generate LOD 
This menu command brings up the 
Generate Level of Detail dialog. Use 
this dialog to generate a lower level of 
detail (LOD) for the selected object and 
optionally for its children. A lower level of 
detail is achieved for a polygon mesh by a 
process called decimation in which 
smaller triangles that face roughly the 
same direction are merged to form fewer 
larger triangles. By adjusting the 
reduction factor, the exact number of 
triangles that are used in the resulting 
lower LOD mesh can be fine‐tuned to 
strike a balance between: reducing file size 
which affects the web viewer’s loading 
time and performance of the viewer, and; 
removing an objectionable amount of 
detail from the resulting lower LOD 
model.    

+ Triangles - 
This controls the aggressiveness of the polygon decimation algorithm. 
The leftmost setting matches the result of an automatically generated 
LOD with no decimation. As you move the slider to the right, it will 
further reduce the triangle count. The value to choose is highly mesh‐
dependent, so the best strategy is to try several settings. 

Resmooth Normals (angle) 
Vertex normals are derived from adjacent face normals, using a common 
technique called “smoothing groups.” When reducing the number of 
triangles, a finely beveled surface which used a single smoothing group 
might be turned into a sharp edge, for which smoothing is not 
appropriate. The Resmooth Normals control allows you to recalculate 
smoothing groups, based on the reduced triangles. This is almost always 
a good idea, as it will allow you to achieve lower polygon counts, without 
introducing shading anomalies. The slider controls the angular threshold 
used in smoothing group calculation. A low threshold (left) will lead to a 
more faceted appearance, while a high threshold (right) will lead to a 
smoother appearance, with hard boundaries only at sharp object corners. 

A good strategy is to ignore lighting issues on the model as you adjust the 
triangle count, instead looking primarily at the quality of the geometry. 
Then, adjust the smoothing generation threshold to eliminate specular 
anomalies. And finally, boost triangle count, if necessary, to eliminate 
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specular anomalies that smoothing groups could not correct. Remember, 
each time you change one of the settings in the Generate Level of Detail 
dialog you need to click on the Generate LOD button to see the result of 
your changes. 

NOTE:  Specular effects are much more sensitive to the direction 
of surface normals than diffuse shading, so reducing the strength 
of specular and chrome effects in the Materials used by the object 
will also allow you to achieve lower polygon counts with a good 
visual appearance. 

Cylinder Detection 
For models created with many programs, cylinder topologies are 
common. Cylinder Detection optimizes for this situation. Using this 
feature will take more time to generate LODs, but model complexity can 
be reduced much more effectively than with arbitrary tessellations 
(complex surfaces simulated with triangles). If the model was created 
using a NURBS tool like Alias Studio, cylinder topologies will not be 
present in the geometry and so time spent attempting to detect them is 
wasted. 

Reduce Child Objects 
The Reduce Child Objects checkbox applies decimation to all objects, 
public and private, below the selected object in the hierarchy. This is a 
destructive operation in that if Generate LOD was previously used on any 
child object, that decimation will be lost and replaced with this new 
decimation. 

Isolate in 3D View 
This check box shows only the selected object (and child objects, if 
Reduce Child Objects is selected) in the 3D View. 

Generate LOD 
This button starts the decimation process, which can take anywhere from 
a second to several minutes, depending on the size of the meshes being 
reduced. 

NOTE:  After you Generate LOD for an object, you can 
immediately select a different object in the 3D View palette using 
Shift‐click. This new selection will then be the target of the 
Generate LOD control. 

The first step of polygon reduction is welding together vertices which are 
in nearly the same place. When working with some models, this can 
change object topology, which impacts surface normals, resulting in 
drastic changes to the way light bounces off an object. For example, a box 
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with sharp edges can suddenly look very rounded. The solution to this is 
to have proper smoothing groups assigned to each triangle, which 
controls the generation of vertex normals more precisely than object 
topology can. Smoothing group generation happens at model import 
time. 

Object Smoothing 
This is the next contextual right‐click 
menu command after Generate LOD. 
This command brings up the Object 
Smoothing dialog. This dialog allows 
you to change every polygon in the 
mesh of the selected object to use a 
consistent approach to normal 
generation (smoothing), overriding the 
smoothing groups generated at model 
import. 
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Crease Angle 
This slider controls the angle at which 
smoothing groups should change. 
Dragging the slider all the way to the 
left will give a completely faceted (not smooth) look, and dragging all the 
way to the right will give a completely smooth look. After adjusting the 
slider, click the Resmooth button to apply the change. 

 

Smooth Child Objects 
If selected, the smoothing checkbox will be applied to all objects, public 
and private, below this one in the hierarchy. 

Isolate in 3D View 
Shows only the selected object (and child objects, if Reduce Child Objects 
is selected) in the 3D View. 

Auto-Apply 
Ordinarily, you need to click the Resmooth button each time you move 
the slider to generate new smoothing groups. When the mesh you are 
working with is relatively small, you can work more dynamically by 
checking Auto‐Apply. The smoothing will then be changed each time you 
move the slider. 

Divide By Material 
This contextual right‐click menu command is only available on objects 
which have: 

• A mesh  
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• No Level of Detail decimation (to restore, use Generate LOD, and 
generate with the triangles slider set to maximum – the leftmost 
position)  

• Multiple materials within the mesh 
For objects that meet these criteria, this option will divide the object into 
multiple objects, generating a different object and mesh for each material 
group. 

Edit Object 
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This contextual right‐click menu 
command brings up the Edit Object 
dialog which allows editing of the 
object transform data. Note that if the 
object transform is manipulated by an 
animation sequence, some of the 
transform items may be disabled. To 
edit the transforms of such objects, you 
need to edit the waypoints (similar to 
keyframes) of the appropriate 
animation sequences using the 
Sequences and Views palette. 

Pressing the manipulator icon next to 
the corresponding transform parameter 
displays the manipulator in the 3D 
View palette. The manipulator can be 
oriented in the object’s local, object’s 
parent or the world coordinate system 
by making the selection in the pull‐
down list, which appears when the 
manipulator is engaged. Clicking the 
manipulator icon for the second time 
enlarges the size of the manipulator in 
the 3D View, making it easier to use 
with certain objects. Clicking it for the 
third time turns it off. 

 



STRATA LIVE 3D User Guide – Chapter 3 
The Workspace 

To use any of the manipulators, first engage one of them by pressing the 
icon, then click on the manipulator in the 3D View, and drag with the 
mouse to move or rotate the object or its pivot point. 

 

EHL Tab 
If the Object is an Elliptical Hermite Loft (EHL), the Edit Object dialog has 
extra tabs across the bottom for editing the EHL configuration, and 
editing the EHL target object (An Elliptical Hermite Loft can be added to 
your model by using the Insert menu and selecting Insert > Object > 
Elliptical Hermite Loft...). 

Once the EHL tab has been selected, the top pop‐up menu is used to 
choose the target object. The EHL starts at the node in the hierarchy and 
goes to this target object. The Likely Targets Only checkbox reduces the 
list to only those objects which are likely to be EHL targets (other EHLs 
and empty leaf objects). 

The Shape section includes major and minor ellipse radius controls 
(which can be locked together to make a circular loft), and source and 
target weight controls which dictate the shape of the Hermite curve. 

The geometry detail section controls how many segments are used to 
model the Hermite curve, and how many segments around are used to 
model the ellipse. Note that Phong shading will cause relatively low 
segment counts to look quite round nonetheless. 

The appearance section selects the EHL material, and texture mapping 
properties.  
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Edit Mesh 
This right‐click context menu command brings up the Edit Mesh dialog 
box. This option is similar to Edit Object, but instead of changing 
transform in the object hierarchy, it modifies the vertex data of the mesh 
directly. Note that if this is used on an object with LOD meshes, the 
transformations are applied to all of them. 

Edit Materials 
This menu command brings up a dialog allowing you to assign a 
different material to the selected object. All materials currently available 
in the model are presented in a pop‐up menu. 

Copy Hierarchy 
This contextual right‐click menu command copies the hierarchy of 
objects, including all materials used by those objects and compression 
settings for images used by those materials, to the system clipboard. It 
wraps the objects in a Master Model. 

Note that sequences and scripts which act on the objects in the hierarchy 
are not copied to the clipboard. 

Copy Mesh 
This command copies just the mesh of the selected object (and materials 
and compression settings) into the system clipboard. It wraps the mesh in 
an object and a Master Model. 

Paste Here 
This command pastes a Master Model from the system clipboard (see 
above commands Copy Hierarchy and Copy Mesh). The way paste 
happens depends on how the copy was done. If Copy Hierarchy was 
used, the objects will be added to the hierarchy under the selected node. 
If Copy Mesh was used, the mesh will replace the mesh of the selected 
node. 

NOTE:  Pasting always creates new materials in the destination 
hierarchy as well. Thus, it is often useful to use the Edit > Delete 
> Unused Materials menu item after using Copy / Paste / Delete 
operations to eliminate materials which are no longer used. 

Animation 
This contextual right‐click menu command is the equivalent of choosing 
Insert > Sequence… from the main menu bar, and then selecting the object 
from the Insert Sequence dialog. The advantage of using the 
Animation command from this menu is that you can bypass the step of 
selecting the object from a pop‐up menu in a dialog. Strata Live 3D knows 
which object you wish to add the animation sequence to because all of 
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these contextual right‐click menu commands operate on the currently 
selected object. 

Delete 
This contextual right‐click menu command deletes the selected object 
from the scene. 

Export to VRML 
This command allows you to save the hierarchy of objects into a VRML 
file. This is useful so that you can read this VRML file into a 3D authoring 
program, modify the meshes as needed, and then bring the edited content 
back into Strata Live 3D using the Copy & Paste functions described 
above. 

3D View Palette 
This palette provides a preview of what your 3D scene will look like. You 
can also use a variety of functions in this palette to assist in scripting. 

Sizing the Window 
The title bar of the embedded viewing window in this palette shows the 
current aspect ratio (change using Edit > Change Aspect), and the 
window size in pixels. To change the window size, use the grow box in 
the lower right corner. 

Sequence Disc Pop-Up 
In the 3D View palette, right‐click on the object of choice and hold down 
the mouse button to get the Sequence Disc. This is a special kind of pop‐
up menu, which allows you to adjust the state of any sequence that 
modifies the state of the object and/or material.  
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NOTE:  If the Scripts palette is open, using this disc will also 
add event markers. 

 

Selecting Objects 
Shift‐click on an object in the 3D View palette to select it in the object 
hierarchy in the main palette. 

Selecting Materials 
Ctrl‐click (Command‐click on Mac) on an object in the 3D View palette to 
select its material in the Material palette. 

Preview Scripts Palette 
Each button on this palette triggers execution of a script in the Master 
Model. You can only execute one script at a time using this palette. 

Preview Compression Palette 
This palette mirrors the 3D View palette, but shows the compressed 
version of the model. Note that compressing the Master Model to web 
resolution can take several minutes, and this will happen when you open 
this palette. Also, this palette should not be used until all sequence and 
script editing is finished. Edits to sequences or scripts will not necessarily 
be reflected into this version of the model. To edit sequences, close this 
palette, make the changes, then open this palette again (and get a cup of 
coffee while the model is re‐compressed). 
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Metadata Palette 
This palette is used to edit information about the model. Note that no 
changes to the text values take effect until you hit the Enter key. 

 
Info Palette 

This palette shows information about the XMM file being edited. You can 
access useful information from the Info palette, such as the overall 
polygon count of your model. 

 
Log Palette 

This palette lists messages generated as you perform editing operations. 
The buttons at the top of the palette can be used to filter the information 
displayed. Use the View Log File button to open the detailed log file, 
where even more progress messages can be found, along with details of 
any errors that occur. 

Sequences and Views Palette 
This palette is used to manipulate and edit sequences and named views, 
as well as scene orientation and lighting.  For a more detailed description 
of how sequences and views are used for interactive animations, see 
Chapter 4, The Workflow, and Chapter 5, Live 3D Tutorials, below. 

NOTE:  Simply manipulating the state of a sequence, scene 
orientation, or lighting using this palette will not have a 
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permanent effect on the model. The initial state of the Master 
Model is controlled exclusively through the initialization script, 
which you edit with the Scripts palette. Edits that you make to 
sequences and views, however, do remain permanent. These 
sequences and views can then be utilized for the creation of 
scripts. 

Named Views Section 
 

The Named Views section can be found across the top of the Sequences 
and Views palette. 

To ensure consistency in the user experience, and to accelerate script 
authoring, it’s a good idea to create named views of a model. A view fully 
defines the camera placement and behavior such as min/max zoom. Select 
a named view from the menu at the top‐left of this palette (in the Named 
Views section of the palette) to jump to an existing named view. 

Change View Definition Button and Edit Camera Dialog 
Once a view is selected in the Jump to View pop‐up menu, you can edit it 
using this button. The Edit Camera dialog comes up. 
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Basic Tab 
The basic tab contains the controls to rename the view, jump to the 
settings of another named view, move the view pane closer or farther 
away, and align the view horizontally and vertically. 

Detail Tab 
This tab provides controls to zoom in and out by changing the lens, 
adjusting the orientation angle of the view, and panning the view 
left/right and up/down. 

Limits Tab 
This tab allows you to set limits on how far a user or script can zoom the 
view or change the elevation angle. 

Advance Tab 
This tab allows you to set up the target point for the view. 

Use As Default Button 
Views used by scripts usually get many of their parameters from the 
defaults stored in the Master Model. These defaults typically match the 
values used by the view in the Init script, which is typically a named view 
called Init or Initial. After selecting a view, you can change the Master 
Model view defaults to instead use the values from the selected view. 
Any view that was using the old defaults will start using these defaults 
instead. This is useful, for example, to globally increase camera distances. 

Create New View 
This button creates a new named view, and launches the Edit Camera 
dialog. 

Deleting A View 
There is currently no facility to delete a view, other than the Edit > XML 
menu item. 

Sequences Section 
The Sequences section of the Sequences and Views palette takes up the 
majority of the space in order to make room for multiple sequence sliders. 
Sequences can be thought of as animation and interactivity building 
blocks. Sequences and views are used by the Scripting palette to create 
animation scripts. 

You can create a new sequence by using the menu command Insert > 
Sequence… from the main menu bar. 
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Jump To Menu 
The Jump To menu allows you to select a previously made bookmark. A 
bookmark is a combination of a script and a time value, which together 
describe the state of several sequences, and possibly the camera. All 
bookmarks are listed in this Jump To menu, and selecting one sets all the 
sequences to their bookmarked values. 

Scene Lighting Button 
Use this button to change scene lighting (only existing lights can be 
edited; to add new lights, use the Insert > Light command from the main 
menu bar). The actual Scene Lighting editing interface will appear 
overlaid on the 3D View palette. 

Sequence Controls 
Each sequence can be manipulated directly using the controls in this list. 
Note that the current sequence state can also be manipulated in the 3D 
View palette using the right mouse button to gain access to the Sequence 
Disc controller. 

Sequence Radio Button 
 

The radio button, just to the left of the sequence name, is used to select a 
sequence for special editing. You can use the Up and Down buttons to 
change the order, or “sort”, the selected sequence. You also have the 
option of merging sequences by using the Merge Into pop‐up menu. 

Sequence Slider 
Each sequence will have a slider controller associated with it. As you drag 
this slider you will see the object go through the waypoints currently 
created for the sequence. 
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Jump To Named Waypoint Pop-Up Menu 
For sequences that have named waypoints there will be a pop‐up menu to 
the right of the slider. You can use this pop‐up menu to select a named 
waypoint and the slider will jump to that point in the sequence.  

Edit Button 
Click the Edit button to the right of a slider to edit the sequence. The Edit 
Sequence dialog will appear containing a list of existing waypoints for the 
sequence. A waypoint is similar in concept to a keyframe. Selecting a 
waypoint from the list allows changing its name, parameter value, and all 
of the waypoint’s effects in the Waypoint Details section on the right side 
of the dialog. 

You can edit two different types of sequences: object animation 
sequences, and material animation sequences. 

 

Simple object sequences operate on a single object in the scene, and can 
affect the object’s position, orientation, location of the pivot, and the 
object’s opacity. When a waypoint of an object sequence is selected, the 
controls for animating the object’s attributes appear below the waypoint’s 
name in the Waypoint Details section of the palette. For already animated 
attributes, their current values are displayed and can be edited. For those 
attributes that are not yet animated, an Animate button is displayed. 

Once an attribute is set to animate, you can edit the values of the 
attributes by typing in new values. Additionally, for Position, Pivot and 
Orientation attributes, interactive manipulators are available. Pressing the 
manipulator icon next to the corresponding attribute displays the 
manipulator in the 3D View palette. The manipulator can be oriented in 
the object’s local, object’s parent, or the world coordinate system by 
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making the selection in the pop‐up menu, which appears in the Waypoint 
Details section of the dialog when the manipulator is engaged. Clicking 
the manipulator icon for the second time enlarges the size of the 
manipulator in the 3D View, making it easier to use with certain objects. 
Clicking it for the third time turns it off. 

To use any of the manipulators, first engage one of them by pressing the 
icon, then click on the manipulator in the 3D View, and drag with the 
mouse to move or rotate the object or its pivot. 

 

Simple material sequences can animate the material alpha, and apply 
a color curve filter to the material. To specify a set of materials to 
animate, you can press the Select… button and select the desired 
materials from the list. To animate the alpha value of the selected set of 
materials, first click the corresponding Animate button, and then type in 
the alpha value desired for the current waypoint. To apply an animated 
color curve to a set of materials, click its Animate button, and then click 
the Edit… button to open the curve editor. 

Sorting  
The order in which sequences are listed can be important for usability. In 
particular, it controls the order in which tracks appear in the Script 
palette. Sequences should be grouped by the parts on which they operate. 
For very large models with many sequences, it is helpful to further group 
sequences by where they appear on the 3D model. For example, you 
might want to group sequences that operate on the front of the model 
together, then group sequences that operate on the back of the model 
together. 

To change the order of sequences, click the radio button next to the 
sequence you want to move. Then use the Up and Down buttons at the 
bottom of the palette to change the sequence order. 
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Merging  
When two objects must work in concert with one another, it is often 
convenient to merge their sequences. While the runtime system can deal 
with sequences that have differing waypoints, it is strongly 
recommended that all waypoints in all sequences that are merged match 
exactly in both parameter value and ID. In practice, this means it is safe to 
merge simple two point sequences, such as Fade sequences. Merging 
more complex sequences should be followed up with the use of Edit > 
XML to ensure the waypoints of the various sub‐sequences correspond. 

To merge sequences, choose the sequence that you wish to become a sub‐
sequence by clicking on its radio button, then choose the new parent 
sequence from the Merge Into pop‐up menu at the bottom of the palette. 

Scripts Palette 
A script controls the animation of sequence state – and optionally camera, 
lighting, and scene orientation – over time. This control takes the form of 
an “event marker” – a designation of a “state” at a given time. The 
animation state between event markers interpolates the event marker 
values. The script editor organizes these event markers into “tracks.” 
There is one track for each sequence used by the script, and optionally 
tracks for camera motion, scene lighting, and scene orientation. 

Every Master Model has an initialization script. This special script must 
set the state of every sequence, the camera, lighting, and scene 
orientation. Failure to include a sequence in the initialization script will 
lead to unexpected results: the object will start in whatever state it 
happened to be in when last saved. 

 

To add a new script to the scene, use the Insert > Script... menu 
command. This will open the Scripts palette, and activate the Append 
Script dialog.  You can select an existing script to use as the starting point 
of this script, or choose Cancel to instead define the script using tracks. 
The remainder of this section describes each of the functional areas of the 
Scripts palette. 
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Append Script 
The Append Script dialog allows you to 
create a new script by basing it off of an 
existing script. This approach is most 
commonly used to create reverse scripts. 
Ordinarily, only scripts that make sense 
given the current state of the model are 
listed. To see the list of all scripts, uncheck 
the Respect Preconditions box. 

Generally, scripts are created in pairs. One 
script does something (for example, “Box 
Open”) and the other undoes it (“Box 
Close”). To facilitate this, you can choose 
an existing script, and then select Reverse Script. The new script will 
contain the same event markers as the original, except time is reversed. 
Also, heuristics are applied to guess the right preconditions and even the 
name of the reverse script. These can, of course, be edited as needed. 

Anytime you create a new script the Append Script dialog is presented. If 
you cancel out of this dialog, you will be presented with the Add Track 
dialog, described in the next section. 

Add Track 
This dialog is accessed by selecting Insert > Script… from the main 
menu bar or you can click on the Add button, which appears on the left 
hand side of the Scripts palette, just under the last track in the script. 
Using this dialog, you can add any track to the script. Available tracks 
are: 

Camera: This track controls the viewing direction, position, and 
magnification of the view while the track is running. Note that in web 
Product Tours, which run with a variable frame rate, all camera motion is 
smoothed, to avoid sudden changes. This smoothing is, by default, much 
slower while scripts are running than the smoothing applied when the 
user is interacting with the 3D model. To avoid a sudden camera snap at 
the end of a script, it is a good idea to avoid having any camera moves 
during the last second of a script, to give the viewpoint a chance to settle. 
The final camera event marker in a script also defines the user interface 
thereafter in a web product tour: center of rotation, limits on zoom, min 
and max elevation angle, etc. 

Scene Lighting: This track controls the position and intensity of the 
lights in the scene. To add more lights to the scene, use the Insert > Light 
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menu item. Each light in the scene will lower the update rate slightly, so 
avoid using more lights than absolutely necessary. 

Scene Orientation: If you think of the 3D scene as a photo studio, this 
track controls how the product being viewed is placed on the table. It is 
extremely rare that you will need to adjust the scene orientation, since the 
camera can be moved in a wide variety of ways. However, when the need 
arises, this track can be used. 

Sequences: The remaining tracks listed in the Add Track dialog’s pop‐
up menu correspond to sequences that have not yet been used in the 
current script. These might include sequences you’ve created or ones that 
were imported with your model file. 

Timeline & Track Editing 
At the top of the Scripts palette is a timeline for the script. Below the 
timeline are the individual sequences that make up the script. Right‐
clicking on the timeline, or on a sequence, brings up a menu of available 
operations: 

Edit 
This option is available if you right‐click on an event marker. Select it to 
open the editor for this event marker. Note that double‐clicking the event 
marker has the same effect. 

Set To > 
Allows quickly setting a camera event marker using a named view, or 
setting a sequence event marker using a named waypoint. 

Copy 
Copies the selected event marker. 

Paste 
Pastes a copied event marker. Note that you can copy and paste event 
markers between scripts. 

Delete 
When clicking on an event marker, this command deletes that event 
marker. On the track, this deletes the entire track. Note that intermediate 
event markers can be quickly removed by dragging them off the track. 

Insert Time 
Inserts more time into the script at the point where you clicked the 
mouse. Everything to the right of this point will slide to the right. 
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Delete Time 
Deletes time from the script at the point where you clicked the mouse. 
Any event markers to the right of this point will slide to the left. 

Change Duration 
Changes the overall duration of the script by moving all event markers 
proportionally along the timeline. You can use this option to effectively 
make the script play faster or slower. 

Add Time to End 
Adds one second to the end of the script. Note that clicking the + button 
at the top‐right of the palette, or on the 3D Remote (described below) has 
the same effect. 

Track Editing 
In addition to the right‐click menu commands outlined above, you can 
also edit individual tracks with the following options:  

• Each event marker on the track can be dragged to a different time in 
the script, or dragged all the way off the track to delete it (except the 
first and last event markers, which can only be dragged).  

• Double‐clicking on an event marker brings up the editor for that 
event marker.  

• Double‐clicking on the track adds an event marker and brings up the 
editor. 

Major time intervals (seconds and integral fractions of seconds) have 
“gravity” when editing: clicking or dragging near those points will snap 
to them. To temporarily disable this gravity, hold down the Ctrl key 
(Command key on Mac). 

To add more time to the end of the script, use the “ + ” button at the top‐
right of the palette. Each click adds one second. Typical use is to make 
plenty of room for the script, and then when all the editing is finished, 
use the “ – ” button to trim any excess time to the right of the last event 
marker. 

 

3D Remote Control 
When the Scripts palette is showing, there is a remote 
control also shown in the 3D View palette. From this 
remote, you can perform several of the functions 
available in the Scripts palette. Float your cursor over 
the buttons on the remote control to see text 
descriptions of their functions. 
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When you manipulate the state of an object, in the 3D View palette using 
the right‐click Sequence Disc pop‐up function, event markers are 
automatically added at the current time in the script being edited. To add 
a camera event marker, use the camera button on the remote control. 
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Preconditions 
Preconditions specify things that must 
be true in order for it to make sense to 
use this script. For example, a Box Open 
script would have Box Closed as its 
precondition. This way, the user is not 
presented with a Box Open button to 
choose when the Box is already open. By 
setting up preconditions correctly, 
Product Tour interfaces can be 
consolidated. For example, the Box Open 
and Box Close scripts, being mutually 
exclusive by their preconditions, can be 
assigned to a single “Box” button, which 
opens or closes the Box, depending on its current state. 

 

Click the Edit Preconditions button at the top of the Scripts palette. In 
this dialog you can select the state that any sequence must be in, in order 
for the current script to make sense to run. 

You can float your cursor over the Edit Preconditions button to see a 
tooltip with the list of preconditions currently being used by this script. 

Befores 
Befores are references to other scripts, which need to run before this 
script. For example, a Box Open script might have a Lock Open script as a 
Before. When the user chooses the Box Open animation from the Product 
Tour, the Lock Open script will run first. 

A good rule of thumb is: 

• Preconditions are about this object  
• Befores are about other objects 
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Click the Edit Befores button. In this dialog you can select which scripts 
need to run before the current script, adjust the order in which they run, 
and the rate at which they execute. 

You can float your cursor over the Edit Befores button to see a tooltip 
with the list of Befores currently being referenced by this script. 

For a more detailed description of how scripts are used for interactive 
animations, see Chapter 4, The Workflow, and Chapter 5, Live 3D 
Tutorials, below. 

Materials Palette 
This palette shows all the materials defined in the current Master Model. 
You can select a material using the 3D View palette by Ctrl-clicking 
(Command‐clicking on Mac) on the desired object. Note that you can do 
this even if the Edit Material dialog is open. 
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Inside the Materials palette, right-click on a material name to access a 
context menu. This menu contains three entries: Edit; Web Settings, and; 
Add Alternate. 

 

“Edit” Context Menu Command 
Selecting Edit from the context menu brings up the Edit Material dialog. 
The following controls can be found in this dialog: 
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Solid Color 
Use this pop‐up menu to choose a 
color for this material. The list 
contains colors already used in the 
model, and “Choose…” to add a 
new color. You’ll note that the 
colors in the pop‐up menu are 
designated in “hex” values. Hex 
values are often used in HTML 
coding to define colors. If you select 
“Choose…” the color picker will 
display the colors in both hex values 
and RGB. 

 

Texture Image 
Choose an image for this material. 
The list contains image files already 
used in the model, and “Import…” 
to add a new image. Note that only 
JPG, GIF, and PNG image formats 
are supported. 

Shader 
Choosing “None” will show textures and colors exactly as they appear, 
with no lighting effect. This is sometimes called “Self‐illuminated” 
lighting. The “Phong” shader allows the use of artificial lighting effects to 
improve realism for non‐photographic textures and solid colors. 

Ambient Intensity 
For the Phong shader, this controls the influence ambient light has on the 
material (global ambient light intensity is multiplied by this factor). 

Diffuse Intensity 
For the Phong shader, this controls the influence that directional light has 
on the material (each directional light intensity is multiplied by this 
factor, as well as by a factor based on the angle between the light and the 
surface). 

Specular Intensity 
For the Phong shader, this controls the influence that directional lights 
have on the specular highlights shown on the material. Specular 
highlights can be thought of as reflections of the light source. Specular 
highlights are always white, and not only add white to the surface, but 
also reduce material transparency. Note that specular intensity and 
glossiness together control the size of specular highlights. 
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Chrome Effect 
For the Phong shader, this effect makes materials look like metal or glass, 
instead of plastic. 

Glossiness 
For the Phong shader, this controls the size of specular highlights. 
Numbers approaching 1 will lead to smaller/sharper highlights. Note that 
surface normals are critical to these calculations: completely flat surfaces 
will never have specular reflections. For flat surfaces, a glossy surface will 
reflect light over a smaller range of angles than a less glossy one. Note 
that if Specular Intensity is set to zero Glossiness will have no apparent 
effect. 

Alpha 
This controls material alpha level (0 is transparent, 1 is opaque). Note that 
this attribute can be animated by a sequence. 

Backfaces 
Triangles that face away from the camera can be culled or displayed, 
depending on the setting of this control. In general, performance will be 
better with backfaces hidden. 

UV Wrapping 
For triangles with materials containing texture maps, UV coordinates 
approaching or exceeding the standard 0 to 1 range, this controls the 
display of texture beyond those coordinate values. Wrapping means to 
take the pixel from the opposite side of the texture, and not wrapping 
means to use the last pixel repeatedly. Note that this can be relevant even 
for materials which are mapped to exactly the 0 to 1 range, since texture 
coordinates are assumed to be on pixel centers, so anti‐aliased pixels may 
reach slightly beyond the maximum vertex texture coordinate value. 

Composite 
This controls the manner in which this materialʹs color values are 
rendered into the scene, similar to the way Photoshop layers can be 
combined. Use additive compositing for effects like fire, lens flare, or 
point lights. Use the “Multiply” setting for compositing effects like smoke 
or shadow masks. 

Library Save and Load Buttons 
These two buttons allow you to work with a Materials Library. Click on 
the Load button and the Open dialog appears. This dialog defaults to 
opening to the Materials folder that is located in your Strata Live 3D 
install folder. You’ll note that Strata Live 3D ships with a number of pre‐
made materials for you to use. 
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The Save button allows you to save your material creations. The Save 
dialog defaults to the Materials folder location as well. 

“Web Settings” Context Menu Command 
This command (accessed by right‐clicking 
on a material name from the Materials 
palette) is available for materials with 
textures. The command brings up the 
Web Settings dialog, which controls the 
way the texture map is stored in web tour 
applications. 

Scale 
This allows you to scale down the texture 
for use in web applications. Smaller numbers create a smaller texture map 
– the image will actually be smaller in pixel dimensions when saved out 
as a web Product Tour. 

Bit Depth 
This allows you to control the way each pixel is stored. 32 bit ARGB is 
required for materials that have a per‐pixel alpha channel. 24 bit RGB 
retains exact true color for materials with no alpha channel. It is 
extremely unlikely that you will need to use this format. The two 16 bit 
YCrCb formats represent color with 8 bits of intensity per pixel, and 16 
bits of chrominance spread over pairs of pixels (analogous to JPEG “422” 
encoding). Optionally, the 16 bit formats can use an error‐diffusion dither 
to conceal any color detail lost in color averaging process. 

MIP-Map 
When using textures that are high resolution, MIP‐maps will pre‐sample 
the texture at lower resolution to avoid “sparkle” in the texture as the 
object moves. This can be disabled, enabled, or enabled‐with‐blur. The 
blur option biases selection of MIP level toward lower resolution, and can 
be used to aggressively combat Moiré patterns that appear in some 
textures with repeating patterns (ventilation grills, for example). 

“Add Alternate” Context Menu Command 
This command turns the present material into a multi‐state material, as 
might be used to show different video screens, or for a script that offers 
viewer selectable material changes. Adding an alternate material also 
creates a sequence which controls which material is displayed. This 
sequence can then be accessed by any scripts you create. 

For additional tips on how to use materials, see section 4.2, Working With 
Materials, Textures and Shaders, below. 
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Chapter 4 

The Workflow 

Introduction: The Workflow Process 

In a typical project you will develop or locate your 3D model, import it 
into Strata Live 3D, “clean‐up” the model to make it more efficient for live 
presentations, perfect your materials, setup your lighting, create your 
views – and then script your interactivity. This chapter is laid out to 
follow this approximate workflow progression. 

4.1 Making Efficient Models 

Developing 3D models for real‐time applications creates some unique 
challenges. Whether you develop your own models for a given project or 
you get them from a client, co‐worker or model library, there can be many 
issues to think about. 

Strata Live 3D does a lot of this thinking for you by automatically dealing 
with the three key areas of optimization: decimation, compression and 
streaming. More detail on the proprietary ways in which Strata Live 3D 
automatically deals with these issues can be found in the Appendix of 
this User Guide. This section will only present the areas that may require 
some input from you to ensure the highest quality model at the smallest 
possible size. 

Optimizing the Original Model 
If your model was created for some other purpose – such as 
manufacturing, high resolution illustration, or movie special effects – 
you’ll find that there will likely be extra polygons, objects and high 
resolution texture maps that aren’t necessary for your Live 3D 
presentation. If possible, you’ll want to clean up or remove some of these 
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objects prior to exporting the model for use in Strata Live 3D. Some of the 
issues of concern include: 

• Small Details (nuts, bolts, etc.) 
• Hidden & Unused Details (internal machinery, components, etc.) 
• Fine Details (high polygon count representation of surfaces) 
• High Resolution Textures (images that are meant for very close 

examination in the original model but may not see such scrutiny in 
your Live 3D presentation) 

If you don’t have access to the original modeling application, or you’ve 
done all you can within that application to simplify the model, Strata Live 
3D provides some very powerful technologies to improve the situation. 
As mentioned, many are automatic and done in the background. You 
have full control over two of the most important tools: Level of Detail and 
Texture Map optimization: 

Using Level of Detail (LOD) 
Strata Live 3D includes a very powerful polygon decimation, or 
reduction, technology that allows you to reduce the polygon count of any 
object while maintaining the overall shape. This technology is accessed 
through the Level of Detail dialog. 

The Level of Detail dialog is accessed by right‐clicking on the object’s 
name in the hierarchy on the main Strata Live 3D palette and then 
selecting the Generate LOD command from the contextual menu. All the 
functions of this dialog are outlined in detail in the Strata Live 3D Main 
Palette section of Chapter 3, The Workspace. 

Once you’ve created a reduced polygon LOD for your model, Strata Live 
3D will use this representation of the object for all exported Product 
Tours and Walk‐throughs. 

Generating an LOD Model 
There are two basic approaches to generating lower levels of polygons for 
you model using LOD: Selectively reducing portions of your model, or; 
Reduce all of the parts of your model, then selectively “up-res”, or 
increase the resolution of selected parts of the model that need greater 
detail. 

For complex models it may be easier to use the reduce all approach. To 
do this, select the top element in the hierarchy view of the main Strata 
Live 3D palette (this will typically be the name of the model that you have 
imported into Strata Live 3D) and right‐click on the object name. This will 
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bring up the contextual menu. Select 
“Generate LOD”. The Generate Level of 
Detail dialog will appear.  

In the dialog, drag the Triangles slider to 
the far right. Now click on the Generate 
LOD button. A progress dialog will 
appear showing the progress and 
displaying the number of polygon 
reduction in the title bar of the progress 
dialog. When you look at your model in 
the 3D View palette you may be able to 
see the affect of the reduction of polygons. 

To selectively adjust the LOD for your 
model – whether to “up‐res” portions 
after using the reduce all approach, or to 
selectively reduce the detail of 
particular sections – you simply select the 
object in your model that you want to 
adjust and use the Generate LOD command from the contextual menu. 
You can select parts of your model directly in the 3D View palette by 
holding down the Shift key and clicking on the object you want to select, 
or you can use the hierarchical view to select the object directly by name. 
Either way, once the object is selected, it will appear shaded in red (both 
in the 3D View and in the Hierarchical view). Right‐click on the selected 
name in the main palette and select Generate LOD. Adjust the LOD to a 
desired level for the object. 

 

The reduction of polygons is non‐destructive – meaning that detail is not 
actually lost, Strata Live 3D just provides this lower level of detail as an 
alternative view of the model which is then used for Export operations.  

To see the individual polygons (and the explicit result of your LOD 
generation), select View > Wireframe > On from the main menu. The 
model will now show the wireframe of the polygons overlaid on your 
model. You can compare the full polygon structure of your model to the 
reduced version by selecting View > Level of Detail > Highest. Your 
model will now display the original level of polygon detail. Select View 
> Level of Detail > Lowest to return to the reduced LOD. 
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Using Web Settings for Material Optimization 
You can directly optimize texture maps 
for web and other Product Tour projects. 
To access these settings, open the 
Materials palette and then right‐click on 
any material that contains a texture map. 
You will see a context menu with three 
commands: Edit, Web Settings and Add 
Alternate. We will only concern ourselves 
with Web Settings in this part of the 
User Guide. For a detailed explanation of all three of these commands, 
see the Materials Palette section above.  

NOTE: If the Web Settings command is grayed out when right‐
clicking on a material name it is because there is no texture map 
contained in that material. Web Settings only apply to texture 
maps. 

On selecting the Web Settings command from the context menu the Web 
Settings dialog will be displayed. This dialog offers three areas of 
control: Scale, Bit Depth and MIP-Map. 

Texture Map Scale 
The texture map scale is a relative setting. What this means is that if you 
keep the starting setting of 1.000 as the scale, the texture image map will 
be output for your web Product Tour at the same size that it is currently. 
If you input a scale setting of 0.500 the map will be reduced in size by 
50% horizontally and 50% vertically – which is actually 25% of the 
original size (because the effective size of the image is equal to splitting 
the image 50% from the top and 50% from the side – the size is equal to 
one of those four pieces left from these splits – the image is then sized 
down to fit that new dimension). 

As you can see from the above description, reducing the size of the map 
scale has a large effect on the overall size of the image. To determine what 
setting is best for your project, think in these terms: 

• How important is the detail in this particular texture map? 
• How close will the viewer ever get to the surface the material is 

applied to? 
• If the texture map were to appear “fuzzy” on the few occasions the 

viewer does get close, how big a detriment is that?  
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Once you can answer these types of questions you are ready to choose a 
setting for the texture map scale. 

Texture Map Bit Depth 
The important thing for “Bit Depth” is that you want to go as low as you 
can. Typically the most efficient setting will be 16 bit YCrCb with 
dithering. Similar to selecting a texture map scale, for bit depth you want 
to make a qualitative judgment about how the texture will be seen by the 
end viewer of the presentation. Issues to consider are these: 

• Does the texture map include an alpha channel? If yes, is that alpha 
channel truly important to the material? If yes again, you need to use 
32 bit ARGB to maintain the alpha channel on output. 

• Is the texture photo‐based and does that photograph use a wide 
range of colors? If yes, how important is it to maintain that true color 
fidelity for this presentation? If you feel it is important, and there is 
no alpha channel involved, then you may want to use 24 bit RGB. 

• If you feel the texture can be satisfactorily displayed in 16 bit color, 
you’ll want to choose between dithered and non‐dithered. In almost 
all cases you’ll want to utilize the dithered option. Dithering is a 
process of mixing individual colored pixels from a limited palette of 
colors, and into a loose pattern, to gain the illusion of a wider color 
spectrum. The only time you may want to use “undithered” would be 
when you expect the viewer to magnify the model to the point where 
the dithering becomes more of a distraction than a help. 

Texture MIP-Mapping 
Though this setting has more to do with avoiding Moiré patterns on large 
textures, it can be a useful tool for optimization in this sense: When you 
do decide to reduce the resolution of some of your texture maps, you’ll 
want to make sure that any high resolution texture maps work well – and 
are worth the size commitment you make. Additional tips on maximizing 
your use of textures can be found later in this chapter. 

Setting Compression Parameters 
Overall compression parameters can be accessed by selecting the menu 
command Edit > Compression Parameters from the main menu. This 
command brings up the Quality-driven Compression Parameters 
dialog. 
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As the name implies, compression in Strata Live 3D is quality‐driven, 
meaning that the system attempts to meet a quality goal and is not tightly 
constrained by specific parameters you input. 

 

The Common Settings cluster of options deals with wavelet 
compression parameters, which are used for image compression. This can 
be a very complex process and so we recommend you use the Custom 
Settings pop‐up menu at the top of this section of the dialog. 

Wavelet compression is similar to JPEG in some regards. Wavelet 
produces superior results relative to JPEG, providing smaller file sizes 
and better image quality. Wavelet is especially good for photo‐based 
texture maps. 

If you turn on the Paletted Compression checkbox you allow the 
wavelet compression to take into account a reduced palette, similar to the 
way GIF compression works. 

The Recompress JPEG and GIF checkboxes allow the wavelet 
compressor to recompress images that may already have been 
compressed by you before you brought them into the model. If you have 
the option, it is best to bring in the highest quality images you can into 
the model. This allows the wavelet compressor a better starting point to 
work from to compress the images. 

The two “Quantize” menus allow you to set the desired bit depth for 
coordinate accuracy – the lower the number the better the compression. 
You do run the risk of rendering anomalies in the final exported Product 
Tour, so make sure you fully test your final work. 
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The Geometry Weld Threshold field lets you set the system tolerance 
where two vertices will be “welded” together. The higher the number, the 
more vertices will be combined into one vertex – and the more the model 
will compress. However, as with all compression techniques, you do run 
the risk of quality degradation and/or rendering anomalies. 

Use the Palettes > Preview Compression command from the main 
menu to preview the compression techniques you’ve learned from this 
section. 

4.2 Working with Materials, Textures and Shaders 

In Strata Live 3D, imported objects will typically have some material or 
texture already applied to them. Often, these imported textures and 
materials don’t take full advantage of the real‐time effects possible in Live 
3D. In this section we’ll discuss how you can add these effects to your 
materials. 

To edit these existing materials, open the Materials palette. You can open 
the Materials palette in a couple of ways. You can select Palettes > 
Materials from the menu bar or you can click on the object while 
holding down the Ctrl key on PC or the Cmd key on Mac. 
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The Materials palette displays all the materials which are applied to the 
objects in your model. Materials are shown by name in a hierarchical 
view under the name of the object they are applied to. To edit an 
individual material, right-click on the material name and select Edit. 
This will bring up the Edit Material dialog.  

The individual controls in the Edit Material dialog are outlined in detail 
in the Materials Palette section in Chapter 3. Rather than detail each of 
those controls here, we’ll instead discuss strategies for getting the desired 
look for particular materials. 

Getting the Right Look 
One easy way to get the right look for your objects is to take advantage of 
the Materials Library that ships with Strata Live 3D. These can be 
accessed from the Edit Material dialog using the Load button near the 
bottom of the dialog. To understand how to create your own effects and 
what some of the materials settings can do for you, read on. 

Chrome 
You can add a “chrome effect” to any material by editing it in the Edit 
Material dialog and using the “Chrome Effect” field. You can edit this 
field (and all fields in this dialog) in three ways: by directly entering a 
number, clicking on the up and down scroller arrows or by clicking and 
dragging up or down on one of the scroller arrows. As you drag on a 
scroller arrow you will see the numbers go up or down proportionately. 

While adding the Chrome Effect you will notice a couple of things. First is 
that the Specular Intensity field matches the numerical changes of the 
Chrome Effect field. This is set up this way because Specular Intensity has 
a direct affect on the Chrome Effect. Specular Intensity does just what the 
name implies – it affects the intensity, or brightness, of the specular 
intensity. You can directly edit the Specular Intensity to change its 
proportional relationship to the Chrome Effect field. Make sure you 
watch the change in effect of these settings in the 3D View palette to 
ensure you get the desired result. 
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Another thing you will notice is that changing the “Glossiness” setting 
will have an affect on how the Chrome Effect works on the surface. The 
higher the number, the tighter (and likely smaller) the specular highlights 
will be. Tight, bright specular highlights typically indicate a highly 
polished surface.  

 

Playing with all three of these settings – Chrome Effect, Specular Intensity 
and Glossiness – provides total control over this effect. 

Glass 
To create a glass effect you need to alter several settings in the Edit 
Material dialog box. Readers who use 3D rendering software will find 
these issues to be familiar. You need to decrease opacity (referred to as 
Alpha in the Live 3D Edit Material dialog). That’s plain enough. But in 
order to achieve an appearance of a glass‐like material you need to 
modify a couple of other settings as well. 

To look like glass, a material must have a lowered Alpha (to provide 
transparency as previously stated), lowered Diffuse Intensity (more of 
the surface’s light contribution should be coming from the background 
via transparency and less from diffuse light reflecting the surface colors), 
increased Glossiness (you expect a glass surface to be somewhat 
glossy) and increased Specular Intensity (glass surfaces tend to be 
more polished than “frosted”). When you adjust this combination of 
settings you can begin to get a convincing glass surface.  
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Using Alpha/Stencil Maps 
 

Strata Live 3D supports using per-pixel alpha transparency in textures 
(also known as Stencil maps in Strata 3D CX). This can be useful, for 
example, for creating ventilation grills without using excessive geometry. 
These are the steps to follow: 

1. Create your color image map with an alpha mask and save as a PNG 
file. PNG is currently the only file format supported by Strata Live 3D 
that will read in the alpha transparency information. To create a PNG 
with alpha transparency using Adobe Photoshop:  

a. Use the “Add Layer Mask” button on the bottom of 
Photoshop’s Layers palette.  

b. Paint the transparent areas in the mask. Any dark paint in the 
new mask will create areas of transparency.  

c. Once you have the layer mask defining areas of transparency, 
choose “Save As…” from Photoshop’s Edit menu. The Save 
As… dialog will appear. From there select PNG from the 
Format pop‐up menu and then save the file. 

2. Next, Open or Import the model into Strata Live 3D on which you 
wish to use the texture map with alpha transparency.  

3. Open the Materials palette by selecting Palettes > Materials from 
the main menu.  

4. Find the material applied to the object and right‐click on the name. 
From the pop‐up context menu select “Edit…” This will open the 
Edit Material dialog. 

5. From the Texture Image pop‐up menu select “Import…” Find the 
PNG image using the Open dialog and open it. It will now be loaded 
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into the Texture Image channel of the Material. In the 3D View palette 
you should see areas of transparency on your object. 

6. Make any other adjustments you’d like to make on the material and 
then click on the OK button.  

7. From the Materials palette, right‐click on the material name again, 
but this time select “Web Settings...” from the menu. The Web 
Settings dialog will appear. For “Bit Depth”, select “32 bit ARGB”. 
This tells the 3D View palette that you want to use Alpha channels for 
your export, so a full 32 bit color representation is required. 

NOTE: If you’re using alpha transparency for a ventilation grill 
or other repeating pattern, it might be a good idea to set the MIP‐
map setting to “On with Blur” as well while you’re in the Web 
Settings dialog. This setting forces the MIP‐level selector to bias 
toward the lower resolution texture, which can help reduce Moiré 
patterns. 

Pixel‐level alpha transparency is in addition to the overall material level 
alpha transparency (which you can also change in the Edit Material 
dialog using the “Alpha” numerical setting – or you can animate 
transparency with a sequence). And both of these are in addition to 
Object‐level alpha, which you can expose simply by making an object 
public (right‐click the object in the hierarchy view and use the menu 
items). 

PERFORMANCE NOTE: Using alpha channels of any kind 
requires that the rendering be sorted for every scene, to ensure 
parts layer correctly. This can slow update rate for very large 
scenes, so use alpha channels only when needed. 

Natural Surfaces 
One of the best ways to get natural looking materials is to utilize actual 
photographs for your texture maps. Photos with lighting already “baked 
in” help to show features such as bumps, dimples, cracks, etc. This is one 
of the reasons that Strata Foto 3D is ideal for creating models for Live 3D 
– the surfaces are based on actual photographs of the object. 

An ideal baked‐in texture will be one that was originally shaded as if 
wrapped around the object you’re applying the texture map to. In our 
Saber Dino tutorial model, the texture map for this (and the geometry for 
that matter) came from Strata Foto 3D. This means that the belly portion 
of the texture map (for example) is shaded a bit darker than the top of the 
Dino’s back. 
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When using these “pre-lit” texture maps you very well may want to let 
the existing lighting of the map shade the object. To let this existing map 
lighting show through you’ll need to turn off local lighting from any 
light sources that may be in your model. You can do this for the entire 
model and all materials that are applied to all surfaces, or you can 
selectively turn off this lighting on a material by material basis. 

To turn off lighting for all materials, go to the main menu and select Edit 
> Change All Materials > Light None. You will see an immediate 
change in the lighting of your surfaces. To change the lighting for selected 
materials, hold down the Ctrl key (PC) or Cmd key (Mac) and click on the 
surface that you want to turn off lighting for. The Materials palette will 
come up with the clicked‐on material selected. Right‐click on the selected 
material and select Edit from the pop‐up menu. In the Edit Material 
dialog, Shader field, select None from the pop‐up menu to the right. 
The Phong shader calculates the effect of the local lights. Turning off 
Phong will let the baked‐in lighting fully show through. 

Animating Materials 
Details on the process of creating animation scripts in Strata Live 3D can 
be found below in Creating Basic Interactivity. In a nutshell, to create 
animation scripts, you first create a “sequence”, then utilize one or more 
sequences to develop a script. 

To create an animating material sequence, choose Insert > Sequence 
from the main menu. The Insert Sequence dialog appears and from 
there you select the Material sequence radio button. Once you click OK, 
the Edit Sequence dialog appears and you’re given the option to 
animate the Alpha and/or a color Curve for the materials you select. 

To specify a set of materials to animate, you press the Select… button 
and select the desired materials from the list. To animate the alpha value 
of the selected set of materials, first click the corresponding Animate 
button, and then type in the alpha value desired for the current 
waypoint. To apply an animated color curve to a set of materials, click its 
Animate button, and then click the Edit… button to open the curve editor. 

Once your sequences are created, youʹre ready to build the scripts. As 
mentioned, this process is similar, whether youʹre scripting a lid opening 
or a material fading. Just follow the process outlined in Creating Basic 
Interactivity to learn more. 
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4.3 Working with Lighting 

There are basically two key aspects that affect your lighting: emitted 
light and reflected light. In Strata Live 3D, light sources emit light to 
illuminate the scene. How that light effects the surfaces is controlled by 
the material applied to the surface. 

Light Sources 
Strata Live 3D provides both ambient and directional light sources. By 
default, a model will have three directional light sources along with the 
base ambient light. These light sources affect all surfaces with materials 
where the shader is set to Phong. 

Ambient light is provided to give a general fill level of light. By using 
ambient light, no surface will be totally unlit. Even an area that has no 
directional light hitting it will have the minimum setting of the ambient 
light. 

Directional lights are similar to sunlight in that they are effectively an 
infinite distance away from the model. 

Editing Lights 
To access the Scene Lighting editor open the Sequences and Views 
palette and click on the “Scene Lighting…” button.  
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When you click on the Scene Lighting button, the Lighting Editor appears 
on the 3D View palette. On the left side of the editor is the ambient light 
slider. Typically, it will be set at about 10%. 

 

The circular controllers and the adjacent sliders each represent one light 
source. The cross‐hair icon is the light indicator for the position, or 
direction, of the light source. The center of the circle represents the top 
down view of the scene, the left side the left, the right the right, and so on.  

Think of the circle as an unwrapped sphere. If you could take a flexible 
cover off of a ball by pulling it open from the bottom and stretching it out 
flat, that is what this controller represents. Anywhere on the outside ring 
represents the bottom of the lighting sphere. The circle line in the middle 
represents the side of the lighting sphere – or the equator if you will. If 
you place the light indicator cross‐hair on the right side of the equator 
line the light will come directly from the right side. The center of the 
circle represents the top – place the light indicator icon there and the light 
will come from the top. 
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Of course, you can individually adjust the intensity of each of these lights 
by using the vertical slider to the left of each circle controller. 

 

Adding Lights 
To add a light, go to the main menu and select Insert > Light. Choosing 
this command inserts a light, opens the Sequences and Views palette (if 
not already open), opens the Scene Lighting dialog and applies the 
Scene Lighting editing overlay on the 3D View palette to allow you to 
position the light and set its intensity. 

Animating Lights 
Light source position and intensity can be animated. This is done just like 
animating all other aspects of the model – by using scripts. However, 
with lights you bypass the sequence procedure and go straight to 
scripting. 

Here’s a quick tutorial on how to animate your light sources: Select 
Insert > Script… The Scripts palette will open with the Append Script 
dialog floating on top of it. Click cancel to dismiss the Append Script 
dialog. Now, a smaller dialog will appear named “Add Track”. From this 
dialog select “Scene Lighting” from the pop‐up menu and click OK. 

Now click twice on the “+” icon on the 
upper right of the Scripts dialog to add 
two seconds to the track. You’ll note 
that there are event markers at the 
beginning of the track but none at the 
end. Click on the event marker and 
drag it to the right to the end of the 
track. The original marker stays put 
and a new marker is added to the end 
of the track. 
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Right‐click on your new event marker at the end of the track and select 
“Edit” from the pop‐up menu. You’ll notice that the Edit Lighting dialog 
comes up in the Scripts palette and the Scene Lighting editor overlays 
on the 3D View palette. Make any desired edits. Move the light positions 
and/or intensity. When you’re done click the OK button on the Edit 
Lighting dialog. 

Now when you click on the play button in the Scripts pallet you’ll see the 
lights animate from the position they started at to the positions and 
intensity you changed them to in the final event marker. 

Shadows 
Shadows in Strata Live 3D are highly efficient and designed for 
maximum “readability”. With a floor shadow the sense of dimensionality 
is greatly increased. 

These shadows are created by rendering the silhouette of the scene in a 
top‐down view onto a low‐resolution texture. When this low‐resolution 
texture is rendered with linear filtering, it achieves a soft shadow effect, 
without having to do an expensive “convolution” operation. 

For more about shadows and how you can edit them, see the section 
below on editing the HTML export file. 

Materials and Their Effect on Lighting 
The way in which light reacts with the surface of an object is controlled 
by that object’s material. With Strata Live 3D you have controls to make a 
material ignore the effect of light sources and use the inherent luminosity 
of the texture map itself – or you can greatly enhance the effect of the 
light sources through the material controls.  

Illuminating the Surface Using Textures 
This is the feature described as “pre-lit” or “baked-in” lighting. To use 
the inherent luminosity of the texture map (such as photo‐based texture 
maps) you need to turn off the effect of the light sources by turning off 
the Phong shader used in the material. You can do this globally for the 
entire model or on a material by material basis. 
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To turn off the lighting effect on a global basis, go to the main menu and 
select Edit > Change All Materials > Light None. 

 

To turn off the effect on an individual material, open the Materials palette 
(Palettes > Materials) and right‐click on the texture name and select 
“Edit…” In the Edit Material dialog select None from the Shader pop-up 
menu. 

Enhancing Lighting Using Materials 
If you’re not using a pre‐lit texture as the sole way to light your object 
then the material settings dictate how your light sources reflect off of the 
surface. These settings can be altered on a material by material basis or 
you can utilize menu commands to make global changes.  

The following section deals only with the material settings that directly 
effect lighting. For a more detailed description of the settings in the Edit 
Material dialog see the Palettes section in Chapter 3. 

Individual Light Reflection Material Settings 
To access the individual material settings select the Palettes > Materials 
menu command. From the Materials palette right‐click on the name of the 
material you want to alter and choose the Edit command from the pop‐up 
context menu.   

NOTE: All of the following settings rely on setting the Shader 
pop‐up menu to Phong. The Phong shader creates shading by 
calculating how the light sources in your model will affect the 
color, value and highlights on the object surface. 

77 



STRATA LIVE 3D User Guide – Chapter 4 
The Workflow 

78 

Ambient Intensity 
This controls the influence ambient light has on the material (global 
ambient light intensity is multiplied by this factor). 

Diffuse Intensity 
This controls the influence directional light has on the material (each 
directional light intensity is multiplied by this factor, as well as by a factor 
based on the angle between the light and the surface). 

Specular Intensity 
This controls the influence directional light has on the specular highlight 
shown on the material. Specular highlights are always white, and not 
only add white to the color, but also reduce material transparency. Note 
that specular intensity and glossiness together control the size of specular 
highlights. 

Glossiness 
This controls the size of specular highlights. Specular highlights can be 
thought of as reflections of the light sources themselves. Numbers 
approaching 1 will lead to smaller specular highlights.  

NOTE: Surface normals are critical to these calculations. 
Completely flat surfaces will never have small specular 
reflections. For flat surfaces, a glossy surface will reflect light 
over a smaller range of angles than a less glossy one. 

Global Material Light Reflection Settings 
There are two global light enhancing settings that can be accessed from 
the Edit menu on the main menu bar. Select Edit > Change All 
Materials > to see the following light enhancing menu commands: 

Light All Matte 
This sets all materials to use a Phong shader, with no specular highlights. 
Specular highlights are reflections of light sources. Without these 
highlights surfaces are perceived to be dull and non‐shiny. 

Light All Specular 
Converse to the above, this setting changes all materials to display 
specular highlights, making all surfaces appear glossy. This is done by 
using a Phong shader with a specular intensity of 1. 

Normals, Smoothing and Their Effect on Lighting 
This section explains how Strata Live 3D uses smoothing groups to 
compute vertex normals. If you are having issues with the way your 
models are lit in Live 3D, particularly if you notice differences when the 
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model is published to the web, this section has important information for 
you. 

For models which use Phong shading, the shade of the surface color (or 
texture), and the behavior of specular highlights, are all controlled by 
vertex normals. A vertex normal is a 3D vector, or line, which indicates 
the direction the surface is facing at that vertex. A vertex is the point 
where polygon triangles meet. In Strata Live 3D, as in almost all 3D 
modeling programs, the vertex normals are computed by averaging the 
surface direction of triangles touching that vertex. This leads to smooth 
shading across the transition from one triangle to another, making a 
fundamentally polygonal object look smooth and rounded. 

In some cases, you do not want adjacent faces to have smooth shading. 
Suppose you have modeled a cube. Averaging face normals to compute 
the vertex normals leads to strangle lighting effects, since the boundary 
between faces actually should be a sharp edge in the case of a cube. In 
Strata Live 3D this is handled by smoothing groups. Each face of the box 
can be placed into a different smoothing group, and when vertex normals 
are computed, a single vertex will end up with multiple normals, 
depending upon which face is being shaded.  

These smoothing groups can be obtained in six different ways: 

1. If you use Strata 3D CX to build and prepare your models, using the 
Render to Live 3D function outputs a native Strata Live 3D XMM file. 
This file retains all the smoothing groups and normal calculations 
from the original Strata 3D CX model. 

2. If you use 3ds Max, and the Strata export script (use the Help > 
Extras menu item), then the smoothing groups used by 3ds max are 
used directly by Strata Live 3D. The only catch is that Live 3D only 
support 24 smoothing group bits, not 32 like Max, so you need to 
make sure you only use the bottom 24 smoothing groups. 

3. If you use a 3D program that exports normals into the VRML file, 
Strata Live 3D will look at those normals and compute smoothing 
groups which match the normals as closely as possible at import time. 
Note that many 3D programs have a checkbox in the exporter to 
choose whether normals are exported: make sure you turn it on! 

4. If you use a 3D program that does not export normals (such as 
Lightwave), Strata Live 3D will look at the topology of the mesh. If 
two faces share a vertex (and the vertices are “welded” into one 
vetex), then they will be placed in the same smoothing group. If two 
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faces share a vertex location but use different vertices (the vertices are 
“split”), then the faces will be placed into different smoothing groups.  

5. After import, you can assign new smoothing groups to any object by 
right‐clicking it in the hierarchy and choosing the Object Smoothing 
command from the menu. This command allows you to compute 
smoothing groups based on the angle between faces. 

6. When you use the Generate LOD feature to reduce polygon count, 
you can also generate new smoothing groups as part of that 
operation. Suppose you have a cube with a finely rounded edge. In 
this case, a single smoothing group leads to attractive lighting effects. 
But suppose you need to eliminate this fine edge while generating 
LOD to reduce triangle count. After decimation, it is better to have 
the adjacent faces in different smoothing groups. By using the 
Resmooth Normals feature of the Generate LOD panel, you can 
make this correct at the same time you decimate the mesh. 

Although it is rare, sometimes after compressing your model for the web, 
the lighting will change. This can happen because one step of web 
compression is welding. Vertices which are very close spatially are 
automatically welded together, to save space during compression. If the 
smoothing groups are correct, this will have no impact on the visual 
appearance. But if the smoothing groups do not accurately describe the 
way lighting should be after welding, then edges that were sharp can 
become smooth. 

To correct this, right‐click the problem object in the object hierarchy, and 
choose Generate LOD. Move the “Triangles” slider slightly to the right, 
and do a decimation. Generating LOD also welds vertices, as well as 
giving you the opportunity to compute new smoothing groups. 

4.5 Setting Your View 

In addition to freely rotating, moving and zooming your view from the 
3D View palette, you can also modify the base view the Navigation Bar 
Reset button resets to, create additional views and even animate 
views. 

Modifying the Default “Reset” View 
The default view – the one your scene goes to when you click on the 
“Reset” button in the 3D View palette – can be modified in virtually 
any way you like. 
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To modify the view, open the Sequences and Views palette. From the 
“Jump to View” menu, in the upper left corner, select “Initial”. Just to 
the right of the Jump to View menu is the “Change View Definition” 
button. Click the button and the Edit Camera dialog comes up. 

The dialog contains four tabs: Basic, Detail, Limits and Advanced. 
Click on the tabs and review the available controls. The options are fairly 
self explanatory and you’ll note that you have control over every aspect 
of the camera.  

 

While the Edit Camera dialog is open, you can also make your changes to 
the camera by making adjustments directly in the 3D View palette. 

Once you make changes to your camera, click on the OK button. Now, 
after you alter the view in the 3D View palette, when you click on the 3D 
View palette’s Reset button, the view will return to the one you defined 
using this procedure. 

Creating Additional Views 
You can create additional defined views by clicking on the Create New 
View button in the Sequences and Views palette. The Edit Camera dialog 
comes up allowing you to define the camera in any way you like. You’ll 
want to give the new view a descriptive name (edit “Unnamed” at the top 
of the dialog) and click the OK button. You can see your new view in the 
Jump to View pop‐up menu. 

Animating Views 
To animate views you simply define multiple views by using the Create 
New View button in the Sequences and Views palette. Once you have 
the views created to define two or more key points in your view 
animation, you’re ready to move on to creating the animation script. 

Select Insert > Script… from the main menu. The Scripts palette will 
open with the Append Script dialog floating on top of it. Click cancel to 
dismiss the Append Script dialog. Now, a smaller dialog will appear 
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named “Add Track”. From this dialog select “Camera” from the pop‐up 
menu and click OK. 

Add the amount of time you want for the view animation by clicking on 
the “+” icon on the upper right of the Scripts dialog. You’ll note that 
there’s only one event marker on the track. 

Right‐click on the event marker and select “Set To” from the pop‐up 
menu. Choose the view you’d like to use for the beginning of your 
animation. Now, right‐click on the track time‐line where you’d like your 
next event marker. Again, choose Set To from the menu to select the pre‐
defined view you’d like to use for the next step in your animation. 
Continue this process until you have all of your views represented on the 
track as event markers in the positions in time where you want them. 
Now click the Scripts palette Play button. You’ll see the view animating 
in the 3D Views palette.  

 

NOTE: Don’t forget to use the Rename button to give your 
camera script a recognizable name. This will be important for 
button names, reusing the script to create reverse scripts and 
more. 

4.6 Rendering Options 

If you export a Web Tour you have the ability to overlay a sketch mode 
style of drawing on your textured models, or you can go to a full sketch 
mode where no textures show through. 

82 



STRATA LIVE 3D User Guide – Chapter 4 
The Workflow 

As of this writing the only way to access this feature is through the HTML 
code that is output with you web tour. Though not a terribly complicated 
process, it does require that you delve into the HTLM code. You can learn 
more about how to do this in Editing the HTML File in the Export and 
Editing Options section below.  

 

4.7 Creating Basic Interactivity 

Strata Live 3D uses “scripts” to create animations and interactive 
elements. Don’t let the word “scripts” scare you though – all scripts are 
created with easy to use event markers, dialogs and buttons. Scripts are 
assembled using “sequences” and “views” that have either come in 
with your model file or that you build yourself from within Live 3D. 

Interactivity Workflow 
The starting point is to create sequences that contain “waypoints”. 
Waypoints can be thought of as keyframes for the sequence. These 
waypoint keyframes can then be used in a script track as event marks 
and placed precisely where you want them on the timeline. You can even 
reuse waypoints as many times as you like within a script track.  
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The exceptions to this waypoint process is in animating views and 
lights. For views, you create individual new views in the Sequences and 
Views palette. These views are then used to create event marks on a script 
track timeline, just as if they were named sequences. The process of 
creating sequences and using them to create scripts is described more 
fully later in this section. 

 

For lights, you go straight to inserting a script by using the Insert > 
Script menu command. From there you select Scene Lighting from the 
Add Track dialog box. Drag out the starting event marker to make 
additional markers. From there, right‐click on the event markers to bring 
up the Scene Lighting overlay. For a much more detailed description of 
this process look in the Animating Lights section above. 

Preparing Sequences and Views 
Usually, you’ll want to prepare your sequences and views prior to 
assembling them into scripts. Both sequences and views can be created in 
third party applications, such as Strata 3D CX, and brought in with the 
imported model file. You can also assign sequences to static model data. 

Imported Sequences 
Animated orientation and position data can be imported in as sequences 
with waypoints into Strata Live 3D. When using Strata 3D CX you have 
the option of which types of data to export with your XMM file. To bring 
in data from other applications you will use the VRML file format. The 
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level of support for animation varies with the application – so check the 
documentation of the 3D product you use to see what features are 
supported in their VRML output. 

New Sequences 
To create a new sequence, choose Insert > Sequence… The Insert 
Sequences dialog appears. You’re given the option to create either an 
Object sequence or a Material sequence. Either of these can be set to be a 
“Discrete”, or non‐interpolated, sequence. 

If you select Object sequence, the dialog provides a pop‐up menu 
allowing you to select an object from your model to use for the sequence. 
In either case, when you click the OK button, you’re provided with the 
Edit Sequence dialog, which is discussed in the next section.  

Editing Sequences 
When editing a sequence, whether it’s an imported sequence or one 
you’ve created using the Insert > Sequence command, you are presented 
with the Edit Sequence dialog box. To access the dialog on a 
preexisting sequence, open the Sequences and Views palette and click on 
the Edit button to the right of the listed sequence’s slider.  

One of the first things you’ll want to do is provide a logical name for the 
sequence – such as Box Open. This follows an important convention in 
Strata Live 3D. The first part of the name should be the object being 
animated and the second part should be the operation being performed. 
You will see the importance of this as you move through your scripting 
process. 

 

85 



STRATA LIVE 3D User Guide – Chapter 4 
The Workflow 

86 

The Waypoint List 
The left side of this dialog is identical, regardless if you’re editing a 
material based sequence or an object based sequence. This left side 
contains the list of waypoints currently contained in the sequence. Using 
a row of buttons across the bottom of this section, you can choose to add, 
clone, delete and move waypoints within the overall order. Individual 
waypoints in the list can be selected for further editing in the right side 
section, Waypoint Details. 

Waypoint Details 
The contents of the Waypoint Details section vary depending on whether 
you’re editing an object based sequence or a material based sequence. For 
all waypoints – as with sequences and scripts – it’s important that you 
provide logical names for your waypoints. The Name field at the top of 
the Waypoint Details section allows you to name the waypoint. 

Object based sequences allow you to edit the object’s position, orientation, 
location of the pivot, and the object’s opacity. Material based sequences 
allow you to edit the material alpha, and apply a color curve filter to the 
material. For material sequences, you specify a set of materials to animate 
by pressing the Select… button and select the desired materials from the 
list. 

You can read more details about the Edit Sequence dialog in the Palettes 
section of this User Guide. 

Building Scripts 
Once you have your sequences created (or views in the case where you 
want to script view animation) you’re ready to build some scripts. 
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New Scripts 
To create a new script select the menu 
command Insert > Script… This 
command brings up the Scripts palette 
and the Append Script dialog. To create a 
new script you’ll want to click Cancel on 
the Append Script dialog. Next you’ll see 
the Add Track dialog. From here you can 
select the sequence you want to use for the 
new script from the pop‐up menu. 

Now you have the beginnings of a new 
script. You’ll notice that the script is listed 
as “Unnamed” in the upper left of the 
Scripts palette. Even though the sequence 
you’re starting from has a name, the script 
is unique and should have a unique name. 
But more than just a unique name, the name should conform to the 
following convention [name of object] plus [action or operation] – for 
example, Box Open. 

 

Following this naming convention is important in order to take 
advantage of Live 3D’s built‐in heuristics logic. If you go through the Ball 
in Box tutorial below, you’ll see that after creating the Box Open script, 
the reverse of this script is automatically named Box Close and even the 
preconditions are automatically set. 

To rename your script, click on the Rename button at the top of the 
Scripts palette. 

Once you’ve inserted your new script you can add additional event 
markers. Some sequences will come in with more than one event marker. 
Some will come in with only one event marker at the beginning. 
Regardless, you can add event markers in a few ways.  

If you drag the first event marker to the right you will see that it makes a 
copy and leaves the first event marker in place. You can also right‐click 
on the track of the sequence you wish to add an event marker to and 
select Set To >.  If the track doesn’t represent a sequence that you’ve 
properly prepared, the Set To > menu item may not have any items in it – 
Set To > will only show named waypoints. You can also double‐click 
anywhere on the track to insert a new event marker. 
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You can edit any existing event marker by using the above described 
right‐click menu and choosing Edit or Set To >. You can also double‐
click on an existing event marker to edit it. 

Appending an existing script is especially useful for creating a reversal 
script – such as Box Close if you already had Box Open. To create an 
appended script, you can select Insert > Script or click on the Append 
Script button at the top of the Scripts palette. The button will add the 
appended script to the script you’re currently working on. The Append 
Script dialog will appear on top of the Scripts palette. You may have to 
un‐check the Respect Preconditions checkbox in order to find the 
script you want to append from the pop‐up list. 

Once you select the script you wish to append, you now need to make the 
choice of whether to reverse the script or not. If yes, then select the 
Reverse Script checkbox. Click OK and you will see the copy of the 
existing script as a track in your Scripts palette. If the script had 
previously been setup with “Preconditions” and “Befores” these will be 
included and/or respected in this new copy. 

Preconditions specify things that must be true in order for the script to 
make sense. If the box should be open before the ball can come out, then 
you would choose the Box Open script as a precondition to running the 
Ball Out script. In this case, the viewer would need to open the box before 
he can choose to take the ball out. Setting preconditions are as easy as 
clicking on the Edit Preconditions button and selecting the precondition 
states for the objects listed. 

Befores are references to other scripts, which need to run before the 
script that you’re creating. Using our previous example, if you want the 
viewer to be able to take the ball out without having to explicitly open the 
box first, you could set Box Open as a Before for the Ball Out script. This 
would cause the Box Open script to run before the Ball Out script runs. 

For a more detailed walk‐through of the animation process see the Ball in 
Box tutorial below. For more detailed explanations of the features found 
in the Sequences and Views palette, or the Scripts palette, see the Palettes 
section of Chapter 3, The Workspace, above. 

4.8 Export and Editing Options 

This section covers dealing with export options other than compression 
and optimization issues. Those issues are covered in Making Efficient 
Models above. 
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Using Navigation Bar Templates 
When you’re exporting your web tours, you can select Export > Web 
Tour > Other Web Template to choose a different Navigation Bar than 
the standard controller. 

The first dialog you encounter will ask you to choose a name and location 
to save your web tour. The next dialog will be the Select Design 
Template dialog, asking you to choose from a list of Navigation Bar web 
templates.  

You can see that there’s a variety of templates available to choose from. 
You can even create your own version of these templates. See the tutorial 
called Creating Custom Navigation Bars in Chapter 5 below. 

 

Making Walk-Through Presentations 
In addition to all of the options available to you for creating Product 
Tours, Strata Live 3D can also be used to create walk‐through‐style web 
tours for environmental design, interior design, architectural applications 
and more. When you use the menu command Export > Web Tour > 
Scene Walk-Through your web tour will be exported with a special 
Navigation Bar designed for these types of projects.  

The following recommendations will help you author web tours with 
walk‐through navigation: 

 

• From the Sequences & Views palette, select the Initial view from the 
Jump to View menu. Next, click on the Change View Definition 
button. Set the camera distance to zero, to bring the viewer into the 
scene. Use the Advanced tab to adjust the exact location of the 
camera.  
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• Create scripts which take the viewer to various points of interest. 
Give each script a camera track, and edit the camera waypoint to 
move the camera center location to the desired location. The user will 
then be able to “walk” starting at this place.  

• If the model has multiple floors, be sure to create scripts which take 
the user to each level. The applet will not allow the user to change 
elevation, by default.  

• Export the tour using the Export > Web Tour > Scene Walk-
Through option. Edit the HTML to change the walking speed (look 
for the variable walkSpeed). 

NOTE: There is currently no viewer feature available for 
collision detection or elevation grid support. This puts the viewer 
in what’s commonly called in 3D games “God Mode” – with the 
viewer being able to walk through walls, etc. This obviously has 
both benefits and drawbacks. 

Editing the HTML File 
When you export a web tour using the Export > Web Tour menu 
command, several items are placed in the directory with the 3D model 
.JAR file. One of the items exported is an HTML file, which includes an 
APPLET tag. An APPLET tag is a line in the HTML file that tells the 
browser to automatically download an applet (a common name for a 
small software application) and run the applet within the user’s browser. 

Following the APPLET tag, which shows up as “<applet” in the HTML 
file, is a section of special code that helps to drive the web tour.  

The following sections review some of the things you can do to alter how 
your web tour looks and functions. All of these discussions assume that 
you’ve browsed to the folder where you saved the web tour. Also 
assumed is that you’ll be using a basic text editor (such as WordPad on 
Windows) to edit the HTML file. Do not use a word processing 
application like Microsoft Word because it will end up adding hidden 
formatting characters that will cause problems in the end. 

Change the Web Tour 3D View Size 
You can alter the size and aspect ratio of the 3D viewing window for your 
web tour by editing the HTML code. Open the HTML file, find the 
APPLET tag, and change the width= and height= parameters to 
whatever size you want. These dimensions are in pixels, so keep that in 
mind as you make your calculations. 
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NOTE: The larger the viewing window, the lower the interactive 
update rate will be. 

Save your changes and view the HTML file with your browser (if your 
browser is still showing the file, just click the Refresh button). 

Change Web Tour Text Button Positions 
You have some control over the position of the text‐based interactive 
buttons in your web tours. Open the HTML file, find the line that reads: 

scriptButtonsSpace=100; 

This tells the user interface to leave 100 pixels of space on the left for the 
Script control buttons. This may be too much space for smaller web tours. 
Try changing this number to the following: 

scriptButtonsSpace=0; 

Save the file, and view the HTML file with your browser (if your browser 
is still showing the file, just click the Refresh button). 

Create the Illustration Sketch Look 
You can add lines that take on the look of an illustration, or sketch, to you 
projects. In the HTML applet code, look for these lines of text: 

customizeUI={ 
Shadow.Shadow_3d.alpha=0.0; 
Shadow.Shadow_3d.width=Shadow.Shadow_3d.height=96; 
Shadow.Shadow_3d.below=0.001; 
uiDone(); 

This is the code for displaying the shadow underneath your object in the 
web tour. Add this code to that block, just above uiDone(); : 

 Scene.3d.illustrationMode=true; 
 Scene.3d.illustrationThickness=.008; 
 Scene.3d.illustrationThreshold=40; 
 Scene.3d.illustrationLineColor="9C9CD3"; 
 Scene.3d.illustrationFillColor=""; 

The final block should look something like this: 
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customizeUI={ 
Shadow.Shadow_3d.alpha=0.0; 
Shadow.Shadow_3d.width=Shadow.Shadow_3d.height=96; 
Shadow.Shadow_3d.below=0.001; 
Scene.3d.illustrationMode=true; 
Scene.3d.illustrationThickness=.008; 
Scene.3d.illustrationThreshold=40; 
Scene.3d.illustrationLineColor="9C9CD3"; 
Scene.3d.illustrationFillColor=""; 
uiDone(); 

The first line you added tells the Live 3D renderer to use the illustration 
mode instead of the regular renderer: 

 

Scene.3d.illustrationMode=true; 

You can set this to “true” or “false” to quickly change between rendering 
modes. 

The second line determines how thick your outlines will be in sketch 
mode: 

Scene.3d.illustrationThickness=.008; 

The number here is in the default units for your object, most likely inches. 
Very small numbers are required. Lines of this thickness will be drawn on 
the silhouette of your object automatically.   

The third line determines the breaking angle where a line will be drawn 
on your object. It takes a look at the edge wherever two polygons meet. If 
that angle is equal to or less than (in this case) 40 degrees, it will draw a 
line on that edge. 
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Scene.3d.illustrationThreshold=40; 

The proper number here will be highly dependent on the detail of your 
model. For example, if the model is very low resolution, you will likely 
have very high breaking angles, and this number may need to be reduced 
to avoid an excess of illustration lines on your model. If you wish to 
outline more of your model, you would want to increase this number. As 
an extreme example, if you used 180 degrees, the renderer would put a 
line at every joint. This is because 180 degrees would represent two 
polygons that line up perfectly. 

The fourth line determines the outline color used: 

Scene.3d.illustrationLineColor="9C9CD3"; 

The outline color is noted here as a Hexadecimal color code. This code 
can be found in the bottom of the color selector in Photoshop and many 
other popular image editors, as well as numerous places online. You can 
also use simple color definitions here, such as red, green, black, white 
or orange. When you do choose to use color names do not use “quote” 
marks. The line using a color name should look like this: 

Scene.3d.illustrationLineColor= purple; 

Again, notice no quote marks when using color names.  

Color names give you far fewer color choices, but are easier to read. If 
you do not want outlines on your object, you can set this parameter to 
nothing: 

Scene.3d.illustrationLineColor=""; 

The fifth line determines the fill color used for your object (note again 
using quote marks on a Hexadecimal color): 

Scene.3d.illustrationFillColor="FFFFFF"; 
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Just like the outline color, this value is a Hexadecimal color code, and can 
be replaced with a simple color name. If you set this value to nothing, the 
regular textures of your object will display instead of a fill color: 

Scene.3d.illustrationFillColor=""; 

If you want the background color or background image of the web tour to 
show through your object (see instructions below for color and image 
backgrounds), set the fill color to nothing, and alter the textures in your 
web tour to have an alpha value of 0. You can, of course, use intermediate 
alpha values to get differing levels of shading on your object, and use the 
“composite” value to determine how those semi‐transparent surfaces look 
when they overlap each other. 

Change the Background Color of the Web Tour 
To change the background color of your web tour, look for this line in the 
HTML file: 

Applet.Primary.fill="FFFFFF"; 

In this case, “FFFFFF” is Hexadecimal for white. “000000” would be 
black. This code can be found in the bottom of the color selector in 
Photoshop and many other popular image editors, as well as numerous 
places online. 

Simply replace the Hex code with the color wanted. 

Applet.Primary.fill="000000"; 

You can also use simple color definitions here, such as red, green or 
orange. These give you far fewer color choices, but are easier to read. 

Add an Image Behind Your Web Tour 
Underneath the line in the HTML file that determines the background 
color of the tour: 

Applet.Primary.fill="FFFFFF"; 

Add these two lines: 

Applet.Primary.image="blueprint.jpg"; 
keepDisplayImage=true; 

The first line is the location of the background image you want to use, 
relative to the HTML file. The second line ensures that the image stays 
throughout the tour. If you set this line to “false” the background image 
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will act like a “splash screen” and disappear once your 3D model has 
loaded. 

Change the Navigation Bar 
This line in the HTML code specifies what navigation controller is used. 

Data.Program.url="stratathin.jar"; 

Just like the model file, the Navigation Bar is also a “.JAR” file. You can 
create your own custom Navigation Bars, or use one of the included 
navigation files located in your Strata Live 3D install directory, in the 
Web Templates folder. 

You simply change the name of the Navigation Bar file to match the new 
one you want to use: 

Data.Program.url="minimalist.jar"; 

…and ensure the correct navigation jar is in the same folder as the web 
tour. Similarly to the “codebase” item above, you can centrally locate 
these navigation bars and call them using a root path: 

Data.Program.url="/java/minimalist.jar"; 

This will look for the navigation jar in a folder named “java” in the root of 
your site: 

eg. http://www.strata.com/java/ 

Modify the Drop Shadow 
Shadows are dynamically generated by the Strata Live 3D player. They 
are created by rendering the silhouette of the scene in a top-down view 
onto a low‐resolution texture. When this low‐resolution texture is 
rendered with linear filtering, it achieves a soft shadow effect, without 
having to do an expensive “convolution” operation. This generally works 
very well for real products, but for some scenes you may want to modify 
the effect. 

In your text editor, find the following line in the HTML file: 

Shadow.Shadow_3d.alpha=0.75; /* Set to 0.0 for no shadow */ 

To improve the quality of the shadow, replace that line with the 
following: 



STRATA LIVE 3D User Guide – Chapter 4 
The Workflow 

Shadow.Shadow_3d.alpha=0.25; /* Set to 0.0 for no shadow */ 
Shadow.Shadow_3d.width=Shadow.Shadow_3d.height=96; 
Shadow.Shadow_3d.below=0.001; 

The first line controls the alpha (transparency) of the shadow. By 
lowering it from 0.75 to 0.25, the shadow is lightened. The next line sets 
the width and height of the Shadow to 96x96 pixels. This results in a 
sharper, more detailed shadow. The last line sets the shadow to be just a 
hair below the bottom of the 3D scene. 

Save the file, and view the HTML file with your browser (if your browser 
is still showing the file, just click the Refresh button). Try playing with 
these settings. You can always customize your shadows to best fit the 
project at hand. 

 

Using More than One Web Tour on Your Site  
When you use multiple web tours, you’ll want to change the base path for 
the core Java classes. The first line of the APPLET tag defines the classes 
that the web tour needs to operate:  

<applet id="meson" code=com.kaon.meson.MesonApplet  
archive='mesonApplet.jar,rasterGluon.jar,sceneGluon.jar' width='500'  
height='500' mayscript alt='Please Enable Java' codebase=''> 

If you have more than one Live 3D web tour on your website, Java may 
hold these core items in memory, and cause subsequent tours to become 
unstable. The best way to avoid this is to put these files in one location on 
your site, and link every tour to the same classes. The way you do this is 
by entering a path in the “codebase”. This item works like any other path 
in HTML. If you want to keep these files in a folder called “java” in the 
root of your site:  

http://www.strata.com/java/ 

You would change the codebase to look like this:  
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codebase='/java/' 

The Applet will look to that folder for all of the items located in the 
“archive” parameter. This way, if you are uploading many tours, you 
only need to upload the three archive classes once, to one location, 
regardless of where the tours are located in your site structure.  

Making Better 3D PDF Documents 
The Strata Live 3D PDF solution has been specially designed to maximize 
the capabilities of PDF documents to be used for sales, marketing, and 
presentation purposes. Adobe’s native 3D PDF solution was designed for, 
and works very well with, CAD files. As Adobe puts it, their 3D platform 
“helps manufacturing and other extended teams communicate 3D design 
intent more securely and reliably.”  

The good news for designers, illustrators and artists of all stripes, is that 
Strata Live 3D integrates directly with the Adobe solution, using their 
own U3D file format. The Strata Live 3D exporter for PDF outputs a U3D 
file and a companion Javascript, which is automatically placed in the PDF 
file. Together, these provide the end‐user with a much more visual and 
rich experience. 

Strata Live 3D PDF Benefits 

Better Compression 
Sales & Marketing oriented PDFʹs need to be as small as possible. 
Whether used as a click‐download, or sent via email, with PDFʹs, size 
does matter. Strata’s proprietary optimization algorithms yield 3D PDF 
content which is dramatically smaller than PDFʹs created using the 
standard U3D encoder found in other applications. 

Faster Load Times 
Once the end viewer has the PDF file on their local machine, startup time 
can be an issue. The same optimizations which make Strata Live 3D PDF 
files smaller, also make them start up much faster. 

Better User-Controlled Navigation 
By default, Adobe Reader provides a user navigation system (toolbar, 
mouse gesture handling, etc.) which are not designed for marketing 
oriented needs. The base interactivity of the standard 3D PDFʹs are 
oriented toward the CAD community – which can mean “non‐intuitive” 
for you audience. Strata 3D PDFʹs include a custom user navigation 
system, written entirely in Javascript, which gives the user an easy‐to‐use 
toolbar, intuitive rotation, and smooth camera motion. It also ensures that 
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all users can interact with 3D content the same way, regardless of which 
version of Adobe Reader they happen to be using. 

Measuring 
Strata Live 3D’s custom navigation toolbar includes an easy‐to‐use point 
to point measuring tool. Users have control over the displayed units 
using the right‐click context menu in the 3D window. 

Material Swaps 
Using Strata Live 3D’s tools, your 3D PDF file can automatically be 
generated with all the extra object hierarchy and Javascript code required 
to allow changes to materials at run time. This can be used, for example, 
to show a single product in several finishes, or to change the screen image 
displayed on a 3D mobile phone or camera. 

Interdependent Animations 
One of the things the engineers who designed Strata Live 3D have 
learned though years of creating interactive 3D product models is that 
once you have more than a couple moving parts, things start to get really 
complicated quickly. The user can get the object into unexpected 
configurations, and the next thing you know, parts are moving through 
each other in ways that make no sense, and can be really confusing.  

Strata Live 3D has addressed this problem via the Master Model format, 
which allows the relationships between animation scripts, and 
relationships between scripts and object state, to be stated in simple terms 
that prevent errors. Rather than using the primitive built‐in animation 
capabilities of the U3D format, Live 3D uses this Master Model animation 
system, implemented entirely in Javascript within the Strata Live 3D PDF. 
The end‐user gets a collection of easy‐to‐use animation buttons, which 
automatically do the right thing no matter what order the user tries them. 

Mouse-over Hot Spots 
It is a well‐established technique in 3D games and applications to give 
users more information about a product, or even trigger animation 
sequences, based upon mouse gestures such as hovering over a place on 
the 3D model. Strata Live 3D’s toolset makes it relatively easy to provide 
this kind of interactive experience to the user within a PDF. 

Debugging Tools for Your 3D PDF's 
This section shows you how to access some built‐in debugging features 
that Strata Live 3D puts into every 3D PDF. To avoid end‐users of the 
PDF from accidentally enabling these features, they are protected by a 
simple password: 777.  
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To access these functions, open a 3D PDF using Adobe Reader, click in 
the 3D area of the page, and type 777. Now you can type other keys to 
trigger different actions: 

W .............Switch to Wireframe rendering mode and back 

I ...............Switch to Illustration rendering mode and back 

S ..............Switch to Solid & illustration rendering mode and back 

C..............Display Contents, displays some information on the model 
(version of Live 3D U3D Exporter, version of Adobe runtime, 
object count, polygon count, texture count, texture size) 

L ..............Avoid zoom-in Limits (useful if you want to zoom-in closer than is 
allowed by default) 

B..............Starts/stops Benchmarking mode in which model starts rotating 

F ..............Display FPS, to measure FPS precisely it should be used in 
benchmarking mode. Press B, wait 5 seconds, press F. 

Editing the XML File 
The Strata Live 3D model is encapsulated in the XML code. You can learn 
more about this format and how to edit, and enhance it by going to the 
Live 3D Help menu and selecting the Master Model Format command. 
This will bring up the Master Model specification web page on the Strata 
website. 

You can edit the XML representation of the Master Model code directly 
from within Strata Live 3D by selecting Edit > XML. This will bring up 
the Edit XML dialog. You can use this dialog to do your editing – but this 
isn’t the best way to go. The Edit XML dialog is a very simple text editor 
and doesn’t supply any features such as Search and Replace, so you may 
find that using a third party text editor is easier.  

NOTE: Simple text editors, such as WordPad on Windows, work 
best because they don’t add any hidden formatting characters to 
the text. 



STRATA LIVE 3D User Guide – Chapter 4 
The Workflow 

100 

There are two ways to use an external text editor: Copy and Paste, or; 
Using an “unpacked” model.  

Copy and Paste Method 
This approach is fairly straight forward.  To edit just a portion of the XML 
code, open the Edit XML dialog and select the portion of the code you 
want to edit (by clicking and dragging). Next, copy the code using Ctrl - 
C (Cmd - C on Mac). There is no Edit menu in the Edit XML dialog, so 
you need to use the command key equivalents. 

Paste the copied code into the editor of your choice. When you’re done 
editing, just paste the text back into the Edit XML dialog using Ctrl - V 
(Cmd - V on Mac).  

To edit the entire document, click anywhere in the code (to make sure it’s 
the active content area) and hit Ctrl - A for Select All (Cmd - A on Mac). 
Now hit Ctrl‐C to copy. Open your text editor of choice and paste the text 
into a new document. Do the reverse of this to paste the edited XML code 
over the existing code in your model. 

Using an Unpacked Model 
You can save your model in all of its separate components by using the 
Save As command – this includes a separate XML file of your model. 
Once you have the separate elements, you can open the XML text file 
directly with your text editor of choice and simply save your changes. 
You can then use the File  > Reload XML command each time you want 
to see the effect of your changes. In some cases you may need to export a 
3D web tour from Strata Live 3D to see the changes in action – such as 
pop‐up text hotspots. 

To save an unpacked version of the Master Model, select File > Save 
As…. Create a new folder for the model’s content, then specifically save 
the model under the name MASTER.XML. When you do this, the XMM 
data will be saved unpacked into the folder you navigated to. This 
technique should not be used on models with more than a few hundred 
objects as System software performance may drop dramatically when 
folders have thousands of files in them. 

Once you’ve done your Save As command, open the folder you saved 
your model into. You’ll see the file named MASTER.XML. This is the file 
you’ll want to edit, save and then reload. 
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Working with Flash 
Strata Live 3D is setup to create content that works with Flash content. To 
create Flash integrated 3D content, you will want to build your model just 
as you would for a regular web tour. When it comes time to export, 
choose this command: Export > Web Tour > Flash Embedding. This 
export option creates an ActionScript macro program which causes the 
Flash authoring application to create a default user interface for the 
product tour. This default interface can then be customized using Flash. 
The 3D component of the tour is still produced using the Java applet, but 
this option embeds the 3D component in a Flash movie, for added 
flexibility in authoring. 

The following information is for more advanced users, and requires a 
knowledge of Flash, the Live 3D XML code and some Meson scripting: 

Using a “Mouse” Event in the 3D View to Trigger Flash  
When integrating 3D with Flash, it may be desirable to have mouse clicks 
on objects in the 3D scene trigger behavior in the Flash movie. 

First, you need to create a “Trigger” in the Master Model, corresponding 
to the mouse‐able area. See Using XML for Targets with Pop-Up Text – 
found in Chapter 5 – to learn how to make a Trigger. 

Once you have a mouse‐area Trigger embedded in the XML code, use the 
menu item Export > Web Tour > Study Scene from Outside to test 
that you’ve created the Trigger in the right place. 

Next, use Export > Web Tour > Flash Embedding to create a Flash 
movie with the embedded 3D model. Use a slightly different name, or put 
it into a different folder, so that the first web tourʹs HTML file is not 
overwritten. For example, you might have files widgetWeb.html and 
widgetFlash.html. The next step involves adding some Meson statements 
to the widgetFlash.html file, based on what you see in the 
widgetWeb.html file. So open both files in text editors, such as WordPad. 

In the web HTML file, find the line that looks like this: 

makeHotSpot(^location=[SceneRT.Scene_...],^text="...",^script="") 

Copy the part in square brackets, including the brackets. 

In the flash HTML file, find the line that reads: 

/* Define functions to be called by Flash */ 

Immediately before that line, add the following: 
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HotSpotRT.MyHS1.location=[...the location you copied from the other 
file...]; 
FlashVar.MyHS1_press.test={HotSpot.3d_MyHS1.press} 

In your flash movie, you can detect mouse clicks on that point by testing 
the variable _root.MyHS1_press. To respond to mouse‐over, you would 
use: 

HotSpotRT.MyHS1.location=[...the location you copied from the other 
file...]; 
FlashVar.MyHS1_hover.test={HotSpot.3d_MyHS1.hover} 

If you have multiple Triggers, you can create multiple lines like these. Just 
be sure to replace MyHS1 with MyHS2, etc. 

Note that this will not cause anything to appear in the 3D window telling 
the users where the Triggers are. If that is a requirement, you will also 
need to create images to display at the location on the screen. For 
example: 

Image.MyImg.file="arrow.gif"; 
Image.MyImg.parent="Scene.3d"; 
Image.MyImg.anchor=_S; 
Image.MyImg.enabled=false; 
Image.MyImg.offsets=[{HotSpot.3d_MyHS1.x},{HotSpot.3d_MyHS1.y}, 
 {HotSpot.3d_MyHS2.x},{HotSpot.3d_MyHS2.y}]; 

Note that these images will always be displayed. To hide images when 
their hotspot is hidden, change the last line to: 

Image.MyImg.offsets=[{HotSpot.3d_MyHS1.visible?HotSpot.3d_MyHS1.
x:_N}, 
{HotSpot.3d_MyHS1.y},{HotSpot.3d_MyHS2.visible?HotSpot.3d_MyHS2
.x:_N}, 
 {HotSpot.3d_MyHS2.y}]; 

For more information on the classes used in this example, see the Meson 
User Manual. From the main menu select Help > Meson Language 
Manual. 
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Live 3D Tutorials 

Basic Interactivity: Ball in Box 

This tutorial walks you through bringing in data and publishing it to the 
web. Along the way we will cover many features of Strata Live 3D. While 
this tutorial uses a Strata 3D CX model, nearly everything we’ll cover 
applies no matter what program you use to create your 3D content – 
though the specifics of how you get the data into Strata Live 3D and what 
the file structure will look like may vary a bit. 

All of the files used for this tutorial can be found in the Tutorial Files 
folder located in your Strata Live 3D application folder. 

Ball in Box Tutorial Part 1 
If you are a Strata 3D CX user, you should open the BallInBox.s3d file in 
that application. Non‐Strata 3D CX users should just follow along – weʹll 
bring you in shortly! 

Step 1: Animate the Scene 
You’ll note that the BallInBox.s3d file is already animated. You can check 
this animation by opening the Project Window and clicking on the Play 
button. You’ll see that the Lid of the box opens, and the ball comes out. 
We won’t be covering how to setup Strata 3D CX keyframes in this 
tutorial – but the important thing to notice is that every part of the scene 
goes through its entire range of motion during the timeline. This is how 
you create animation for use in Strata Live 3D: Make a timeline in which 
everything happens. It doesnʹt really matter in what order things happen, 
how many frames the actions span, etc. Strata Live 3D will analyze the 
timeline to find every partʹs range of motion. 
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Step 2: Render to Live 3D 
This is a special function in Strata 3D CX for saving out a native Live 3D 
XMM file. To do this, you select the menu Render > Render Live 3D. 
This will bring up the Render Live 3D dialog box. You’ll want to select all 
of the options for this project except for the “Camera Script” and the 
“Scene Playback Script” checkboxes. Click the OK button and select a 
place to save the .xmm file. Name the file “BallInBox.xmm”. 

If you’re a LightWave user (for example) you would export a VRML file 
for this project. You would do this from the File > Export > Export 
Scene As VRML97 menu item. The default choices are fine, except that 
you must check the “Embed Objects” checkbox. (As far as we know, 
LightWave is the only program that supports writing non‐embedded 
objects, so this issue is peculiar to LightWave.) Choose an output 
directory, then click OK. Note that if the scene had used textures, you 
would need to manually copy all the JEPG, GIF, or PNG images into the 
same folder where you put the .wrl file (.wrl is the file extension for 
VRML). This tutorial uses no texture maps. 

At this point you should have an .xmm file which is just like the one you 
can find in the Tutorial Files folder in your Strata Live 3D program folder. 
Non‐Strata 3D CX users can start from the BallInBox.xmm tutorial file 
and jump in here! 

Step 3: Open the .xmm file in Strata Live 3D 
Strata 3D CX users, launch Strata Live 3D and drag the .xmm file you 
created into the Strata Live 3D main palette. (Or, use File > Open... to 
browse to the .xmm file).  
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Non‐Strata 3D CX user, or if you just want to start from here, use the 
BallInBox.xmm file supplied in the Tutorial Files folder then open that file 
now. 

The hierarchy appears in the main palette, and an orange rectangle 
appears in the 3D View palette. You’ll notice that, although there 
appears to be many objects, essentially there are only three objects in the 
scene. One object, the Box, is a group and contains five sides (Back Side, 
Left Side, Bottom Side, Right Side and Front Side). The top is a separate 
object (the Lid), making the total of six sides for this cube. 

 

Use the Palettes > Log menu item to find the Log palette. If you set it to 
show Progress Messages, you will see an indication that you opened the 
.xmm file. The View Log File button on this palette gives a much more 
detailed rundown of everything that happens in Strata Live 3D. It can be 
useful, in particular, if you have trouble importing a VRML .wrl file, as 
some diagnostic messages may only appear in the log file. 

Use the Palettes > Info menu item to see details about the model. Note 
that it has 3,980 triangles, which, while not terribly high, is kind of silly 
for something so simple. We’ll deal with this issue later on in this tutorial. 
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Step 4: Modify Names 
 

Use the Palettes > Metadata menu item to open the Metadata Editor. 
Click the “Insert Top Element” button, and add a “creator” element. 
Type in your name and then hit the Enter key. Now, double‐click on the 
right side of the title row (in the “Value” column) to change the model 
name. Make it a little more “human readable” by changing the name to 
Ball in Box. Notice that the model name at the root of the hierarchy 
changes, as does the name in the Info palette. This name will also be used 
as the default HTML title for generated web pages. While you have the 
Metadata palette open, feel free to add more Metadata to the model. 

Close the Metadata Palette. 
 

You can rename individual objects in your scene by right‐clicking on 
them in the hierarchy view and selecting “Rename” from the contextual 
pop‐up menu. 

Step 5: Adjust Backfacing 
In the 3D View palette, rotate the Box down a little, and right click on the 
Lid (it should be the teal colored side). The Disc that shows up provides a 
small sphere as a control for the Lid animation sequence that was created 
in Strata 3D CX. Using the right mouse button, slide the Lid control away 
from the center of the Disc to open the top of the box. 
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Now hold down the Ctrl key (Cmd key on Mac), and Left Click on the 
green Back Side. This opens the Materials palette (which you could have 
opened using the Palettes > Materials menu item), and selects the 
green material used by the Back Side. 

 

Right‐click on the selected green material, and choose Edit. Find the 
Backfaces pop‐up menu, and change it to Hide. This will set the green 
material used by the Back Side to use no backfacing, while every other 
materials will continue to show backfaces. Click OK to dismiss the dialog. 
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Clearly, we have a problem! There is no interior back to this box. 
Obviously, we don’t want the box to disappear when we open it and look 
inside. In the case of the change we made to the Back Side this is exactly 
what happens. Rotate the box around to get a look at it from behind. 
You’ll see that the green Back Side is still there. It’s just that the triangles 
that are facing into the box are now being hidden because of the change 
we made. You already know how to change this back so the green panel 
is showing – do that now. 

If we wanted to change all the materials so that they were one way or the 
other we could just use the “Edit > Change All Materials > menu and 
select “Backface All” or “Backface None”, among many other options. 
However, the Ball is the only object that doesn’t really need backfacing 
polygons, since it is a closed object. Select the bottom material from the 
Materials palette [Ball Pink], right‐click and select Edit. From the Edit 
Material dialog choose “Hide” from the Backfaces pop‐up menu. Click 
OK to dismiss the Edit Material dialog, then close the Materials palette. 

It’s good practice to avoid the use of backfaces wherever possible, as it 
can often improve performance by a factor of two to not have to draw 
unnecessary triangles. 

Step 6: Adjust the View 
The default initial view is just large enough to hold the scene in the state 
it started in. In the 3D View palette, right click the ball, and move the Ball 
sequence control out (you may need to rotate the box so you can see the 
Ball). Using the Disc controller will move the Ball out of the box, and out 
of the view. Clearly, we need to move the camera back so we can see 
everything. 

Use the Palettes > Sequences & 
Views menu item to show the Sequences 
and Views palette. At the top of that 
palette, set the “Jump to View” pop‐up 
menu to “init” for the Initial view. Now 
click the Change View Definition button. 
Increase the Camera distance. You can 
type in a number, click the up and down 
arrows, use the Closer/Farther buttons, or 
click the up/down arrows and drag the 
mouse up/down without releasing the 
mouse button. A distance of about 850 is 
sufficient to ensure the Ball stays visible 
when it is removed from the Box.   
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You can also adjust other attributes of the initial view, such as the 
orientation, field of view, and zoom limits. You can do this using the 
various tabs of this dialog box and/or by dragging in the 3D View palette. 
You can change the controls in the 3D View palette to adjust whether 
you’re turning, moving or zooming the model. 

Find a viewing angle that looks good, and click OK to dismiss the dialog. 

Note that after adjusting the Initial view, it is a good idea to set it as the 
default for camera centering, distance, etc. Select the Initial view from the 
Sequences and Views dialog again, and then click the “Use As Default” 
button. Any new view which is created from this point forward will use 
the same centering, distance, etc. as this one. Later, if you decide to 
change the default, all those cameras will automatically be adjusted. 

Now would be a great time to use File > Save. 

In the next part of the tutorial, weʹll create some scripts to control these 
animations, and make a web tour. 

Ball in Box Tutorial, Part 2 
If you’re starting the tutorial from this point go to step 1 below. If you’re 
continuing from Part 1 above skip step 1 below and start with step 2. 

Step 1: Open the Model 
Open the model “BallInBox2a.xmm” from the Tutorial Files folder. 

Step 2: Sequence Clean-up 
Use the Palettes > Sequences & Views menu item to open the 
Sequences and Views palette. Find the sequence called “Lid” and click the 
Edit button to its right. 

This opens a dialog which shows each waypoint of the sequence 
(waypoints can be thought of as keyframes). You can click on the 
individual [unnamed] waypoints to see the position represented. Once 
you have a waypoint selected you can use your keyboard arrow up and 
down keys to scroll through each of these waypoints. As you scroll 
through you can see the Lid open and close in the 3D View palette. These 
20 waypoints were created when Strata 3D CX saved the .xmm file out. 
However, only the first and last waypoints are really necessary to animate 
the Lid. Select the second waypoint, then click the Delete button at the 
bottom of the list. You’ll want to click the Delete button 18 times – or until 
you just have the first and last waypoints remaining. 
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Now select the first waypoint. In the right side of the dialog, in the 
“Waypoint Details” section, change the waypoint Name to “Close”. 

Select the last waypoint. Change the waypoint Name to “Open”. Notice 
that if you scroll down in the Waypoint Details section you can adjust the 
actual opening angle if you needed to. 

 

Click the OK button to end editing the sequence waypoints. Notice that 
the Lid slider in the Sequences and Views palette still takes the Lid 
through its entire range of motion, and the pop‐up menu to the right of 
the slider shows only two options, Close and Open. 

Now click the Edit button for the Ball sequence. In this case, the 
intermediate waypoints are important, because they are not just linearly 
interpolating the first and last waypoints. In this case, weʹll only name the 
first and last waypoints, since those are the conceptually important ones. 

Select the first waypoint, and change the Name to “In”. 

Select the last waypoint, and change the Name to “Out”. Click OK to 
close the waypoint editor. 

Drag both the Lid slider and the Ball slider to the left to close the box and 
put the Ball in the box. 

Step 3: Create the Box Open Script 
From the main palette, use the Insert > Script... menu command to 
create a new Script. We will not be appending any script to start with, so 
just cancel out of the initial “Append Script” dialog. Next, a smaller 
dialog named “Add Track” appears. From here we are allowed to select 
a Track to get started. Select the Lid track and click “OK”. 
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Notice that a small remote has appeared in the 3D View palette. Click the 
“+“ button on the remote twice, to make the script 2 seconds long. 

Right click the Lid of the box, and drag the Lid control to the outside of 
the control Disc. 

Notice that a new event marker was automatically created on the 
timeline. Alternately, you could have right‐clicked on the timeline, and 
used Set To > Open to set a event marker to open the box. 

Click the Play button in the remote to see the script execute. 

Click the Rename button in the Scripts palette, and name the script “Box 
Open”.  

NOTE:  By convention, scripts should be named by the part they 
operate on, followed by a description of what they do. This 
convention is assumed by the web export interface, to automate 
assigning scripts to control buttons. 

It really only makes sense to run the Box Open 
script if the box is Closed. This is called a 
precondition, and we should set the 
preconditions accordingly to facilitate user 
interface automation. Click the Edit 
Preconditions button, and change the Lid 
sequence to Close. This means that the Box Open 
script is only available when the Lid is Closed. 
Click OK to dismiss the dialog. 
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Step 4: Create the Box Close Script 
Use the Insert > Script... menu command to 
create a new Script. This time we will start from 
an existing script: the Box Open script we just 
created. 

Uncheck the “Respect Preconditions” 
checkbox to allow display of the Box Open script, 
regardless of whether the box is currently closed. 
Select Box Open from the drop‐down menu. 

Check the Reverse Script checkbox. This will 
append the Box Open script, only reversed. Click the OK button. 
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Notice that some built‐in logic automatically comes up with a reversed 
name: In the upper left corner of the Scripts palette is the name for this 
new scrip – Box Close. Float your mouse cursor over the Edit 
Preconditions button, and notice that the preconditions are also 
automatically reversed (in order to Close the box, it must currently be 
Open). 

Step 5: Preview the Scripts 
Use the Palettes > Preview Scripts menu item to enable the script 
preview palette. Only those scripts that have matched pre‐conditions are 
enabled. 

Click the Box Open and Box Close scripts to confirm that they work the 
way you want, and that they have the right pre‐conditions (only one is 
enabled at a time!). 

Step 6: Create the Ball Out Script 
Use the Insert > Script... menu item to create a new Script. Cancel the 
Append dialog, and choose the Ball track from the Add Track dialog. 

Right Click the first event marker on the Ball track, and choose Set To > 
In. 

Click the “ + “ button twice (in the upper‐
right of the Scripts palette and just to the 
right of the Duration display). You’ll see 
that the timeline for this script is now 2 
seconds. Right‐click on the right‐hand side 
of the script’s timeline and select Set To > 
Out from the pop‐up menu to create the 
second event marker. (Of course, you could 
have used the Remote in the 3D window, 
like we did for the box Lid.) 

Click Rename, and change the name to Ball 
Out. 

Click Edit Preconditions, and change the 
Ball precondition to In. 

Before the ball can come out, the box needs to be open. Click the Edit 
Befores button, then, from the Execute Before… dialog click on the 
Add... button. The “Add Before” dialog appears. Select Box Open from 
the pop‐up menu, then click OK in the Add Before dialog. Now click the 
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OK button in the Execute Before… dialog. You’ve now set a “Before” 
condition for this script. 

Step 7: Create the Ball In Script 
Use the Insert > Script... menu item to create a new Script. Uncheck 
Respect Preconditions, select Ball Out, check Reverse Script then 
click OK. 

The name and preconditions are set correctly, but as with taking the ball 
out, we need to make sure the box is open before we put the ball in the 
box. Click Edit Befores, then the Add... button, then Box Open from the 
menu, then click OK for both dialogs. 

Step 8: Preview the Scripts 
Use the Palettes > Preview Scripts menu item to preview these new 
scripts. You’ll notice that even when you get the box into a condition 
where the Lid is closed and the Ball is inside, you can still click on the 
Ball Out script. The system knows that it needs to open the Lid before it 
can move the Ball out – and it does just that! 

Step 9: Generate a Web Tour 
Create a new folder to hold this new web tour. Because web tours create a 
set of shared files you’ll want to use a new folder for each new web tour 
you make to ensure that all the work you did to create scripts and more 
are unique to this saved tour. 

Use the Export > Web Tour > Study Scene from Outside menu item 
to create the web tour. Your browser should open automatically. 

You’ll see that in your web tour there are four text based buttons in the 
upper left. The first two Lid and Ball buttons are the original scripted 
animations from the Strata 3D CX exported .xmm file. You’ll note that 
these two scripts don’t have any preconditions or befores. The bottom 
two text buttons are the ones we created in this tutorial. Notice how these 
two buttons respect preconditions and befores. 

Use File > Save to save your work. In the next tutorial, weʹll adjust the 
size of the model, polygon count and tidy up the web display a bit. 

Ball in Box Tutorial Part 3 
If you’re starting the tutorial from this point go to step 1 below. If you’re 
continuing from Part 2 above, skip step 1 and start with step 2 below. 
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Step 1: Open the Model 
Open the model “BallInBox3a.xmm” from the Tutorial Files folder. 

Step 2: Dealing With Excess Triangles 
Use the View > Triangle Counts menu item to show triangle counts in 
the hierarchy view. 

There are a lot of unnecessary polygons that we can easily eliminate. The 
box sides each are made up of only two triangles – pretty efficient. 
However, the Ball contains 3,968 triangles – way too many for the 
needs of this simple demonstration. 

First we’ll get a better look at the ball and its triangles. If the Ball isn’t 
currently visible, select Palettes > Preview Scripts then click on the 
Ball Out button.  

Next, select View > Wire Frame > On to see the edges of the triangles. 
You can see that the entire exterior of the Ball is overly tessellated 
(another word for triangulated). This is easily remedied using the 
Generate LOD feature, which weʹll do next. 

Step 3: Generate LOD 
The Master Model format used by Strata Live 3D allows the same object 
to be represented at several levels of detail, or “LOD”s. The lowest level 
of detail is used for all real‐time applications, while the highest is 
maintained for future use, such as increasing the detail for additional 
projects (such as a technical manual) or for creating even lower LODs, 
should you discover that you weren’t aggressive enough in decimating 
(removing) polygons for the web. 
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For the Ball, we’ll do full LOD generation pass, which will eliminate 
unnecessary polygons while still maintaining the spherical shape of the 
Ball. Right‐click the word “Ball” in the hierarchical view in the main 
palette and choose Generate LOD 
from the pop‐up contextual menu. 

Now, click on the Triangles slider at 
the top of the dialog to make it the 
active slider in the dialog. Now you 
can use the right arrow key on your 
keyboard to nudge the slider. Nudge it 
three moves to the right, then click the 
Generate LOD button on the dialog. 
Notice that the polygon count drops 
immediately to 2,230 triangles (visible 
just under the slider). A substantial 
drop, but we’re going for more here, 
so use your mouse to drag the 
Triangles slider all the way to the right 
and click on Generate LOD again. The 
polygon count now drops all the way 
down to 386 – less than 10% of the 
original 3,968.  

If you slide the Generate LOD dialog 
out of the way, youʹll see that the sides still have two (2) triangles each, 
but the Ball displays: 

 

Ball (386 / 3868) ‐ 386 in the lowest LOD, 3,968 in the highest 

This is a good opportunity to play with another control in the Generate 
LOD dialog. Try moving the Resmooth Normals slider all the way to 
the left, then click Generate LOD again. You’ll notice the Ball appears 
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pretty rough. You’ll want to put the slider back to about the middle and 
click Generate LOD again.  

With some models the default Resmooth Normals setting may create 
these odd lighting effects. In that case you may need to slide this control 
to the right some to increase the angle on which the LOD setting creates 
smoothing, and therefore, creating a more natural appearing surface. 

Click OK to finish the Generate LOD process. 

Step 4: Adjust Dimensions 
Most 3D modeling programs work in arbitrary units that have no 
particular relationship to real‐world units like inches or meters. The 
VRML format (which is used for interchange between many 3D modeling 
programs and Strata Live 3D) recommends that units of 1 meter be used. 
However, this convention is rarely followed. 

Even when using Strata Live 3D you may want to set up a custom 
dimension to ensure that your model conforms to client expectations. To 
adjust the dimensions displayed by the measure tool in a web product 
tour, we need to find the relationship between internal model units and 
real‐world units. 

Suppose we know that the Ball is meant to be 8 inches in diameter. Select 
the Measure tool in the 3D window, and click and drag from the top of 
the ball to the bottom. It will show that the current measurement is about 
12 inches. 

Select the Edit > Dimensions menu item. At the top of the dialog is the 
overall scaling factor. It gives the relationship between native model units 
and real‐world units. For example, if you work in a CAD program that 
models everything in centimeters, and that program just outputs native 
units to VRML exports (which is typical) then the overall scaling should 
be 1 cm. But for this model, the chances are pretty good that you have no 
idea what the scaling factor should be. 

More likely, you know the actual size of an object in the scene, and so you 
can use that to determine scaling. In this case, we know that the ball is 
supposed to be 8 inches in diameter. Change the drop‐down at the top of 
the dialog to use “inch” as the units. Now click on the down adjustment 
arrow to the right of the Height field. As you drag downward on this 
control you will see the measured height displayed in the 3D View 
palette also goes down. Keep dragging this control until the displayed 
height comes close to the 8 inch target. 
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You’ll notice that the other values (width, depth, and overall) change 
automatically, to correspond to the changes you made to the Height field. 
Click OK to lock in the change. 

Step 5: Export Web Tour 
Use the Export > Web Tour > Study Scene from Outside menu item 
to create a web tour. Select an empty directory to hold the files, and name 
the output file BallInBox. 

Your web browser should open automatically and display the tour. 

Obviously, there is much more that can be done to customize buttons, 
add pop‐up text labels – the possibilities are endless – especially when 
you take into account the ability to edit the XMM file and the Meson code. 

 

Creating Custom Navigation Bars 

Creating custom web tour Navigation Bars to match your website design, 
or your client’s colors, or your model theme, or – you name it – is possible 
for users with a little graphic arts talent and access to painting software, 
such as Photoshop. 

The Teal-Blue Translucent Navigation Bar 
Though Strata Live 3D offers complete control over designing your 
interface elements by utilizing the Meson programming language, for this 
tutorial we’ll take an easier approach. In this tutorial we’ll customize an 
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existing controller from the Web Templates folder in your Strata Live 3D 
folder. 

Step 1: Select a Template 
The first step is to select an existing Navigation Bar. You’ll want to choose 
the one that comes closest to the look and size that you want to base your 
new controller on. If you haven’t already done so, test out all the available 
templates. To do this, just use a simple model such as the Saber Dino that 
we used for the quick start tutorial in Chapter 2. The Saber Dino can be 
found in your Strata Live 3D folder, in the folder named Tutorial Files. 

Once you have Saber Dino loaded, choose Export > Web Tour > Other 
Web Template. The first dialog you encounter will ask you to choose a 
name and location to save the Saber Dino to. The next dialog you see will 
be the Select Design Template dialog asking you to choose from a list 
of Navigation Bar web templates. You’ll want to save each version in its 
own folder to avoid overwriting files that are necessary for each version 
of the Navigation Bar. Once you’ve had a chance to look at and use all the 
templates that come with Strata Live 3D, you’ll have saved versions of 
each template in a working web model. This will be useful for future 
projects. 

Not to stifle your creativity, but for this tutorial we’ll use the controller 
named strata_large.jar. This Navigation Bar, as the name suggests, is 
larger than some of the others templates. This will give us a little more 
pixel real‐estate to work with. 

 

Step 2: Make a Copy of the Template 
When customizing these templates, you’ll want to make sure you keep 
the original file around. Make a copy of strata_large.jar by opening the 
Web Templates folder. Select strata_large.jar, go to your system Edit 
menu and select Copy. Now paste a copy of the file back into your Web 
Templates folder. 

Step 3: Convert the JAR File 
As discussed earlier in this User Guide, the file extension “.jar” simply 
stands for Java Archive. As an archive, it contains a series of files that 
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are necessary to create the Navigation Bar. The JAR file is assembled and 
compressed with a very familiar compression technology – ZIP.  

To open the template as a .ZIP file, rename the copy of strata_large.jar 
that you made in Step 2 to now be MyTemplate.zip. Now “unzip” the 
file with a ZIP compression utility. It should unzip into a folder named 
MyTemplate. Now you’re ready to start editing. 

Step 4: Open the GIF Files 
In the folder MyTemplate, you’ll find a series of .gif image files and a text 
file named template.txt. For right now we’re only going to concern 
ourselves with two of the .gif files: toolsColor.gif and toolsMask.gif. 

NOTE: For the purposes of the writing of this tutorial, the 
painting application being used will be Adobe Photoshop – but 
any competent painting software should be able to do the job. 

Open these two .gif files in Photoshop. As the file names suggest, one 
image contains the color versions of the controller and the other contains 
the mask, or alpha, for the controller. 

Both the color image and the mask image are divided into four sections. 
The top section is the default/rest state of the template. The second section 
down provides the highlights for each controller point for the non‐
selected tool. For example, if you mouse over the move‐left arrow on the 
Move controller, even though it’s not selected, the small arrow will 
highlight. If you click on that same arrow, the Move controller will 
become “selected” (indicated by the highlight from the third section of 
the color image). The fourth and final section provides the highlights for 
each controller point, combined with the highlight for the full controller. 
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Step 5: Edit the Color Image 
We’re going to keep our edits pretty simple for this tutorial, but you’re 
probably already chomping at the bit to get creative. First, let’s work on 
the toolsColor image. In Photoshop, choose Image > Adjustments > 
Hue/Saturation. We’ll go teal‐blue on this one. Click on the Colorize 
checkbox. Now put each slider in the center position – about 180 for the 
Hue slider, 50 for the Saturation slider, and 0 for the Lightness slider. 

Now save the file. That’s it. You now have your gif image in your 
MyTemplate folder. 

Step 6: Edit the Mask Image 
Now bring the toolsMask image to the front in Photoshop. As you’re 
probably aware, the way the mask image works is that dark areas are 
used to make the color image transparent. The white area makes the color 
image opaque. What this mask image doesn’t have is any gray. Let’s add 
some semi‐transparent areas to this Navigation Bar. 

First, change the color mode of the image from Indexed to Grayscale. 
Do this by selecting the Photoshop menu command Image > Mode > 
Grayscale. Now you’re able to edit the image. 

If you check the dimensions of the image you’ll see that it’s 290 pixels 
wide by 272 pixels tall. What we’ll do is make each of the four 
quadrants the same, so we’ll work on the top quarter first, then copy that 
portion and replicate it three times. The 272 pixel height can be divided 
into four equal chunks of 68 pixels. 

Alter the Photoshop marquee tool to 290 pixels wide by 68 pixels tall. To 
do this, select the Rectangular Marquee Tool from the Tool palette. Next, 
select Fixed Size from the pop‐up menu in the tool Options bar. Enter 290 
in the Width field and 68 in the Height field. 

Next, click in the upper left of the mask image. This will select just the top 
quarter of the image. Now make a new layer to paint on. Set your colors 
to about a 50% gray for the foreground and white for the background. 
Now, choose the Gradient Tool and do a gray‐to‐white fade. Set the Layer 
Blending Mode to Darken. Copy and paste this fade until you’ve covered 
all four quadrants. 
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Step 7: Save the Mask GIF 
 

This time when you save the image you need to use the Save For Web 
command in Photoshop. The reason for this is that we changed the mode 
of the image and added a layer. The GIF format does not support these 
elements so, unlike the toolsColor image, you cannot just select save. 

When you select File > Save For Web you get special dialog for saving 
images like JPEGs and GIFs. For this project make sure the format selector 
is set to GIF. Set the Colors field to 16. This will cause some banding, but 
since this image will only be used for transparency levels, that won’t 
really be noticeable. Save the file into your MyTemplate folder and 
replace the previous image named toolsMask. 

Step 8: Create the JAR File 
Now you’re ready to compress the files back into a .jar file. Select all the 
files in the MyTemplate folder. Make sure you do not compress the 
MyTemplate folder – just the contents of the folder. After the file is 
compressed, rename it MyTemplate.jar. Now place the template in with 
all your other templates in the Web Templates folder. 

Step 9: Test Out MyTemplate 
Go back to Strata Live 3D. Take any test model and do an Export > Web 
Tour > Other Web Template command. Remember, the first dialog you 
get in this process is to name your model and to locate a place to save it. 
After you save the model, the next dialog should automatically bring up 
the Web Templates folder with MyTemplate in with all the others. 
Double‐click on MyTemplate. 

You should see your test model come up with your new template 
creation, looking something like this: 
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Notice how the color has changed and that the template is semi‐
transparent, getting progressively more opaque towards the bottom. This 
is, of course, a result of the grayscale fade you created.  

 

You can see the potential for creating and modifying the available web 
templates. One note for the code‐minded among you, the text file you 
saw in the uncompressed MyTemplate folder (template.txt) is the 
Meson code that controls the behavior of this Navigation Bar. When you 
want to delve into a high level of customization, this is the place to start. 

Using XML for Targets with Pop-Up Text 

One of the powerful things you can do in the XML code is to add targets 
in 3D space that can launch other activities, such as scripts, material 
changes and pop‐up text notes to label parts or provide instructions for 
the viewer. Below is a short tutorial showing how to add pop‐up text 
notes. 
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Tutorial: Saber Dino Text on the Nose 
In this tutorial we’ll use XML to create a target on a 3D object. The XML 
code will tell the player to display some pop‐up text when the target is 
clicked on. 

Step 1: Open the Saber Dino Model 
We’ll be using the same Saber Dino VRML file that we used for the quick 
start tutorial, found at the beginning of this User Guide. The file can be 
located in your Strata Live 3D application folder, then inside the Tutorial 
Files folder. Drag and drop the file named Saber Dino.wrl onto the main 
Strata Live 3D palette. 

Step 2: Gather the Target Information 
Use the Palettes > Log menu item to ensure the Log palette is showing. 
Next, select the Progress Messages button at the top of that panel. 

Now, hold down the Shift key and click on the Saber Dino’s nose. You 
may need to rotate him first to get a clear shot at his nose. You should see 
something close to the following: 

Picked object ID ORITGT at local coordinate 0.5353206,0.1344095,-0.13964817 

You’ll note that the information is pretty hard to make sense of. In the 
first place the name is a bit strange (ORITGT?). Let’s try changing that 
name and see where that gets us.  

In the main palette, right‐click on the last object in the hierarchy 
(ORITGT). Now select the third item in the pop‐up context menu: 
Rename… A small dialog named Rename ORITGT will pop‐up. Delete 
ORITGT from the text area and type in Dino. Now try shift‐clicking on 
Saber Dino’s nose again in the 3D View palette. What do you see in the 
Log palette now? You’re right, the same thing!

The reason the name in the Log palette is still the same is because the 
name we changed was only the description (or desc in XML Master 
Model talk). The true ID continues to be ORITGT in the XML code. You 
can change this by opening the XML file. Let’s do that now. First, select 
Edit > XML from the main menu. When the Edit XML dialog opens, you 
can find the following text eighteen lines down (about halfway from 
the top when you first open the Edit XML dialog): 

<object id="ORITGT" desc="Dino" private="true"> 

Change “ORITGT” to “Dino”. Click OK on the Edit XML dialog. Now, 
when you shift‐click on Saber Dino’s nose, you’ll see: 
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Picked object ID Dino at local coordinate 0.5353206,0.1344095,-0.13964817 

Though that worked, it was quite a hassle locating and editing that name 
in the XML file. There was no “search” function we could use, no edit 
menu – overall, it’s a pretty simple text editor. In the next XML edit we’ll 
use a much better text editor. 

Step 3: Save As XMM 
Now we’ll use the method outlined at the beginning of the section 
Editing the XML File to break the XMM model file into its component 
pieces. 

Select Save As… from the File menu. Navigate to the place where you’d 
like to save the model data. You might want to create a new, empty 
folder. To do this, you can click on the folder icon with the red spark on it, 
which can be found in the upper right of the Save dialog. Give the folder 
a descriptive name, like “Dino on the Nose”. Now open your new 
folder.  

For this special trick of saving the unpacked Master Model, you need to 
name the file you’re saving MASTER.XML. Make sure you use the file 
extension XML and not XMM. Only MASTER.XML will create the 
unpacked file we’re after. Now, from you computer system, navigate to 
the “Dino on the Nose” folder and open it up. 

Step 4: Open the XML File 
When you open the “Dino on the Nose” folder, you’ll note that there are a 
number of files in this folder. One is a JPEG file, which is the UV based 
texture map. The file we’re interested in is the one named MASTER.XML. 
If you’re working on Windows, right‐click on the XML file and select 
Open With > WordPad. If you’re a Mac user, the likely choice to use is 
TextEdit. 

Once you have MASTER.XML open, we’re ready to make some more 
edits. 

Step 5: Insert Some XML Code 
Now we’re ready to add our target. First do a search (should be in the 
edit menu: Edit > Find of your text editing application) and look for 
</scripts>. The “ / ” defines the end of a segment of code. In this case, it 
represents the end of the block of script code. You’ll find </scripts> as 
the second to the last line in the XML file. 



STRATA LIVE 3D User Guide – Chapter 5 
Live 3D Tutorials 

127 

The target code we’ll be inserting will go after the end of the script 
section but before the end of the entire master file ( </master> ). Insert 
the following text: 

 <triggers> 
   <trigger desc="Text you want to\nhave pop up" 
        id="trigger1" object="Object1" 
        radius="1" x="1" y="1" z="1"> 
   </trigger> 
 </triggers> 

That’s a good starting point. Your XML code should look like this at the 
bottom of the text editing window now (but without the left‐hand side 
numbers): 

    </scripts> 
1. <triggers> 
2.    <trigger desc="Text you want to\n have pop up" 
3.      id="trigger1" object="Object1" 
4.      radius="1" x="1" y="1" z="1"> 
5.    </trigger> 
6. </triggers> 
    </master> 

If you don’t have the fancy indented formatting, don’t worry about that 
as it has nothing to do with how the XML code executes in the Live 3D 
player. 

Step 6: Get to Know the Code 
Let’s review what the code means that you’ve inserted. The first line: 

     <triggers> 

indicates the beginning of your triggers list. The next line: 

          <trigger desc="Text you want to\n have pop up" 

is your first trigger (and in this example, the only one). This line includes 
what to do when the trigger is clicked on: provide a description with text. 
The text is enclosed in quotes. You’ll note that they are not “fancy” 
quotes, but rather standard, "simple" quotes, where both are identical to 
each other. The XML code must be simple text or Strata Live 3D will not 
accept the Reload command. Within the quotes is a basic string of text – 
but with a “soft return” inserted in it. This is the “\n” you see between to 
and have. You can use as many of these are you like, or none at all. 
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The third inserted line: 

            id="trigger1" object="Object1" 

provides the ID for the trigger (“trigger1”) and the name of the object 
that is subject to the trigger (object="Object1"). The id attribute can be 
anything you choose, just make sure each trigger has a different one – if 
you add multiple triggers. 

The fourth inserted line: 

        radius="1" x="1" y="1" z="1"> 

provides the size and location of the target. The radius attribute is the size 
of the sensitive area in native model units. The x, y, and z attributes give 
the location of the center of the hot area, relative to the object. 

The last two inserted lines (the fifth and sixth lines): 

   </trigger> 
 </triggers> 

indicate the end of the end of the trigger you created and the end of the 
triggers section. 

Step 7: Customize the Trigger Code 
Now it’s time to make this trigger code work for our Saber Dino model. 
The first thing you need to do is to edit the pop‐up text string so it says 
something that works for our project. How about: 

   <trigger desc="Right on the Nose!" 

Next, input the correct target object name: 

        id="trigger1" object="Dino" 

Finally, we need to input the correct target numbers. This is where the 
Log palette information comes into play. If you recall, you get this 
information by shift‐clicking on the nose of Saber Dino. You should see 
numbers like this: 

Picked object ID Dino at local coordinate 0.5353206,0.1344095,-0.13964817 

You can see that this log information also includes the proper object name 
that we edited early in this tutorial. Input the correct numbers: 
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        radius="1" x="0.54" y="0.13" z="-0.14"> 

There are a few things to take note of here. Even though it’s not labeled, 
the coordinate location data feedback from the Log palette comes in the 
same order that the XML target code wants it; X, Y then Z.  

The next thing to note is that we didn’t need to use the full seven digits of 
accuracy from the Log palette. The above numbers have been rounded to 
the closest number with two digits of accuracy. 

The third thing to think about is the radius size. In native units, the target 
numbers are very small. This tells us that the radius of our target should 
probably also be a very small number. Let’s try 0.1 and see how it 
works: 

        radius="0.1" x="0.54" y="0.13" z="-0.14"> 

Now save the MASTER.XML file from your text editor. 

Step 8: Reload the XML File 
From the Strata Live 3D main palette, choose File > Reload XML… The 
Open dialog will display. From the dialog, navigate the “Dino on the 
Nose” folder and open it. Select the MASTER.XML file then click on the 
Open button. The XML file will now be reloaded.  

If you made any mistakes when editing the XML file, the Log palette 
will display the errors. Make any necessary corrections to the XML file 
from within your text editor, save, and then reload the XML file until you 
get a clean reload. 

Step 9: Test it Out 
Export your web tour by choosing Export > Web Tour > Study Scene 
from Outside. Save the web tour in a new, empty folder. Once you’ve 
saved the tour it should automatically open in your web browser. It 
should look something like this: 

When you export the model, the exporter will write extra code into the 
generated HTML page to create the hotspot. 

The appearance of text pop‐ups is controlled by the user interface 
template, such as strata_large.jar. You can open this file using WinZIP, 
and edit the Meson code in the template.txt file to change attributes such 
as text buffer color, or font style. 

If you’d like to change the   icon you can follow the same basic 
instructions in the Creating Custom Navigation Bars tutorial above. Just 
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use your favorite paint application to edit the GIF files that represent that 
particular icon. 

For full documentation of triggers see the Master Model Format Spec. by 
clicking on the Strata Live 3D Help menu and choosing Master Model 
Format.
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Appendix 

Troubleshooting and Support 

Support from Strata 

Email Support 
Strata provides email‐based technical support that is second to none. 
Send your questions to support@strata.com.  

Strata.com Support System and FAQ 
The Strata website has a complete support section that includes 
information about updates, registration help, available training and an 
FAQ (frequently asked questions) system. 

To access our web‐based FAQ support system, point your browser to 
http:// faq.strata.com and choose the app you want support for (in this 
case, Strata Live 3D). You can search through support issues that have 
come up in the past, or submit a new question here. Our support staff will 
respond to your issue online, and you will receive an email when your 
issue is updated. This helps us keep all support information in one, easy 
to search location online for all users 

Training Materials 
Check with Strata about new and updated DVD and CD ROM based 
training materials. 

Training Classes 
Strata offers regional training classes taught by Strata certified trainers. 
Check with us to find out about a class near you. You can also arrange to 
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have an instructor come directly to your location for in‐person, one‐on‐
one training. 

StrataCafe.com 
StrataCafe (www.stratacafe.com) is the official user community for Strata 
users. At StrataCafe you’ll find a place to post test web tours and get 
feedback from professional artists, gain access to free models, custom 
Navigation Bars and textures, and join in the discussion forums to get 
answers to everyday questions about using your Strata software. You can 
even get answers to basic design questions. 

Program Memory 

Warning: Propeller Heads Only 
Strata Live 3D is configured, by default, to use up to 800 MB of memory. 
If this amount of memory is not sufficient (for example, when opening a 
Master Model with 1 GB of texture), it’s possible that the program can fail 
without warning. If this happens, a log file will be left in the Logs folder 
which can be found in your Strata Live 3D install folder. 

To configure the program to use more memory, edit the file called 
Master.lax in the Program Files/Strata/Strata Live 3D folder where Strata 
Live 3D is installed. The line that reads: 

lax.nl.java.option.java.heap.size.max=828860800 

controls the maximum memory usage. The number must be expressed in 
bytes (1MB = 1048576 bytes). Note that configuring the editor to use more 
memory than physically exists on your computer will almost certainly 
lead to very poor performance. Also, desktop versions of Windows 
prevent the application from using more than about 1.2 GB of memory. 

If you are working on a model which requires more memory than you 
have available, see the menu item: Special > Unlimited Texture 
Memory. 

Common VRML Import Issues 
Some VRML exporters turn the model 90 degrees on export. To correct 
this, right‐click on the ROOT object in the main palette, and select Edit 
Object. Put the value –90.0 in the Orientation Y control (or whichever 
control fixes the problem). Next, use Palettes > Sequences & Views, 
to show the Sequences and Views palette. Select the Initial view in the 
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drop‐down menu at the top‐left of the palette, then click Change View 
Definition. Select the Advanced tab, and click the Center of Visible 
Scene button to re‐center the model with its new orientation. 

Exporting VRML from Maya 
The “vrml 2” export function in Maya is not enabled by default. In Maya, 
use the menu item Window > Settings/Preferences > Plug-in 
Manager… to open the plug‐in manager. Scroll to the bottom, and check 
both load and auto load for vrml2Export.mll. 

To export VRML97 files, use File > Export All and select the dialog. Then 
adjust the settings to match those shown here: 

 
VRML Export from Max 

Note that if you are importing models from 3D Studio Max, a MAX‐Script 
is available for that program which improves upon the VRML export 
built into that program. The script generates ancillary information about 
Animation Key Frames and Smoothing Groups, which are not 
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included in the MAX VRML export function by default. Click on 
Help>Extras to access this script. 

Importing Alias Studio .WIRE Files 
Note that this feature will not work unless you have a licensed copy of 
Alias Studio 10 or later on the same machine where Strata Live 3D is 
being used. Also, the Alias binary directory must be in your system 
PATH environment variable. This is set by default when Studio is 
installed, but if you get a message about not being able to find the DLL or 
“Error 128”, follow these steps: 

1. Right‐click “My Computer”  

2. Choose Properties  

3. Choose the Advanced tab  

4. Click the Environment Variables button  

5. Select the PATH variable in the System Variables section, choose 
Edit  

6. Use the Home key on your keyboard to jump to the beginning of the 
path, and insert the path to Alias Studio, separated by a semicolon ; 

This is typically one of the following (check your machine to make sure): 

C:\Program Files\AliasWavefront\StudioTools10.1\bin 
C:\Program Files\Alias\StudioTools11.0\bin 

Click OK to save the change to your PATH, and restart Strata Live 3D. 

Alias Studio files will tend to have extremely high polygon counts, so the 
next step in the import process will be to right‐click the top of the object 
hierarchy tree and choose Generate LOD to create a working model with 
a reduced Level of Detail. 

Optimizing Large 3D Models for the Web 

This section reviews the technologies and processes Strata Live 3D uses to 
produce the smallest projects possible. 
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3D models are among the most complex kinds of data to transmit 
efficiently. A comprehensive web optimization solution requires 
Decimation, Compression, and Streaming. Failure to address any one 
of these areas, even in part, can make an otherwise good approach 
extremely inefficient. 

Decimation is a “lossy” process, in which high‐resolution data, which is 
not required in a web application, is removed. Compression is the process 
of representing a large data set using a smaller data set, by exploiting 
patterns or other kinds of predictability in the data. Streaming is a 
technique used to send data while the user is looking at the running 
application, to reduce the perception of delay. These three techniques 
apply across three domains of technology: Authoring Tools, Formats, and 
Viewers – as shown in the following chart: 
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As this chart shows, aspects of decimation and streaming apply across 
technologies, requiring support beyond a single technology. For this 
reason, and because of the interplay between all these aspects of efficient 
data transmission, a solution which includes tools, formats, and viewers, 
all working in harmony, will generally produce the best results. 

Each of these aspects of efficient transmission will be explained in the 
following sections. 
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Decimation 
Decimation is the process of eliminating unneeded information from the 
3D model. It is a “lossy” process, which means it must be guided by 
knowledge about the end‐user requirements of the data. This knowledge 
comes from several sources: 

Developer Input 
You, as the developer, select parameters based on your understanding of 
end‐user requirements. 

Viewing Platform Limitations 
By making the software aware of limitations (such as maximum zoom) of 
the viewing platform, it can eliminate data which would not be visible to 
the end‐user. 

Behavioral Analysis 
By making the software aware of the behavior of the 3D model, it can 
eliminate data which will not be relevant for a given application. 

A 3D model is generally represented by a “scene graph,” in which a 
hierarchy of transform nodes tie together various parts. At each of these 
nodes, there may be geometry. There are many parts of this graph which 
may be decimated. The next sections discuss each of the candidates. 

Mesh Decimation (Polygon Reduction) 
Tessellated 3D models often have more triangles in each mesh than are 
really necessary for a given end‐user application. In some cases, such as 
co‐planar polygons, this decimation requires no technician input; but in 
general, you will need to make quality determinations to decide how 
aggressively the system should remove polygons from the tessellation. 

Strata Live 3D uses a quality‐driven approach to decimation. Rather than 
giving an exact polygon count goal, which is impossible for the you to 
know in advance, the software is given an abstract quality metric, and the 
reducer will eliminate as many polygons as possible without dropping 
below that quality level. This allows you to work on large hierarchies of 
objects at a time, and then do fine‐grained adjustments to the decimation 
as needed. 

Hierarchy Decimation (Merging Nodes and Meshes) 
3D scene graphs often have far more hierarchy than is necessary for an 
end‐user application. For example, an Alias Studio model of an MRI 
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machine which Strata Live 3D based production company was using, had 
about 3000 nodes in its hierarchy, but only about a dozen moving parts. 
Analogous to automatic “inlining” in a compiler, Strata Live 3D will 
analyze the motion and visibility operations actually used in an 
application, and identify the levels of hierarchy that are irrelevant to 
animation. It can then decimate these out of the scene graph, apply the 
necessary transforms, and merge child node mesh data. 

Coordinate Table Decimation (Welding) 
Triangular meshes are generally represented using tables of coordinate 
values (3D positions, vertex normals, and texture mapping coordinates). 
Often these tables will contain values which are duplicated, or very close 
to duplicated. This redundant data can be decimated through a 
“welding” process, in which values which are within a defined threshold 
are unified. The maximum threshold to use can be determined with 
knowledge of the resolution limitations of the end‐user application. 
However, placing this value under your control allows the use of a more 
aggressive weld threshold to further reduce model size. 

Coordinate Value Decimation (Quantization) 
3D scene graphs generally use floating‐point representations for all 
coordinate data (positions, normals, and mapping coordinates). However, 
floating point data is extremely difficult to work with in compression, so 
this data will first be quantized into an integer representation for 
subsequent compression. Quantization is a kind of decimation, because it 
effectively decimates the least significant digits of each coordinate value. 
The choice of the number of bits to use for each integer might be 
determined through statistical analysis of the dynamic range, and 
variance, of the sample data. However, again it is best to leave this under 
your control, since an algorithm cannot effectively determine which 
variance is noise, and which is actually important geometry. 

Texture Decimation (Cropping, Down-Scaling, Noise Reduction) 
For many classes of 3D scenes, the texture data can dwarf 3D geometry. 
Photographic based processes can produce models with a hundred 
megabytes of texture. This texture data must be aggressively decimated 
as well. Three approaches are used by Strata Live 3D to get the number of 
pixels down to a reasonable level: cropping, down‐scaling, and noise 
reduction. 

First, the texture coordinates used by the meshes are analyzed to 
determine which image pixels are actually mapped to triangles, and 
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unused pixels are cropped out of the image (either by reducing the 
rectangular boundary of the image, or by replacing these pixels with an 
average color value). 

Next, the images are scaled. By default, Strata Live 3D uses a quality‐
based approach to scaling images. The image is scaled down as much as 
possible, without dropping the quality of the image below a threshold 
(relative to the unscaled original). Using this approach, a largely uniform 
texture might be scaled down a lot, whereas a highly variable texture will 
be scaled very little. In addition to this quality‐based approach, you can 
choose individual scale factors directly, for more optimal reduction. 

Finally, under your control, the images may be noise‐reduced. Noise 
reduction is a common data pre‐conditioning technique used on image 
data, to ensure the compressed image is as small as possible. For example, 
in the Save to Web feature of Photoshop, applying a Gaussian blur is an 
option in the JPEG compression step. Of course, Strata Live 3D uses a 
more sophisticated noise reducer than simple Gaussian blur. 

Both noise reduction and scaling can make images look blurry, so it is 
often desirable to augment these techniques with a post‐decompression 
sharpen filter in the viewer, to re‐introduce much of the original clarity of 
the image. 

Object Decimation (Invisible Node Removal) 
Object decimation is analogous to dead‐code removal in a compiler. By 
performing static analysis of the potential dynamic nature of a scene 
graph, the software can determine that some parts will never be visible in 
the final application. These objects, and texture images used by these 
objects and no others, can be dropped from the scene. 

Compression 
After decimating out as much data as possible, the remaining data must 
be effectively compressed. Strata Live 3D uses a proprietary technique 
that we call Dedkov compression. Here, we discuss the kinds of data that 
must be compressed, but we do not get into the details of our proprietary 
approach. 

Hierarchy & Animation Compression 
After Decimation, there is usually not much hierarchy left to compress, 
and animation information is generally fairly small to begin with, so 
ordinary ZIP‐style compression is adequate for this data. 
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Topology Compression 
The topology of the mesh describes how the various 3D coordinates are 
connected together into triangles. 

Geometry Coordinate Compression 
The geometry coordinates give the exact 3D location of each vertex in the 
mesh. 

Mapping Coordinate Compression 
Mapping coordinates dictate the method by which 2D image maps 
should be overlaid onto the geometry. As 3D modeling techniques 
evolve, more and more maps are being applied to geometry (diffuse, 
bump, displacement, etc.), so any technique should support multiple 
mapping coordinates per vertex. 

Vertex Normal Compression 
Vertex normals make up a large part of the data to be transmitted, so 
special attention is often paid to compressing this data. However, for 
almost all tessellated models, the vertex normals can be easily calculated 
by averaging some of the face normals of triangles adjacent to each 
vertex. Exactly which faces to include in this calculation can be encoded 
using a technique called “smoothing groups.” In some cases, the 
smoothing groups will be available in the source data, because they were 
used in the modeling process to drive surface normals to begin with. In 
other cases, they must be computed by analyzing the normals. Encoding 
smoothing groups is a far more effective compression technique than any 
other option for vertex normal compression. 

Texture Compression 
For many models, texture image data will be many times larger than all 
other data combined. Thus, any comprehensive solution to compression 
must focus on texture compression as well. There are two classes of lossy 
image compression, characterized by the familiar JPEG and GIF 
approaches. However, these formats are quite outdated, and there are 
better alternatives for both, as described below. 

Lossy Frequency Domain Image Compression 
JPEG is the dominant image format which uses lossy frequency domain 
image compression. In this technique, color information for blocks of 
pixels is transformed from the amplitude (intensity) domain, into the 
frequency domain, filters are applied to remove high‐frequency changes, 
and the filtered data is encoded. 
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A modern technique which works similarly, but produces consistently 
superior results, is wavelet compression. The JPEG‐2000 standard is an 
example format for wavelet compression. Strata Live 3D uses a 
proprietary wavelet‐based image compression technique, which is similar 
to JPEG‐2000 but has a much smaller decoder footprint, so it is practical to 
use in a Java applet. 

Paletted Image Compression 
For certain kinds of images, such as screen shots, JPEG‐style compression 
requires very large files to produce acceptable quality. For these images, it 
can be beneficial to use a paletted compression technique instead. In this 
approach, a palette of colors is built for the image, and each pixel uses a 
color from this palette. GIF and PNG‐indexed are popular formats which 
use this technique. Strata Live 3D uses a proprietary technique which 
achieves dramatically better compression than these formats for paletted 
images. 

Streaming 
After decimation and compression, a hundreds‐of‐megabytes data set 
may have been reduced to hundreds‐of‐kilobytes. While 1000:1 
compression is admirable, files spanning hundreds of kilobytes will still 
take a long time to load over most Internet connections. To reduce the 
perceived delay, some form of streaming is often desirable. 

The exception to this is cases, like PDF, where the usual user paradigm is 
to download, then view. For formats like that, using a streaming 
mechanism is pointless, and probably counterproductive, since the 
streaming algorithms will undoubtedly make it take longer to load the 3D 
model. 

But for web‐based applications where streaming makes sense, there are a 
few variations to consider: streaming objects, geometry, and/or texture. 
They are examined in the next sections. 

Object Streaming (Instancing) 
Object‐level streaming is an application‐specific optimization, which has 
nothing to do with the decimation, compression, or file formats used to 
transmit data. A good example of object streaming would be a product 
catalog that only loaded 3D models selected by the user, instead of 
loading all the 3D models in the entire catalog and selectively changing 
visibility of individual models. Clearly, in a case like this, object‐level 
streaming is a requirement. But all that it requires is that each viewable 
object be stored separately (or at least clearly indexed within a larger file), 
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and that viewer logic be included to download the visible parts as they 
are needed. 

Geometry Streaming (Progressive Meshes) 
A great deal of research has been devoted to streaming geometry data, 
and it is the primary claimed benefit of the U3D ECMA standard. 
However, we have elected to omit this kind of streaming from Strata 
solutions for two reasons. First, it is not necessary. After decimation and 
compression, the geometry component of a model is rarely more than a 
few tens of kilobytes. For example, with a typical compression rate of 8 
bits per triangle, a 50,000 triangle CAD model (which may have been 
decimated down from 500,000 triangles) will only be 50KBytes. For 
models created with 3D visualization tools, polygon counts exceeding 
20,000 are rare. Adding the complexity of streaming geometry to change 
the user experience during the first 5 seconds of viewing hardly seems 
worth the trouble. 

However, if geometry streaming had no down side, it might be worth 
doing anyway. But the downsides, are, in fact, huge. First, progressive 
meshes cannot be efficiently compressed. In addition to all the data which 
already needed to be encoded, the rules to migrate the initial, low‐
resolution mesh, to transform it into the final high‐resolution mesh must 
also be encoded. This vastly increases the entropy of the system, resulting 
in much lower compression ratios. 

Second, unpacking progressive meshes takes a lot of computation. Thus, 
the user may be seeing a progressively improving visual appearance, but 
there is no opportunity for the user to interact with the lower resolution 
data, because the CPU is spending all its time decoding the data and 
applying the progressive mesh transforms. For large data sets, splitting 
the CPU cache between unpacking the data, and displaying it on the 
screen, can lead to serious performance degradation. 

Texture Streaming 
For photographic‐quality models which have been properly decimated 
and compressed, the amount of data devoted to texture is typically 10 
times the data devoted to geometry. In order to provide the best user 
experience, streaming in progressive resolution in texture is a 
requirement (except in the download‐and‐view case, such as in PDF files). 
And unlike progressive mesh encoding, progressive encoding of images 
generally has no detrimental effect on overall compressed size. For 
example, the familiar progressive‐JPEG approach will typically yield a 
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file somewhat smaller than an ordinary JPEG encoding. And interlaced 
GIF files are exactly the same size as non‐interlaced GIFs. 

The same principle holds true in wavelet encoding, which is the 
dominant texture encoding method used by Strata Live 3D for 
photographic‐quality, textured models. Each “band” of wavelet data 
progressively increases the resolution, color fidelity, or intensity fidelity 
of the image. So merely showing this data as it is decoded gives the users 
a progressively improving quality level, at almost no added cost. 

Summary 
Many tools, formats, and viewers focus on individual parts of the 
problem of efficient 3D data transmission, but by only working on one 
part of the problem, they fail to create useful end‐user applications. Large 
3D models and scenes require a holistic approach for web optimization, 
including Decimation, Compression, and Streaming. By addressing all 
these technology needs, Strata Live 3D and the Meson viewing platform, 
together provide a comprehensive solution to make high‐fidelity 3D 
feasible in a web environment. 

Glossary of Terminology 

3D Acceleration – The majority of computer video cards come with 
some form of hardware based 3D acceleration. Typically, they run on the 
Open GL or Microsoftʹs Direct X based software drivers. The 
inconsistency of these hardware and software combinations has been one 
of the great challenges for web based 3D product and design 
visualization. This is why Strata Live 3D does not use 3D acceleration.

Algorithm – a recursive mathematical procedure. 

Alpha channel – an eight‐bit channel in the 32‐bit color image which is 
used to store transparency data.  

Alpha Fade – the ability to fade to a fully transparent surface using the 
alpha value for either the object or the material. 

Ambient Light – light that is present in the environment. It has no focus 
or direction. 

Antialiasing – a mechanism to prevent or remove the jagged appearance 
of diagonal lines or edges in an image. Antialiasing can be achieved in 
rendered images by averaging adjacent pixels with sharp variations in 
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color and brightness or by increasing the resolution of the image to meet 
or exceed the resolution of the device displaying or printing it. 

Applet – a small program written in Java and included in a HTML page. 
It is independent of the operating system on which it runs. See JAR in this 
Glossary below. 

Aspect Ratio – the relative width and height of the frame dimensions of 
an image. 

Backface – polygons are defined as having a front face and a backface. 
This information is used to determine which way the polygon is facing 
for purposes of lighting calculations and it can be used to eliminate the 
need to render one side of the polygon that may not be seen (such as the 
inside of a box) to improve display speed. 

Bitmap – also known as a pixel image. An image composed of pixels. 
May be any resolution or color depth. 

Bookmark – a bookmark is a combination of a script, and a time value, 
which together describe the state of several sequences, and possibly the 
camera. Bookmarks are used by the Sequences and Views palette to set all 
the sequences to their bookmarked values. 

CAD – an acronym that stands for Computer‐Aided Design. 

Color Depth – the number of bits required to define the color of each 
pixel in an image. Black and white images use one bit. Grayscale images 
use eight bits (256 shades of gray). Eight‐bit color images provide 256 
colors. Images with 24‐bits provide millions of colors (eight bits for each 
color: red, green, blue). Images with 32 bits provide an additional eight 
bits for alpha data. 

Database – the area of memory within the program while it is running 
that is set aside to keep track of objects within a model. 

Decimation – the process removing data to simplify and reduce the 
dataset. In Strata Live 3D, decimation can be done to polygon structures 
(Generate LOD) and object hierarchy. 

Default – a parameter or setting pre‐defined in the program which may 
be changed by the user. 

Diffuse Reflection – that component of the light reflecting from a 
surface caused by its dull or matte nature. Dull or matte surfaces reflect 
the light striking them in random angles over a large area, giving the 
surface an equally‐bright appearance from a wide range of viewing 
positions. 
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Dither – to blend transitions between colors by placing small dots of 
black, white, or other colors to simulate those colors that can’t be 
represented because of limits on the numbers of colors available.  

Extrusion – a method of creating a 3D object using a 2D template; giving 
depth to the 2D shape. 

Fade ‐ the ability to fade to a fully transparent surface using the alpha 
value for either the object or the material. This is the same definition as 
Alpha Fade above. 

File Compression – the process of reducing the amount of storage space 
used by a file. 

Group – a collection of objects that act as one. 

Heuristics – is a technique designed to solve a problem that ignores 
whether the solution can be proven to be correct, but which usually 
produces a good solution or solves a simpler problem that contains or 
intersects with the solution of the more complex problem. Used in Strata 
Live 3D to make “educated guesses” to assist in scripting, among other 
processes. 

Hex Numbers – a numeral system with a radix, or base, of 16. Usually 
written using the symbols 0–9 and A–F or a–f. Used in Strata Live 3D and 
web applications to define colors. Most color pickers, including 
Photoshop’s, provide translation between hex color values and RGB color 
values. 

Hue – the property of color which corresponds to the frequency or 
wavelength of the light. 

Java – a programming language developed by Sun Microsystems, 
expressly designed for use in the distributed environment of the Internet. 
It was designed to have the “look and feel” of the C++ language, but it is 
simpler to use than C++ and enforces an object‐oriented programming 
model. 

JAR – JAR is a standards based, platform‐independent format that 
aggregates many files into one. Multiple Java applets and their requisite 
components (class files and images for example) can be bundled in a JAR 
file and subsequently downloaded to a Browser in a single HTTP 
transaction, improving the download speed. The JAR format also 
supports ZIP style compression, which reduces the file size, further 
improving the download time. 
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JPEG – short for Joint Photographic Experts Group, a committee that has 
been developing a compression standard for still images. This term also 
refers to the compression method developed by that group. 

Lathing – a method of creating a 3D object by revolving a 2D profile 
about a designated axis. 

LOD – LOD is an acronym for Level Of Detail. In 3D work LOD typically 
stands for the ability to provide multiple levels of detail. Specifically, in 
Strata Live 3D this term is used to refer the process of making and using 
reduced polygon versions of the objects. 

Luminance – the amount of light radiated by a surface. It refers to 
intensity or brightness. 

Master Model – the native file format for Strata Live 3D. The file 
extension for Master Models is .XMM. For example, BallInBox.xmm. See 
XMM in this Glossary below. 

Material Fade – similar to Alpha Fade above, the ability to fade to a fully 
transparent surface using the alpha value of the material. 

Mesh Surface – a surface that has common vertex points between 
adjacent polygons. Mesh surfaces are typically used to define complex 
forms. The surface also provides smoothing information for the rendering 
algorithms. 

Meson – is the name of a suite of connected technologies which allow 
interactive applications with both 2D and 3D elements to be developed 
quickly, and with a very small execution footprint. Like “Java”, the name 
denotes a language, an object model of predefined classes, and a runtime 
execution environment. 

MIP-Mapping – pre‐scaled and optimized collections of bitmap images 
for a texture map, intended to increase rendering speed and reduce 
artifacts, such as Moiré patterns. They are widely used in 3D computer 
games, flight simulators and other 3D imaging systems. The letters “MIP” 
in the name are an acronym of the Latin phrase multum in parvo, 
meaning “much in a small space”. 

Moiré Pattern – a Moiré pattern is an interference pattern created, for 
example, when two grids are overlaid at an angle, or when they have 
slightly different mesh sizes. In a 3D scene these patterns can also appear 
when complex texture patterns diminish in size due to perspective or 
scale. Use MIP mapping to reduce this artifact. 
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Normals – the mathematical value that indicates the direction a surface is 
facing in 3D space. Normals may be attached to individual polygons or to 
the vertex points that define the polygons. 

Orthographic – a method of displaying objects in a view where parallel 
lines do not converge. 

Perspective – a depth cue available in Strata 3D in which parallel lines 
converge to align with a designated vanishing point. Perspective is a 
product of several parameters in the displayed view: Lens focal length, 
camera size, and distance from objects. 

Pixel – an acronym that stands for Picture Element. It is the smallest 
component which makes up the display on a computer monitor. Each dot 
on the screen is a pixel. Many images displayed on the screen are likewise 
stored in a pixel form that is mapped to the screen pixels for viewing. 

PNG – Like a GIF, PNG files (short for Portable Network Graphics) are 
compressed in lossless fashion (meaning all image information is restored 
when the file is decompressed during viewing). A PNG file is not 
intended to replace the JPEG format, which is ʺlossyʺ but lets the creator 
make a trade‐off between file size and image quality when the image is 
compressed. Typically, an image in a PNG file can be 10 to 30% more 
compressed than in a GIF format. PNG is the only format supported in 
Strata Live 3D that incorporates a separate channel for alpha transparency 
information. 

Polygon – a closed plane bounded by three or more line segments.   

Public and Private – Public objects in Strata Live 3D provide access to 
object‐level alpha fading. When fading a public object all of that objectʹs 
children are also faded. Private objects may only be individually faded 
using the material level alpha and/or by using an alpha channel imported 
with a texture map. Only PNG files are supported for alpha channel 
import. 

Reflectivity – the percentage of the total amount of light striking the 
surface that reflects from, or bounces off, the surface of the object. 

Refraction – the change in direction of light as it passes from one 
transparent material to another. This causes an apparent shift in the 
image showing through the transparent material. 

Rendering – a visual representation of the model. This is accomplished 
by combining a geometric model with descriptions of its surface 
properties, lighting, etc. to generate an image of the model. 
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Resolution – the number of pixels per unit. The higher the number of 
pixels, the higher the resolution, and the greater the capability to display 
details. 

RGB – a method of representing all colors as the combination of red, 
green, and blue light. 

Saturation – the extent to which a color is made purely or a particular 
hue; the vividness of the hue. 

Shading – the process of calculating how the light sources in your model 
will affect the color, value and highlights on the object surface. 

Shaders – the algorithm used to calculate shading. In Strata Live 3D you 
have the option of shading using Phong shading or using no shading at 
all (used for pre‐lit texture maps). 

Smoothing Groups – groups of polygons from which the surface normal 
smoothing calculation is made. These calculations determine which 
surfaces the renderer attempts to display as continuous, smooth surfaces 
– despite the fact that the surfaces are constructed from a series of flat 
polygon objects. 

Specular Reflection – that component of the light reflecting from a 
surface caused by its shiny or glossy nature. Shiny surfaces reflect light 
striking them in clearly defined angles of incidence; resulting in “hot 
spots” corresponding to the direction of the light sources providing the 
illumination. Can be thought of as actual reflections of the light sources 
themselves. 

Surface Mapping – a process in which an image is used to define an 
object’s surface properties. A separate map can be used to define and 
transparency. 

Texture Maps – images which are wrapped around the surface of an 
object. Texture maps in Strata Live 3D can be used to define color and/or 
transparency on a pixel by pixel basis. 

Tessellate – a technique used to manage datasets of polygons by 
dividing them into polygon structures for rendering. 

TIFF – short for Tagged‐Image File Format. This format was developed 
by Aldus® and Microsoft® to represent pixel‐based images, such as those 
produced by scanners. 

UV Mapping – the surface of a 3D object can be defined as a two‐
dimensional, “unwrapped” surface. This 2D map of the surface is then 
used to “map” or associate an image with the 3D surface. This is can also 
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be thought of as ʺwrappingʺ the image around the object. “U” represents 
the horizontal dimension of the unwrapped surface and “V” represents 
the vertical dimension. Both dimensions are measured from 0 to 1. 

Vertex – a point of intersection of two vectors or a point used to define a 
polygon. 

Vertices – the plural term for vertex. Defines two or more vertex points. 

Wavelet – is a form of data compression well suited for image 
compression. The goal is to store image data in as little space as possible 
in a file. A certain loss of quality is accepted, known as lossy compression. 
Using a wavelet transform, the wavelet compression methods are better 
at representing transients, such high‐frequency components in two‐
dimensional images, for example an image of stars on a night sky. This 
means that the transient elements of a data signal can be represented by a 
smaller amount of information than would be the case if some other 
transform, such as the more widespread discrete cosine transform, had 
been used. 

Waypoint – a collection of state information for objects and materials 
associated with a point within a sequence.  

Welding – a process of combining two or more vertices into one. Welding 
produces a more efficient data set by requiring only one set of position 
information for the combined verticies. 

Wireframe – a fundamental rendering method that represents 3D objects 
with connecting lines outlining the polygon edges. 

X-Axis – the horizontal axis which represents width. 

Y-Axis – the vertical axis which represents height. 

Z-Axis – the “in/out” axis which represents depth. 

XML – (Extensible Markup Language) is a W3C (World Wide Web 
Consortium) initiative that allows information and services to be encoded 
with meaningful structure and semantics that computers and humans can 
understand. Strata Live 3D uses this format to maintain an editable 
version of the Master Model (saved within the XMM file). 

XMM – the file extension used by Strata Live 3D for a natively saved 
Master Model file. At the outermost level, the Master Model format is 
identical to ZIP/JAR archive format, except that it uses the .XMM file 
extension. The key file in the XMM archive is a file called MASTER.XML. 
With the exception of textures, which must be included in the XMM using 
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a standard format (JPEG, PNG, GIF), the entire content of a model can be 
written into the XML format file. 

Trademarks, Copyrights and Legal Notices 

Copyright 
Software developed by Kaon Interactive, Inc. Portions Copyright © 2006 
Corastar, Inc., Copyright © 2002 ‐ 2006, Kaon Interactive, Inc. All rights 
reserved.  

No parts of this document, either in full or in part, may be reproduced or 
transmitted in any form or by any means without the prior written 
permission of the publisher.  

The ʺBlue Earthʺ Strata Live 3D identity illustration by John Barrie. 
Concept by Chris Filsell. All rights reserved. 

Limited portions may be copyright of the following licensors: 
Adobe Systems Incorporated 
Apple Computer Inc. 
Microsoft Inc. 
Sun Micro Systems Inc. 

Disclaimer 
While every precaution has been taken in the preparation of this 
document, the publisher assumes no responsibility for errors or 
omissions, or for damages resulting from the use of the information 
within this document. The publisher reserves the right to make any 
modification to this document, or to the contents of this document, at any 
time without notice.  

Limitations 
Except as permitted by license, no part of this User Guide may be 
reproduced, stored in a retrieval system, or transmitted in any form or by 
any means ‐ electronic, mechanical, or otherwise ‐ without prior written 
permission of Corastar, Inc. 

Files provided for various tutorial examples presented in this User Guide 
may also be protected under copyright law. The unauthorized use of such 
artwork or images in your projects could be a violation of the rights of the 



STRATA LIVE 3D User Guide 
Appendix 

153 

authors. Please be sure to obtain any permission required from such 
authors. 

Trademarks 
Strata, Live 3D, Foto 3D, Strata 3D, Strata 3D base, Strata 3D CX, Strata 3D 
pro , StudioPro, Strata DV, Strata FX, Vision3d, MediaPaint, and 
VideoShop are trademarks of Corastar, Inc., which may be registered in 
some jurisdictions. Adobe®, Adobe Photoshop®, Adobe Illustrator®, 
ATM®, and Adobe Acrobat® are trademarks of Adobe System 
Incorporated. Apple®, Macintosh®, Power Macintosh, QuickTime®, and 
QuickDraw 3D are trademarks of Apple Computer, Inc., registered in the 
United States and other countries. Windows® is a trademark of Microsoft 
Corporation. OpenGL is a registered trademark of Silicon Graphics, Inc. 
All other products or name brands are trademarks of their respective 
holders. 3ds max is a registered trademark of Autodesk, Inc. Jasc, and 
Paintshop Pro are registered trademarks of Jasc Software, Inc.  

For defense agencies, this product is subject to use, reproduction and 
disclosure restrictions as set forth in sub‐paragraph (c)(1)(ii) of the Right 
in Technical Data and Computer Software clause at 252.227‐7013. 

For civilian agencies, this product is subject to use, reproduction and 
disclosure restrictions set forth in sub‐paragraph (a) through (d) of the 
commercial Computer Software Restricted Rights clause at 52.227‐19 and 
the limitations set forth in Corastar, Inc.’s standard commercial license 
agreement included with this software. 

Unpublished rights reserved under copyright laws of the United States. 

Acknowledgments: The JPEG support software is based in part on the 
work of the Independent JPEG Group. 

All other trademarks and registered trademarks are trademarks or 
registered trademarks of their respective owner. 

LICENSE AGREEMENT  
This License Agreement (ʺAgreementʺ) is a legal agreement between 
Corastar, Inc. (ʺCorastarʺ) and you, the user of this Corastar software 
program (ʺSoftwareʺ).  You agree to be bound by the terms of this 
Agreement by installing, copying, or using the Software.  If you do not 
agree, do not install, copy, or use the Software. You understand that the 
Software is licensed to you, not sold, and that all right, title and interest in 
and to the Software remains vested in Corastar and its licensors. 
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The Software consists of two elements:  (a) a ʺContent Development 
Platform,ʺ which is used to develop visual content; and (b) a ʺContent 
Playerʺ, which is used to view applications containing visual content. 

Corastar grants you the following rights provided that you comply with 
all terms and conditions of this Agreement and that you make payment to 
Corastar of the applicable license fees for the Software This grant of 
license to you is non‐exclusive: 

You may: 

 (a) install the Software on one personal computer or other device (or on a 
network storage device, such as a server computer, and allow one access 
device, such as a personal computer, to access and use the Software over 
a private network); 

(b) physically transfer the program from one computer to another, 
provided the program is used on only one computer at a time; 

(c) use the Content Development Platform to develop visual content; 

(d) use the Content Player to view applications containing visual content; 
and 

(e) distribute the Content Player to end users of Your Applications solely 
for use with Your Applications,.  ʺYour Applicationsʺ means programs 
developed by You, where the primary purpose of the program is 
displaying visual content created by You (and not content created by end 
users of the program). 

2.2  You may not: 

(a) distribute the Content Development Platform to any third party; or  

(b) distribute the Content Player other than for use with Your 
Applications; or 

(c) distribute the Content Player as part of a program designed primarily 
to display visual content created by the end user. 

(d) use the Content Development Platform in any service bureau, 
timesharing or rental arrangement 
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(e) allow use of the Content Development Platform by any third party 
(except for reasonable use by third party service providers for the benefit 
of you, the licensee). 

3.  Corastar reserves all rights not expressly granted to you in this 
Agreement.  The Software is protected by copyright and other intellectual 
property laws and treaties. Corastar or its suppliers own the title, 
copyright, and other intellectual property rights in the Software.  The 
Software is licensed, not sold.  This Agreement does not grant you any 
rights to trademarks or service marks of Corastar or its licensors. 

 

4.  You may not reverse engineer, decompile, or disassemble the 
Software, except and only to the extent that such activity is expressly 
permitted by applicable law notwithstanding this limitation. You may not 
rent, lease or lend the Software, or make the functionality of the Software 
available as a hosted service. 

5.  Update Policy: In order to be able to obtain updates of the 
program you, the licensee, must complete and return the Registration 
Card included in the package to Corastar, Inc. or, in place of mailing in 
the physical registration card, register the Software at the Strata website. 
IF THIS SOFTWARE IS NOT REGISTERED WITH CORASTAR., 
CORASTAR, INC. IS UNDER NO OBLIGATION TO MAKE 
AVAILABLE TO YOU ANY UPDATES EVEN THOUGH YOU HAVE 
MADE PAYMENT OF THE APPLICABLE UPDATE FEE. 

6.  You acknowledge that the Software is subject to U.S. export 
jurisdiction.  You agree to comply with all applicable international and 
national laws that apply to the Software, including the U.S. Export 
Administration Regulations, as well as end‐user, end‐use, and destination 
restrictions issued by U.S. and other governments. 

7.  You may transfer your copy of the Software to two different 
computer devices – such as a home computer and an office computer. 
However, both machines must remain under your control and the 
licensed copy granted to you herein can only be used by you, and on one 
machine at a time. After the transfer, and in the event that you lose 
control of one of the devices (such as the sale of, or reassignment of, the 
computer device) you must completely remove the Software from that 
device.  However, you may not assign this Agreement without Corastarʹs 
prior written consent. 
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8.  Without prejudice to any other rights, Corastar may terminate 
this Agreement if you fail to comply with the terms and conditions of this 
Agreement. In such event, you must destroy all copies of the Software 
and all of its component parts. This license is effective until terminated. 
You may terminate it by destroying the program and documentation and 
all copies thereof. 

9.  Corastar and its suppliers provide the Software AS IS AND 
WITH ALL FAULTS, and hereby disclaim all warranties and conditions, 
whether express, implied or statutory, including, but not limited to, any 
(if any) implied warranties, duties or conditions of merchantability, of 
fitness for a particular purpose, of reliability or availability, of accuracy or 
completeness of responses, of results, of workmanlike effort, of lack of 
viruses, and of lack of negligence.  ALSO, THERE IS NO WARRANTY 
OR CONDITION OF TITLE, QUIET ENJOYMENT, QUIET POSSESSION, 
CORRESPONDENCE TO DESCRIPTION OR NON‐INFRINGEMENT 
WITH REGARD TO THE SOFTWARE. 

10.  TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE 
LAW, IN NO EVENT SHALL CORASTAR OR ITS SUPPLIERS BE 
LIABLE FOR ANY SPECIAL, INCIDENTAL, PUNITIVE, INDIRECT, OR 
CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING, BUT 
NOT LIMITED TO, DAMAGES FOR LOSS OF PROFITS OR 
CONFIDENTIAL OR OTHER INFORMATION, FOR BUSINESS 
INTERRUPTION, FOR PERSONAL INJURY, FOR LOSS OF PRIVACY, 
FOR FAILURE TO MEET ANY DUTY INCLUDING OF GOOD FAITH 
OR OF REASONABLE CARE, FOR NEGLIGENCE, AND FOR ANY 
OTHER PECUNIARY OR OTHER LOSS WHATSOEVER) ARISING OUT 
OF OR IN ANY WAY RELATED TO THE USE OF OR INABILITY TO 
USE THE SOFTWARE, THE PROVISION OF OR FAILURE TO PROVIDE 
SUPPORT OR OTHER SERVICES, INFORMATON, SOFTWARE, AND 
RELATED CONTENT THROUGH THE SOFTWARE OR OTHERWISE 
ARISING OUT OF THE USE OF THE SOFTWARE, OR OTHERWISE 
UNDER OR IN CONNECTION WITH ANY PROVISION OF THIS 
AGREEMENT, EVEN IN THE EVENT OF THE FAULT, TORT 
(INCLUDING NEGLIGENCE), MISREPRESENTATION, STRICT 
LIABILITY, BREACH OF CONTRACT OR BREACH OF WARRANTY OF 
CORASTAR OR ANY SUPPLIER, AND EVEN IF CORASTAR OR ANY 
SUPPLIER HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES. 

IN NO EVENT WILL COMPANY’S DIRECTORS, OFFICERS, 
EMPLOYEES, OR AGENTS (COLLECTIVELY ʺPERSONNELʺ) BE 
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LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL, OR 
INDIRECT DAMAGES (INCLUDING DAMAGES FOR LOSS OF 
BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS 
INFORMATION, AND THE LIKE) ARISING OUT OF THE USE OF, OR 
INABILITY TO USE, THE SOFTWARE EVEN IF THE PERSONNEL 
HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 
BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR 
LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL 
DAMAGES, THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU. 

IN NO EVENT WILL COMPANY’S LICENSOR(S), AND THEIR 
DIRECTORS, OFFICERS, EMPLOYEES, OR AGENTS (COLLECTIVELY 
ʺCOMPANY’S LICENSORʺ) BE LIABLE TO YOU FOR ANY 
CONSEQUENTIAL, INCIDENTAL, OR INDIRECT DAMAGES 
(INCLUDING DAMAGES FOR LOSS OF BUSINESS PROFITS, 
BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, 
AND THE LIKE) ARISING OUT OF THE USE OF, OR INABILITY TO 
USE, THE SOFTWARE EVEN IF COMPANY’S LICENSOR HAS BEEN 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE 
SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION 
OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, 
THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU. 

11.  Notwithstanding any damages that you might incur for any 
reason whatsoever (including, without limitation, all damages referenced 
herein and all direct or general damages in contract or anything else), the 
entire liability of Corastar and any of its suppliers under any provision of 
this Agreement and your exclusive remedy hereunder shall be limited to 
the amount actually paid by you for the Software.  The foregoing 
limitations, exclusions and disclaimers shall apply to the maximum extent 
permitted by applicable law, even if any remedy fails its essential 
purpose. 

12.  All Software provided to the U.S. Government pursuant to 
solicitations issued on or after December 1, 1995 is provided with the 
commercial license rights and restrictions described elsewhere herein.  All 
Software provided to the U.S. Government pursuant to solicitations 
issued prior to December 1, 1995 is provided with ʺRestricted Rightsʺ as 
provided for in FAR, 48 CFR 52.227‐14 (JUNE 1987) or DFAR, 48 CFR 
252.227‐7013 (OCT 1988), as applicable.  

13.  This Agreement is governed by the laws of the state of Utah, 
USA, except as to copyright and trademark matters, which are covered by 
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United States laws and international treaties. This License Agreement is 
deemed entered into at St. George, Utah. This License Agreement shall 
inure to the benefit of Corastar, Inc., its successors, administrators, heirs 
and assigns. This Agreement is the entire agreement between you and 
Corastar relating to the Software and supersedes all prior or 
contemporaneous oral or written communications, proposals and 
representations with respect to the Software or any other subject matter 
covered by this Agreement.  If any provision of this Agreement is held to 
be void, invalid, unenforceable or illegal, the other provisions shall 
continue in full force and effect. 
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